LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Blogs > catkin
User Name
Password

Notices

Rate this Entry

Thunderbird "hyperlinks don't open" fix

Posted 12-31-2012 at 05:45 AM by catkin
Updated 01-04-2013 at 01:27 AM by catkin

A new installation of Thunderbird did not open hyperlinks in incoming mails. After ~3 days of looking for a fix, I found it in AndrzejL's Re: Fixing Skype / Thunderbird / Google Earth connection with Firefox on PCLinuxOS-Forums. This is to publicise AndrzejL's technique because I had found it early in the search for a solution and dismissed it as similar to others and/or not closely related to the problem.

AIUI AndrzejL's technique applies when there are no entries for HTTP and HTTPS in Preferences -> Attachments -> Incoming. It is the default configuration and should make Thunderbird use the system default. When that is not working, the technique is essentially Preferences -> Advanced -> Config Editor then search for network.protocol-handler.warn-external.http and click both the HTTP and HTTPS items, changing them to True. Next, open mail(s) with both types of links, click one of each and browse to the desired browser executable, selecting "Remember my choice ..." if wanted.

FWIW, here's the history. In brief, I had looked hard for a solution ...
The most thorough debugging procedure found was support.mozillamessaging's Hyperlinks in Messages Not Working. I followed it religiously, including mozillazine's Standard diagnostic - Thunderbird. I then searched Mozilla's GetSatisfaction forum and found several related threads which had been solved by following the procedure I had already followed and a recent, closely related, unsolved thread. Still looking for a solution I followed mozillazine's Setting the browser that opens in Thunderbird - Linux

... before giving up and deciding to change to SeaMonkey mail. It opened links OK but in the SeaMonkey browser. While looking for how to configure SeaMonkey Mail to open links using another browser, I stumbled on AndrzejL's post again and tried it for thoroughness. Hey presto! It worked!

Versions:
Thunderbird 17.0
Xfce 4.10
Slackware64 14.0
Posted in Uncategorized
Views 413 Comments 0
« Prev     Main     Next »

  



All times are GMT -5. The time now is 11:08 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration