Share your knowledge at the LQ Wiki.
Go Back > Blogs > campanula
User Name


Currently updating my distro, so making a note of what I did for my own reference and to help anyone else.
Rate this Entry

lxde and sound

Posted 03-17-2012 at 05:11 PM by campanula

Decided to move to lxde due to repeatedly disappearing panel in xfce...

Now set up nicely... Transparent panels top and bottom with pretty wallpaper showing through and shortcuts that I like. Whilst I like a quite minimal view for my desktop, not really convinced I like the menu button with no text, and the only option is the location of the button logo. So I just modified it in GIMP to add 'Menu' next to the icon.

hmmm, the logout button doesn't work... That happened when I set up the laptop with Mint 11 LXDE too, and I solved it, but can't remember what I did... Now, the error message mentions xfce-session, so that's why it's not working, because it's linked to the wrong command... So where's the correct command? Something to do with *.desktop files in /usr/share/applications

lxde-logout.desktop is there, so what's wrong? Try
$ sudo leafpad /usr/share/applications/lxde-logout.desktop
The last line is the culprit: NoDisplay=true
Change to NoDisplay=false
then save and exit. Then it appeared in the 'Applications launch bar settings' so I could use it.

Next, does sound work? No...

Lots of searching around without much luck, then found forum discussion suggesting that Pulseaudio might be the problem. I've never been able to get the internal soundcard to work on this computer, but the USB headphones worked in the previous distro.

So, looking at the end of this forum discussion, I also did
$ leafpad /etc/modprobe.d/alsa-base.conf
The last two lines were:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
so I changed this to:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0

I have sound

I then installed and checked musescore, and found that as on my laptop, it was using 97% of CPU without doing anything, and was very sluggish. Had already solved that one on the laptop, so installed JACK audio server, make sure it's started before starting musescore, and change the I/O preferences on musescore to use JACK. Now it works fine!

Next, noticed that PCManFM wouldn't let me open a folder as root, so changed preferences>advanced>switch user command to: gksu %s
then it worked.

Couldn't face starting next section (changing fstab to mount data partition) so finished for the day.
Posted in Uncategorized
Views 1045 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 05:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration