LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

HP-2133: Ubuntu 18.04 LTS Upgrade Failed; Xubuntu 18.04 Clean Install Succeeded

Posted 06-14-2021 at 01:56 PM by flshope
Updated 06-14-2021 at 08:15 PM by flshope (correct typos)

I have a 2008 HP-2133 laptop machine running 32-bit Ubuntu 16.04. The machine has been running satisfactorily for several years, the only chronic glitch being a loss of speaker sound sometime after the 16.04 installation. Also, Unity no longer ran and I have been running Xfce. I have delayed upgrading to 18.04 because I have always had difficulties with OS upgrades as support for my hardware dwindled. Of course, 16.04 reached end of life in April 2021, meaning no further support for that version. Also, Ubuntu 18.04 will be the last LTS version for 32-bit i386 hardware.

I have gotten into the habit of keeping a record of the software installation before and after each OS upgrade. I do this with the terminal command:

PHP Code:
apt list --installed FILENAME.txt 
If you continue to read this story, you will see that this practice allowed me to really mess things up.

Ubuntu 18.04 Failed Upgrade

In early April I attempted a routine upgrade of Ubuntu from 16.04 LTS to 18.04 LTS. Before attempting the upgrade, I did live-DVD tests with Xubuntu 18.04 and Debian 10 using an external USB DVD drive. Both OSs ran -- eventually -- and were mostly functional. I did have difficulty getting internet access with the live DVDs; but I found that if I first booted to Ubuntu 16.04, verified internet access, and then did a warm restart with the DVD drive, the machine booted with internet access. To accomplish the 18.04 upgrade, I set up the machine with a direct wired connection to my internet modem. I ran the upgrade from the Software Updater within the desktop environment GUI Xfce 4.12 (i.e., not a clean install). The Software Updater did a routine update to bring all 16.04 packages up to the latest versions and then rebooted. After the reboot, the Software Updater offered to install the Ubuntu 18.04 upgrade. As a near perpetual newbie, I find Ubuntu's upgrade services a major advantage over, say, Debian. Debian requires doing upgrades from a terminal (not the package updater), and I have further found it dangerous to run Debian upgrades from anywhere but a virtual console (i.e., ctl-alt-Fx -- a tty). When the Ubuntu upgrade runs as expected, it is easy to do. You don't have to know much to get it done. Of course, very often it does not run as expected, particularly with slightly aged hardware.

So I clicked the Upgrade button provided by the Software Updater. Nothing happened. I have learned from many problematical OS upgrades to always open a separate terminal and run the top application during the upgrade. If the Updater window stops showing any activity for a long time (unfortunately all too often), top will show you whether the machine is in a crashed state. You could use the system monitor, but that brings its own GUI and eats up a lot of CPU time. After waiting 5-10 minutes with top showing that the updater was not running, I restarted the Software Updater and started the upgrade again. This time the upgrade started running and top showed a process it called "do-release". It downloaded about 3200 packages in about 40 minutes and then began installing the upgrades and showed a progress bar. It also activated a terminal button, which allowed opening a terminal to watch the install as it proceeded. At about 10 minutes into the install, I started seeing error messages about "setting locale failed". However, the install continued. Frequently, the progress bar would stop showing any change for 10s of minutes and sometimes the install splash would also stop for minutes at a time. After about 2 hours into the install, I started seeing 1000s of error messages scrolling through the splash. The progress bar remained at about 20 percent complete. At this point, about 3 hours into the upgrade, I made the (bad?) judgment call to kill the upgrade. I know the machine is slow -- the upgrade from 14.04 to 16.04 took 4.5 hours -- but I had never seen 1000s of error messages before this. Of course, when I rebooted, the machine would not boot and just appeared crashed with a blank screen. I judged my upgrade attempt a failure.

Xubuntu 18.04 Clean Install

However, I still had my recent experience of a successful live DVD test of Xubuntu 18.04. And I recalled reading often at LQ the opinion that a clean install will often cure a lot of problems. I set up the machine with an internet connection through my Linksys wireless access point (RJ-45 ethernet jack on the machine), which is my routine mode of using this machine. I booted from the Xubuntu 18.04 live DVD on an external drive. The boot took about 12 minutes to reach a stable desktop GUI. I verified internet access by opening a terminal and pinging amazon.com (Amazon always returns pings -- Ubuntu and Debian often do not). The installed desktop offered an icon to install Xubuntu 18.04 LTS, and I used this. The installer noted that the machine already contained an installation of Ubuntu 18.04.5. I chose to over-write that with Xubuntu. The installer set me up as a user with full administrative privileges. I noted on the top terminal screen that the installer was named install.py. The install was completed in about an hour.

Reboot and login were normal. The OS immediately put up a dialog box offering to install Ubuntu 20.04. I declined the offer. The software updater also offered to update 18.04 to the most current version. I declined that, too, preferring to check out the installation I already had. I immediately noted several issues:
- The screen resolution was set to 640 X 480 and the display manager offered no other alternatives.
- The external display would not activate.
- There was no sound through the internal speakers (same as 16.04).
- Wifi internet access did not appear to be active.
- The GRUB menu was not displayed at boot-up.
- There was no boot splash.

I tried a few standard operations to active the external display (FN+F2 and SUPER+p key sequences, which worked under 16.04), but the external display was not recognized. I did use Software and Updates to identify a proprietary driver for the the wifi card ("Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source") and install it. After reboot, wifi activated (blue light on front panel).

I also installed emacs, which I can't live without.

Xubuntu Screen Resolution Problem

First, I decided to let the Software Updater complete the update of 18.04.5 from the version I had on the install DVD (18.04.2). That took 5 hours to complete (the clean install only took one)! The update did not solve the screen resolution or external display problems.

Next, I activated the boot splash. This can be done by editing the GRUB configuration file at /etc/default/grub. Change the line

PHP Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 
to

PHP Code:
GRUB_CMDLINE_LINUX_DEFAULT="" 
Turn on display of the GRUB menu in the same file by changing

PHP Code:
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT
=
to

PHP Code:
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10 
To try to solve the screen resolution problem, I compared the software installation under Ubuntu 16.04.5 and Xubuntu 18.04.5. I immediately observed that 16.04 had bumblebee installed and 18.04 did not. So I very adroitly proceeded to install bumblebee. This not only installed bumblebee and all of the suggests and recommends, but it also removed many other video-related packages. Did this solve my screen resolution problem? It did not! In fact, the machine that had been at least minimally working now booted to a blank screen and promptly crashed. So obviously, the way to get back to a minimally working machine was to remove bumblebee, which I did. Did this restore my machine? It did not. The removal did not re-install all of the removed packages. Fortunately, I did at least have the sense to keep a copy of the bumblebee install script, which gave a list of everything both installed and removed. In particular, it listed one removed package xubuntu-desktop for which I could see from apt show xubuntu-desktop that, if installed, this package installation would include all removed packages. So I ran

PHP Code:
sudo apt install --install-suggests xubuntu-desktop 
This did restore the machine to the minimal level of operability before my ill-fated bumblebee install.

A week later, another internet search turned up the link:

https://askubuntu.com/questions/8068...solution-issue

which suggested installing xserver-xorg-video-openchrome, which I did. On reboot, the external display auto-activated. The external screen resolution was set to 1920 X 1080 and was controllable from the All Settings/Display function. The internal display was set to 1280 X 768, but the image did not fit on the screen. I have not yet diddled further with that since the external display is much larger and preferable for routine use. With this last development, I considered the machine restored to operability. I have not yet solved the problem of no sound, but will report anything further that I find.

I expect that this OS upgrade will keep the machine viable through 2023, but after that Ubuntu will no longer be a viable option because 18.04 is their last 32-bit i386 version.


Short machine hardware summary:
HP 2133 Mini-note PC
Purchase date: 2008
CPU: VIA C7-M Processor 1200MHz (32 bit, 1200 MHz)
RAM: 2 GiB
Display: VIA Technologies VGA CN896/VN896/P4M900, 9-inch diagonal
Wifi: Broadcom BCM4311 802.11a/b/g
Ethernet: Broadcom NetXtreme BCM5788 Gigabit Ethernet (1 Gbit/s)
Audio: VIA Technologies VT8237A/VT8251 HDA Controller
Hard disk: TOSHIBA MK1246GS (120 GB)
Desktop environment: Xfce 4.12
Hostname: HP2008
Posted in Uncategorized
Views 110 Comments 1
« Prev     Main     Next »
Total Comments 1

Comments

  1. Old Comment

    This computer is so old ...

    ... that it has its own Wikipedia page:

    https://en.wikipedia.org/wiki/HP_2133_Mini-Note_PC

    Posted 06-15-2021 at 07:46 PM by flshope flshope is offline
 

  



All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration