LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Blogs > beachboy2
User Name
Password

Notices


Rate this Entry

Contemplating building a new Linux PC? It’s time to Ryzen shine!

Posted 05-19-2020 at 08:46 AM by beachboy2
Updated 06-19-2020 at 03:06 AM by beachboy2

I am not a gamer and I usually use Intel processors, but since I had read such a lot of rave reviews about AMD’s Ryzen CPUs, I decided to give one a go.
I already had a spare Antec case with 2 fans, a Seasonic 430w PSU and an Intel SSD, so all I thought I needed (see below) was the CPU, RAM and a motherboard.

I chose the much-in-demand Ryzen 5 3400G with onboard Radeon RX Vega 11 graphics. Had I been a gamer I would have gone for a Ryzen 5 3600(X) or above, plus a separate graphics card. The costs just keep going northwards for gamers!

I did not fancy using the earlier Raven Ridge Ryzen 3 2200G or 5 2400G CPUs, because, unlike the Picasso 5 3400G, Phoronix had experienced bug problems with both of them in Linux:
https://www.phoronix.com/scan.php?pa...n5-3400g&num=1

It is possible that these bugs have now been ironed out with the advent of more recent Linux kernels. I was not taking that chance, plus the 5 3400G has the better Radeon RX Vega 11 graphics (compared to the 3 2200G).

These are the parts I used:
AMD Ryzen 5 3400G Processor with onboard Radeon RX Vega 11 graphics:
https://www.amazon.co.uk/AMD-Ryzen-3...tronics&sr=1-2

The included Wraith Prism cooler is a large chunk of finned aluminium with a very quiet fan. The CPU runs very cool at about 33°C.
EDIT The temperature has dropped to around 28°C since I altered the DRAM frequency from 2133 MHz (auto) to 2933 MHZ (manual) in order to match my memory's rating of 3000 MHz.

MSI B450 TOMAHAWK MAX Motherboard ATX, AM4:
https://www.amazon.co.uk/MSI-B450-TO...tronics&sr=1-2

Another item much in demand is this very good quality “AMD 3000 Ready” motherboard with 4 fan headers and 6 USB ports. No updating BIOS problems here. It works right out of the box and its manual is a model of clarity:
https://download.msi.com/archive/mnu.../E7C02v1.3.pdf

This is extremely helpful for novice builders and those who have not built a PC for many years.

Memory:
Corsair CMK16GX4M2B3000C15 Vengeance LPX 16 GB (2 x 8 GB) DDR4 3000 MHz C15 XMP 2.0 High Performance Desktop Memory Kit:
https://www.amazon.co.uk/Corsair-CMK.../dp/B0134EW7G8
Decent quality RAM.

The only fly in the ointment for Linux users is that this MSI B450 motherboard, in common with many other manufacturers, uses a Realtek 8111H Gigabit LAN controller.

**See UPDATE for REALTEK below.

I have found Realtek drivers to be a real pain with Linux, so I therefore decided to buy an Intel EXPI9301CTBLK PRO1000 Network Card CT PCIex:
https://www.amazon.co.uk/gp/product/...FNKJFJTRDRH2EZ

This Intel card has the necessary drivers in the Linux kernel and works perfectly out of the box.

As a test I installed Ubuntu MATE 20.04 (using standard kernel 5.4) whilst awaiting the new Linux Mint 20 which is due in June. It took about 7 minutes to install including the updates.

It booted up perfectly after installation and there was no need to use nomodeset.

The only two points I had to be careful with were with regard to cabling.

My old Antec case used a 1394 cable to the front USB 2.0 ports. This cable must NOT be connected to a recent motherboard’s USB header because it will fry the board! I taped it up out of the way.

The various coloured and white cables for the front panel connectors such as the Power LED etc, have white as (-) and colour as (+).

I am hugely impressed with this Ryzen 5 3400G CPU and the MSI B450 motherboard etc and I now await the arrival of Linux Mint MATE 20.

PS My required wattage was only 201w. This wattage calculator from Newegg is very useful:
https://www.newegg.com/tools/power-supply-calculator/

**UPDATE on Realtek 8111H

The Realtek 8111H does work (in Ubuntu 20.04 at least) but it uses driver r8169 which can lead to instability and slow connection speeds. This driver needs to be replaced with r8168.

I followed the manual way in this TuxByte guide:
https://tuxbyte.com/how-to-get-your-...updated-guide/

I initially tried the r8168-8.046.00.tar.gz from the direct download link. This did not work.
I then tried the r8168-8.048.02.tar.gz version from the mtorromeo link. This worked!

The r8168-8.046.00.tar.gz is dated August 2016, whereas the r8168-8.048.02.tar.gz version is dated April 2020.

Summary of the manual way:

• 1. Install dependencies:
Code:
sudo apt install build-essential linux-headers-$(uname -r)
• 2. Download the driver: Download the driver from the official Realtek homepage mirror provided by mtorromeo at GitHub:
https://github.com/mtorromeo/r8168

• 3. Blacklist the r8169 driver:
Code:
user@linux:~$ sudo sh -c 'echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf'
• 4. Untar the archive:
Code:
cd Desktop
(OR cd Downloads OR cd directory_where_i_downloaded_tarfile)

Code:
user@linux:~$ tar xfvz r8168-8.048.02.tar.gz
• 5. Compiling and installing the driver:
Code:
user@linux:~$ cd r8168-8.048.02
user@linux:~/r8168-8.048.02$ sudo ./autorun.sh
You can ignore the SSL error for now.

• 6. Check the driver: If everything was successful, you should see an output like this from lsmod:
Code:
user@linux:~/r8168-8.048.02$ lsmod | grep r8168
r8168                 491520  0
Now reboot and your Realtek 8111H should be using r8168 instead of r8169.
Posted in Uncategorized
Views 4187 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 04:13 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration