Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Bedrock Linux
User Name
Bedrock Linux This forum is for the discussion of Bedrock Linux.


  Search this Thread
Old 05-19-2018, 05:09 AM   #1
LQ Newbie
Registered: May 2018
Posts: 1

Rep: Reputation: Disabled
Issue with initramfs built by dracut on void linux

I am running bedrock linux with void linux as global and rootfs stratum and so far I do really love it.

But I still have an issue: My initramfs is built by dracut (default imageramfs build tool on void linux) and during the boot process of void (after selecting it from bedrocks menu) dracut claims that my rootfs (/) already is mounted. I can skip and bedrock boots without issue but none of my fstab mounts are mounted.

I think the problem is that dracut does mount the mounts either from /etc/fstab or /proc/..../mountinfo while booting from initrd. After this bedrock tries to mount it again because it's the globals/rootfs' fstab file.

Does anybody have similiar issues or even an idea how to solve this?
Old 05-20-2018, 05:51 PM   #2
Bedrock Linux Founder
Registered: Feb 2016
Distribution: Bedrock Linux
Posts: 169

Rep: Reputation: Disabled
Same question was posted on reddit here:

where I happened to see it first. Repeating the answer in case someone else comes across this thread:

I think the initrd is a red herring. On traditional distros, the initrd eventually hands off control to the init system which is responsible for things like mounting /etc/fstab. With Bedrock, the init selection menu is thrown between the two steps, but the initrd still isn't expected to mount /etc/fstab.

There's a (poorly documented - I really should fix that) known issue with the how the current release handles /etc/fstab, and that is my guess for your issue. When setting up, Bedrock makes some directories such as /home into a mount point. When the init system goes to mount /etc/fstab, it'll see there's pre-existing mounts at some of the expected locations (like /home) and instead of mounting over those (which is what Bedrock wants) it just skips them.

There's a couple work-arounds:
  • One relatively simple one is to use /bedrock/etc/fstab - Bedrock mounts that before /home is otherwise messed with, and so it shouldn't skip such directories. This is mounted by Bedrock's busybox and might not work for some more advanced features.
  • Another is to mount it with the mount command, e.g. mount /dev/sda2 /home. You could probably put such lines in /etc/rc.local. If done that way, it'll mount over the mount point instead of skipping it, which is what is desired here.

If you give those a try and they don't work let me know and we can debug further.

I've got various ideas to fix this properly so /etc/fstab just works like people expect, but they probably won't be in place until the upcoming release.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Void Linux gave itself to the void, Korora needs a long siesta -- life is hard for small distros LXer Syndicated Linux News 0 05-16-2018 09:50 AM
“Dracut Patcher generating initramfs error DaddyDee73 Linux - Virtualization and Cloud 0 08-06-2017 07:54 PM
pthread giving error: invalid conversion from ‘void* (*)(int*)’ to ‘void* (*)(void*)’ knobby67 Programming 4 05-05-2017 10:54 AM
Blacklist or ignore block device systemd target in dracut initramfs ACiD GRiM Linux - Kernel 0 08-27-2013 12:45 AM
problem wiht creating initrd (initramfs.img) file using dracut Crackel Linux - Kernel 0 10-26-2010 06:19 PM > Forums > Linux Forums > Linux - Distributions > Bedrock Linux

All times are GMT -5. The time now is 12:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration