-   Arch (
-   -   Wifi doesn't work (

Kubuntu 03-01-2011 03:14 PM

Wifi doesn't work

I installed Arch Linux yesterday.

Well, I've a Conceptronic c150ru, which lsusb is:


Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870 Wireless Adapter
so I followed this instructions:


The 2.6.31 kernel caused the rt2870 driver to conflict with other wireless modules. The fix in this thread says that you need to blacklist the rt2800usb rt2x00usb and rt2x00lib modules by modifying the MODULES array in /etc/rc.conf

Then, I've modified the /etc/rc.conf file in this way:

So, I've written this.


wlan_wlan0="wlan0 essid WLAN_92 key *************"
INTERFACES=(eth0 wlan0)

Where the asterisks are letters and numbers.

But wifi doesn't work. When I write iwconfig, this appears:


wlan0    Ralink STA  ESSID:"WLAN_92"  Nickname:"RT2870STA"
          Mode:Managed  Frequency=2.422 GHz  Access Point: 00:1A:2B:05:69:89 
          Bit Rate=54 Mb/s 
          RTS thr:off  Fragment thr:off
          Encryption key:off
          Link Quality=100/100  Signal level:-61 dBm  Noise level:-83 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

And at the start it says:


Starting network [BUSY]
...IFFLAGS: No such file or directory
...for wireless request "Set Encode" (0B2A) :
Set failed on device wlan0 ; Invalid argument.
Could not associate wlan0 - try increasing WIRELESS_TIMEOUT and check is WEP or has no security

Well, I think that it's all. If I haven't wifi, I can neither install anything nor update the system.

reed9 03-02-2011 08:32 AM

Try doing it by hand, report any error messages.

First let's unload and reload the module and capture anything weird with that from dmesg

(All of this as root)

ifconfig wlan0 down
modprobe -r rt2870sta
modprobe rt2970sta
depmod -a
dmesg | tail

Post the output of the last dmesg command

Now try to connect

iwconfig wlan0 essid "WLAN_92" key <wep hex key>
dhcpcd wlan0

When you installed the rt2870sta driver, did you use the package in the AUR?

Kubuntu 03-02-2011 08:42 AM

No, rt2870sta was already installed with the system.

I'll try using netcfg, I've heard that it has a lot of success.

Kubuntu 03-02-2011 01:55 PM

netcfg doesn't work.

It answers to me, when I write netcfg mynetwork:


:: wlan up        [BUSY]
Line 6: Invalid WEP key 0 '*************'.
Line 6: failed to parse wep_key0 '*************'.
Line 8: failed to parse network block.
Failed to read or parse configuration '/tmp/wpa.wlan0/wpa.conf'.
> wpa_supplicant did not start, possible configuration error

reed9 03-02-2011 02:48 PM

It appears something is wrong with your encryption key. Are you sure it's WEP and hex?

Kubuntu 03-02-2011 03:14 PM


Originally Posted by reed9 (Post 4276735)
It appears something is wrong with your encryption key. Are you sure it's WEP and hex?

Yes. But I don't know if it has case sensitive or not, because when I was with Windows, I put the letters in lower case or in upper case, and it worked.

In Arch I put the letters in lower case. I'll try to put them in upper case.

EDIT: I don't understand this. The same WEP key that doesn't work in Arch works in Mint and worked in Windows :S It hasn't case sensitive in Arch.

Kubuntu 03-02-2011 08:26 PM

I've written the WEP key as hex code, not as ascii code, so it didn't work. Now yes.


All times are GMT -5. The time now is 12:14 AM.