LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 04-02-2012, 12:24 PM   #1
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Rep: Reputation: Disabled
Trouble getting conky to work at startup with arch linux and gnome 3 installed


Hi
I installed conky today and i can get it to work by simply running this command:

Code:
sudo conky -c ~/.conky/conkyrc
It all works fine, but my problem is in making it run at startup.
I have read many forum posts saying to make an executable file and add it to my session under system>preferences>sessions. I do not have those menus! Do I have an incomplete install of gnome? What to do?
 
Old 04-03-2012, 04:58 AM   #2
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 48
Add an entry to gnome-session-properties. You can do this by hitting ALT-F2 and entering "gnome-session-properties". Create a new entry that points to whatever starts conky for you. When you reboot conky should start. If it doesn't have a look in .xsession errors for clues.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-gnome_session.png
Views:	363
Size:	44.9 KB
ID:	9374  
 
1 members found this post helpful.
Old 04-03-2012, 01:04 PM   #3
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
Thanks Glennzo, I did that, but the problem persists... It worked with some other things I wanted to run at startup, but not conky...
Besides that, I don't even have an ~/.xsession file. I looked into the ~/.xinitrc and added it in there. The remaining problem, I think, is that I have to delay the starting of the command.
 
Old 04-07-2012, 09:30 AM   #4
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
Code:
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

conky &
xscreensaver &
# exec gnome-session
# exec startkde
# exec startxfce4
exec fluxbox
this is how it works for me..but i wondering why you trying to start conky as sudoers like
Quote:
sudo conky -c ~/.conky/conkyrc
 
1 members found this post helpful.
Old 04-07-2012, 10:05 AM   #5
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
I don't know... It doesn't really make a difference, it doesn't work anyway. So that code you posted Raleeha, what do I do with it? I'm sorry, it seems that whanever I feel I'm comfortable with Linux, something new pops up
 
Old 04-08-2012, 05:50 AM   #6
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
hi

it's my .xinitrc .. inside i meant the command "conky &" to start at boot.. i don't know if your .xinitrc has same command

Last edited by raleeha; 04-08-2012 at 05:54 AM.
 
Old 04-08-2012, 11:55 AM   #7
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
Yeah... my .xinitrc is just
Code:
exec ck-launch-session gnome-session
 
Old 04-09-2012, 01:05 AM   #8
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
mh why not add
Code:
conky &
to your .xinitrc ?
 
Old 04-09-2012, 12:15 PM   #9
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
That didn't work either... I tried adding
Code:
conky &
and I also tried
Code:
conky -c ~/.conky/conkyrc &
But neither of them worked...
 
Old 04-09-2012, 11:47 PM   #10
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
hi,

mh how do you start the gnome environment? (with login manager or startx command)

p.s. http://http://www.youtube.com/watch?v=Mg_rRJcK9x0 maybe this helps
 
Old 04-10-2012, 02:24 AM   #11
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 48
Here's what works for me. Fedora, from about release 14 up to release 17. My conky configuration is in /etc/conky (/etc/conky/conky.conf). In my home folder is a file I've named .ck.sh. In .ck.sh is the following:
Code:
#!/bin/bash
# Startup script for conky
# Glenn A. Johnson - October 16, 2011
sleep 5
conky -c /etc/conky/conky.conf &
This .ck.sh file is called by adding it to the startup configuration using the method I'd mentioned previously, an entry in gnome-session-properties. As you can see .ck.sh calls /etc/conky/conky.conf. This works reliably for me.

What does your conky.conf look like? Can you post it here?
 
1 members found this post helpful.
Old 04-10-2012, 11:18 AM   #12
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
To raleeha:
I start it with the gdm login manager.

To Glennzo:
It's a big conky.conf file. I could post it, but I don't think that would be any use... I'll make my own .ck.sh file, with my own configuration and I'll give you the results.

:EDIT:
Here's my .ck.sh file:
Code:
#!/bin/bash
# Startup script for conky
# Iraj Eshghi - April 10, 2011
sleep 10
conky -c ~/.conky/conkyrc &

Last edited by ijiboom; 04-10-2012 at 11:23 AM.
 
Old 04-10-2012, 11:28 AM   #13
ijiboom
LQ Newbie
 
Registered: Mar 2012
Distribution: Fedora Linux
Posts: 21

Original Poster
Rep: Reputation: Disabled
OK thanks guys, that worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Arch Linux + GNOME not gnome3 nor gnome-shell demencia Linux - Newbie 6 05-13-2011 09:10 AM
[SOLVED] Conky on Startup CincinnatiKid Slackware 3 07-25-2010 12:30 PM
conky display isssue on Gnome desktop when initiated at startup sd|| Linux - Software 3 11-06-2009 05:21 PM
Installed Mandrake Linux 9.1... Gnome seems to work, but KDE refuses to load. swamiji Mandriva 4 11-28-2003 10:54 PM
Gnome startup fails (used to work) Pingo Linux - Newbie 4 03-03-2002 11:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration