LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 03-15-2005, 09:23 PM   #1
BobL
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10.0
Posts: 11

Rep: Reputation: 0
Angry Swap partition not activated...


Just switched to Arch from Mandrake and learned a good bit in the process. I used the downloadable boot iso ( the full one som 584 MB ) which I burned to a cd and proceeded to install it on the PIII box.

Followed the instructions ( I thought! ) and grub works fine, the system does boot, added a password for Root and a user and password for the user. Nice and straightforward.

The question is why does the swap partion not activate? Grub gives a big red "FAILED" when the machine boots. Other than that the machine boots fine, but I have yet to update it. So since this is probably a dumb noob question (SORRY! ) which file did I forget to add a line too? Maybe something as stupid as swapon -y or something as silly as that? In rc.conf I am thinking but all help is appreciated ( even the gently sarcastic type )

Thanks,

BobL
 
Old 03-15-2005, 10:39 PM   #2
muskrat
Member
 
Registered: Feb 2005
Location: Gulf-Coast TX-MX
Distribution: ArchLinux / Slackware 12.1
Posts: 39

Rep: Reputation: 15
Quote:
The question is why does the swap partion not activate? Grub gives a big red "FAILED" when the machine boots.
I'm not sure where you went wrong, but you must have enough memory or it wouldn't boot very well. As for Grub giving you an error I believe your mistaken.

Grub only loads the kernel from there all the text rolling by on the screen is linux it's self not grub. I don't think Grub even knows about the swap partion.
 
Old 03-15-2005, 10:43 PM   #3
vdogvictor
Member
 
Registered: Feb 2004
Distribution: Arch
Posts: 498

Rep: Reputation: 31
I am not sure what your problem is exactly, but I think what im gonna suggest will fix it.

First off run the command

mkswap /dev/hd??

then this

swapon /dev/hd??

if that works then there is no problem with your swap partition. If you want this to happen everytime the file /etc/fstab needs to have a line added to it. Or maybe the swap line needs to be edited.

note: replace /dev/hd?? with your swap partition device name.
 
Old 03-15-2005, 11:27 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 20,180

Rep: Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755Reputation: 3755
It's certainly not grub issuing the message. Post the following;
Code:
dmesg | grep swap
df
/etc/fstab
swapon -s
 
Old 03-16-2005, 06:31 PM   #5
BobL
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10.0
Posts: 11

Original Poster
Rep: Reputation: 0
Well,

Thanks for all the ideas, but I obviously f--cked up in the very simple instructions with the arch installer. Redid the machine, and even custom partitioned it and all works really well...so far. Ironically, the auto-prepare hard drive option is the original option I chose, which led to the message of swap not activated. When I customized its partions the swap file did indeed activate, at least it said it did!

Oh, Syg00 thanks for those commands, the listing that it spat out, was indicative that something was severely mucked up, as everthing was doubled. Everything now appears fine.

I must admit I am cautiously optimistic about this distro, I like it MUCH better than Mandrake. Not slamming Mandrake at all, I just like this one better.

Thanks again for all the ideas and help!

BobL
 
Old 03-17-2005, 07:08 PM   #6
zsurnz
LQ Newbie
 
Registered: Mar 2005
Distribution: Arch
Posts: 1

Rep: Reputation: 0
Hi,

I had the same problem with the swap partition when I installed Arch.

Quote:
Originally posted by BobL
Redid the machine, and even custom partitioned it and all works really well...so far. Ironically, the auto-prepare hard drive option is the original option I chose, which led to the message of swap not activated. When I customized its partions the swap file did indeed activate, at least it said it did!
For me I did not find any solution yet... Will do like you then.
However I had customized the partitions. First I though that maybe the failure to activate the swap was related to the fact that this swap has been made previously for Yoper and I want to share it between both distros.... But can't see why it should be so.

Maybe I should now rely on 'auto-prepare' instead to get the swap activated ;=)

When I run mkswap followed by swapon, the latter command replies that the partition is BUSY !?

Thanks for the posts, I find this forum and similar ones very helpful.

Quote:
Originally posted by BobL I like it MUCH better than Mandrake.[/B]
I agree with you, apart from this swap pb I'm very fond of Arch, especially for packages management and updates.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Swap partition paddyjoy Linux - Newbie 2 07-19-2005 08:17 PM
Swap partition Proud Linux - Hardware 5 03-23-2005 08:17 PM
No swap activated on kernel 2.6 gt73 Slackware 4 08-30-2004 07:51 AM
Newbie Installing Debian3 on m68k w/250M Partition Needs help creating swap partition AppleMac Linux - Newbie 2 11-01-2002 09:45 AM
Swap partition Thomas_Delrue Linux - Newbie 3 07-12-2001 09:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 01:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration