LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 02-27-2004, 02:57 PM   #1
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Rep: Reputation: 30
Sound in Arch 0.6


I'm trying to install sound on my Dell c610 laptop. I started with an FTP install and everything is working quite well, except my sound and pcmcia cards. First thing first, I'd like to get sound up and running. Grepping /proc/pci gives me this:

Code:
grep audio /proc/pci
Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio Controller (rev 2).
I have loaded everything alsa related, set the permissions, and alsaconf adds the driver listing in /etc/modprobe.conf. Ran alsaconfig and it tells me that eveything is setup, but up at the top of the screen I get this:

Code:
Loading driver...
/usr/sbin/alsaconf: line 619: rcalsasound: command not found
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1061: No soundcards found...
When I try to run Kaffeine in XFCE4 (the only WM I have), I get this:

Code:
kaffeine: Use audio driver auto
kaffeine: Use video driver auto
kaffeine: Init video driver
kaffeine: Init audio driver
audio_oss_out: opening audio device /dev/dsp failed:
No such file or directory
audio_esd_out: connecting to esd server...
/dev/dsp: No such file or directory
audio_esd_out: can't connect to <default> ESD server: Connection refused
I am too confused as to how to fix this. How can I resolve these issues? I can provide any info needed. I want to learn how to get this working as switching to my old Fedora Core is no longer an option.

TIA
 
Old 02-27-2004, 04:00 PM   #2
meldar
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
You need to load the right module into the kernel. I don't know which module you need for your sound card but I will guess something like snd-intel8x0
 
Old 02-27-2004, 04:35 PM   #3
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Original Poster
Rep: Reputation: 30
I can type:

Code:
modprobe snd-intel8x0
And it loads fine without any errors. I'm using a 2.6 kernel. Could that be an issue? I'm thinking that the rcalsasound error could be important. Any feedback?
 
Old 02-27-2004, 05:37 PM   #4
meldar
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
I looked on the alsaconf file. It searches for the alsasound initscript (rcalsasound) in /etc/init.d, /usr/sbin and /sbin. See if you have that file another place and copy it to one of the above places.

Try typing lsmod. What do you get? On my computer i get:
Code:
...
snd-emu10k1            73028   2
snd-rawmidi            13504   0 [snd-emu10k1]
snd-seq-device          4176   0 [snd-emu10k1 snd-rawmidi]
snd-pcm                62020   0 [snd-pcm-oss snd-emu10k1]
snd-timer              14500   0 [snd-pcm]
snd-util-mem            1408   0 [snd-emu10k1]
snd-page-alloc          6068   0 [snd-emu10k1 snd-pcm]
snd-ac97-codec         42712   0 [snd-emu10k1]
snd-hwdep               4640   0 [snd-emu10k1]
snd                    32900   1 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-rawmidi snd-seq-device snd-pcm snd-timer snd-util-mem snd-ac97-codec snd-hwdep]
soundcore               3748   8 [snd]
...
If you get something similar, it should work now that you have inserted the module to the kernel. Try to unmute the card and see if the file /dev/dsp exist. Then you just have to add snd-intel8x0 to /etc/modules.autoload.d/kernel-2.6 or something in that sort.
 
Old 02-27-2004, 07:28 PM   #5
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Original Poster
Rep: Reputation: 30
Hmmm,...I don't have rcalsasound anywhere on my system. Where can I find this file on the net or what package was supposed to set it up? Thanks.

In response to 'lsmod' I get this:

Code:
[ghight@intel1000 ghight]$ lsmod
Module                  Size  Used by
snd_intel8x0           31272  0
snd_ac97_codec         61444  1 snd_intel8x0
snd_pcm                92192  1 snd_intel8x0
snd_timer              23428  1 snd_pcm
gameport                4224  1 snd_intel8x0
snd_page_alloc          9860  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         7040  1 snd_intel8x0
snd_rawmidi            21280  1 snd_mpu401_uart
snd_seq_device          6920  1 snd_rawmidi
snd                    49124  7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8160  1 snd
3c59x                  36136  0
...yet still no sound. /dev/dsp also doesn't exist! Should it when using DEVFS?

Here is the top of my alsamixer which concerns me:

Code:
┌─────────────────────────────────────────[AlsaMixer v1.00 (Press Escape to quit)]─────────────────────────────────────────┐
│ Card: Intel 82801CA-ICH3                                                                                                 │
│ Chip: Cirrus Logic CS4205 rev 3,Silicon Laboratory Si3036/8 rev 1                                                        │
│ Item: Master [Off]
Why does Master say off even though I have the levels turn all the way up?

We are getting close, I can feel it. Thanks for you help!

Last edited by ghight; 02-27-2004 at 07:31 PM.
 
Old 02-27-2004, 08:26 PM   #6
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Original Poster
Rep: Reputation: 30
DAMN!!!

A simple press of the 'M' in alsamixer and BAM!,...SOUND!!

Thanks for all your help.
 
Old 02-29-2004, 09:44 AM   #7
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Original Poster
Rep: Reputation: 30
Well, version 2 here. I turned off my machine for the night and now today everything KDE related says "can't init audio driver [auto]". XMMS and none KDE related stuff work great!
 
Old 02-29-2004, 04:39 PM   #8
meldar
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
Ehm... Try to open kcontrol, and under "Sound System" select alsa or another system. Just a guess...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Arch linux have sound but not in games :S jkh Linux - Games 1 07-14-2005 07:03 AM
questions about sound in arch linux. greythorne Arch 2 06-27-2005 07:26 AM
No sound in Arch Linux, had same problem when upgrading to slack 10.1 landfill Linux - Hardware 11 06-25-2005 01:45 PM
Arch AGilley007 Arch 12 07-30-2004 02:27 PM
Arch .6? gsibble Arch 1 11-24-2003 09:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration