LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (https://www.linuxquestions.org/questions/arch-29/)
-   -   Sddm is being loaded very slow (https://www.linuxquestions.org/questions/arch-29/sddm-is-being-loaded-very-slow-4175642967/)

Sentih 11-24-2018 05:16 AM

Sddm is being loaded very slow
 
During boot I get something like this:
Code:

[  FLOAT] tpm_crb MSFT0101:00: can't request region for resource [mem 0xdd
[ OK ] ...
[  FLOAT] [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3

CPU: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G
GPU:
Code:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] [1002:98e4] (rev da) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Stoney [Radeon R2/R3/R4/R5 Graphics] [17aa:39f9]
        Flags: bus master, fast devsel, latency 0, IRQ 39
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=8M]
        I/O ports at 2000 [size=256]
        Memory at f0e00000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [270] Secondary PCI Express <?>
        Capabilities: [2b0] Address Translation Service (ATS)
        Capabilities: [2c0] Page Request Interface (PRI)
        Capabilities: [2d0] Process Address Space ID (PASID)
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

After one minute sddm starts and everythink works fine. But if I disable sddm.service, reboot and type systemctl start sddm results are immediate.
Second OS (Ubuntu, dual boot) has no such problem.

ondoho 11-25-2018 03:57 AM

as an archlinux user you should be able to provide better troubleshooting information.
please read the Advice links in my signature.

i would start with various systemd-analyze commands.


All times are GMT -5. The time now is 08:11 AM.