LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 09-17-2015, 07:15 PM   #1
herakles_14
Member
 
Registered: Sep 2010
Location: I currently reside in Glendale, AZ
Distribution: Manjaro, LinuxMint 17.2 & Mageia 5
Posts: 362

Rep: Reputation: 0
Question proxy server issues


Hey,

For the better part of ten days or thereabout I will periodically get an error message when I've been using Firefox. The message will either be:

"Secure Connection Failed

The connection to the server was reset while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."


or I will get this one:


"The connection was reset

The connection to the server was reset while the page was loading.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web."

It seems to be only when I am using Firefox do I get these messages. However when Firefox can't connect then Opera and Chrome don't connect either. I have been to the Firefox forum on Mozilla and found others have had these issue and tried some of the solutions offered, but none worked in the long run.

I tried using one of the other browsers, Opera for one, and as long as I was concentrating on one page it was okay. When I made the attempt to move to another page, I got a message about the server being unable to make a connection. Whatever the problem, it is not just with the Firefox browser, it extends to whichever browser is being used on Manjaro, and by that it extends to Manjaro itself. If my assumption is incorrect then point it out to me, and if you can tell me how to correct the issue?

I checked out the Firefox forum from Mozilla, and tried the solutions offered but they were only a temporarily fix.

In the time it has taken me to type this I expect, when I go to post it, to be on the receiving end of one of the error messages. Lucked in there.
 
Old 09-19-2015, 05:21 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,361
Blog Entries: 55

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
Note you haven't posted any relevant details wrt your network connection, since when this happens, any relevant syslog messages etc, etc you should. When you receive these messages perform some basic network tests. Here %{FQDN} means the website as in "(www.)website.addr.ess" without the protocol:// part or any /paths/. Ensure packages are installed prior to testing and if you need root privileges to execute prefix with 'sudo':
Code:
ifconfig -a; iwconfig -a
dmesg 2>&1 | egrep -ie "(netw|wireless|fatal|error|disabl|connect|drop|unreach|icmp)"
dig any %{FQDN}
tcptraceroute %{FQDN}
curl -v -I %{FQDN}
ping -c3 %{FQDN}
and scrub then post output in your reply.
 
Old 09-20-2015, 04:06 AM   #3
herakles_14
Member
 
Registered: Sep 2010
Location: I currently reside in Glendale, AZ
Distribution: Manjaro, LinuxMint 17.2 & Mageia 5
Posts: 362

Original Poster
Rep: Reputation: 0
Below is what came about;



"adates ~]$ ifconfig -a; iwconfig -a
enp5s8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.12 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::212:3fff:fe70:7c01 prefixlen 64 scopeid 0x20<link>
ether 00:12:3f:70:7c:01 txqueuelen 1000 (Ethernet)
RX packets 10631 bytes 2519550 (2.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 5273 bytes 1029249 (1005.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

-a No such device



[menelaos@Mithradates ~]$ dmesg 2>&1 | egrep -ie "(netw|wireless|fatal|error|disabl|connect|drop|unreach|icmp)"
[ 0.000000] NX (Execute Disable) protection: active
[ 0.000000] 2 disabled
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] ACPI: Early table checksum verification disabled
[ 0.246230] acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[ 0.251354] pci 0000:00:01.0: System wakeup disabled by ACPI
[ 0.252360] pci 0000:00:1c.0: System wakeup disabled by ACPI
[ 0.252845] pci 0000:00:1c.4: System wakeup disabled by ACPI
[ 0.253342] pci 0000:00:1c.5: System wakeup disabled by ACPI
[ 0.253812] pci 0000:00:1d.0: System wakeup disabled by ACPI
[ 0.254275] pci 0000:00:1d.1: System wakeup disabled by ACPI
[ 0.254740] pci 0000:00:1d.2: System wakeup disabled by ACPI
[ 0.255201] pci 0000:00:1d.3: System wakeup disabled by ACPI
[ 0.256143] pci 0000:00:1e.0: System wakeup disabled by ACPI
[ 0.258324] pci 0000:01:00.0: disabling ASPM on pre-1.1 PCIe device. You can enable it with 'pcie_aspm=force'
[ 0.274671] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 11 12 15) *0, disabled.
[ 0.333096] pci 0000:05:08.0: Firmware left e100 interrupts enabled; disabling
[ 0.543197] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
intel_rng: don't want to disable this in firmware setup, and if
[ 9.661890] iTCO_wdt: unable to reset NO_REBOOT flag, device disabled by hardware/BIOS
[ 10.154040] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[ 17.598856] Bluetooth: HCI device and connection manager initialized"
 
Old 09-20-2015, 04:31 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,361
Blog Entries: 55

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
Thanks but I said When you receive these messages then perform some basic network tests.
 
Old 09-20-2015, 01:32 PM   #5
herakles_14
Member
 
Registered: Sep 2010
Location: I currently reside in Glendale, AZ
Distribution: Manjaro, LinuxMint 17.2 & Mageia 5
Posts: 362

Original Poster
Rep: Reputation: 0
My mistake. Elaborate on the network tests.
 
Old 09-22-2015, 07:30 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,361
Blog Entries: 55

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
Quote:
Originally Posted by herakles_14 View Post
My mistake. Elaborate on the network tests.
No problem. 'dig' tells you if you have resolver problems, 'tcptraceroute' if you can reach the destination, 'curl' if you can read a (any) output at destination and 'ping' if you can, well, ping the destination. That said, if you are using a proxy provided by your (cellular?) Internet Service Provider you can also tcptraceroute and ping the proxy address and a 'curl -v -I %{FQDN} -x proxy_addressort' may reveal headers / whatever else interesting. If you're using / doing something else please list details.
 
Old 09-25-2015, 02:02 AM   #7
herakles_14
Member
 
Registered: Sep 2010
Location: I currently reside in Glendale, AZ
Distribution: Manjaro, LinuxMint 17.2 & Mageia 5
Posts: 362

Original Poster
Rep: Reputation: 0
unSpawn, I am afraid your elaboration went zipping over my head and into the ether.

The following was posted in 'Cup of Linux Forum':

"I do not believe the problem, if one wishes to call it such, does not lie totally with Firefo. You suggested using "Automatic Proxy Settings URL" I did not try you link, instead I enabled ZenMate, and for most of the twenty-ninth it seemed to be work more or less fine. When Firefox was opened fresh, there was the warning:
"Proxy Server, Refuses Connection"

A couple seconds pass and a new screen appears that of the theme (LavaFox V2. Purple) I am using for Firefox. This screen is up for roughly ten seconds, more or less, then the home page (https://manjaro.github.io) appears and I am good to go. If I am connected to Firefox but not actively using it, such as using LibreOffice Writer for several minutes and I open Firefox to check on something, there is strong probability I will be greeted with Proxy Server was Reset At this time thee screen does not change and I am compelled to reboot back to Manjaro.

When I happen to be using, say Opera, and am watching a YouTube video an it pauses where it shouldn't, I open a new tab and am greeted with: Proxy Server can not connect I close out of YouTube and Opera and open Firefox and I see:

"Secure Connection Failed"

The connection to the server was reset while the page was loading.
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."

Another instance was when I was on Chrome watching a program on Netflix and there was an interruption in the program, a pause, and when I open a new tab I get a 'proxy server can not connect' kind of notice, and this is while I am connected to Chrome and not Firefox.

In both instances I had to reboot to Manjaro.

Between the twenty-ninth and today that was how it was intermittently. A fair amount of the time when I switched from Chrome or Opera to Firefox, I would get Proxy Server, refuses connection but here the screen shows the theme then a few seconds go and Firefox is connected.

That I get such warnings and Proxy Server disconnects regardless whether I am using Firefox, Chrome or Opera, makes me wonder if the problem lies within Manjaro itself? Somewhere there is a Proxy Connection that is not connected, perhaps like in Firefox an 'Automatic Proxy Configuration URL'

Within Manjaro I have three Desktop Environments: Cinnamon, Mate, and LXQT in addition to the default DE, XFCE. Theoretically would I need to set the Automatic Proxy Configuration URL in each of the desktop environments, including xfce or would I only need to set it in xfce?

The Proxy Settings for both Chrome and Opera are set by an extension, which I can not find where or what it is?"

It would seem that using the "Automatic Proxy Settings URL" did help someiwhat, but I still have the issue with the Proxy Server.

Last edited by herakles_14; 10-04-2015 at 02:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hi i am new to proxy server concept please tell me the code how to make proxy server anilchowdary Linux - Newbie 2 05-28-2013 01:48 PM
Suid proxy server configuration issues in RHEL5 hiten801@gmail.com Linux - Server 4 01-07-2013 08:01 AM
hi, squid proxy server issues rajini23 Linux - Server 8 07-17-2012 03:52 AM
proxy server that accepts PARENT PROXY as a SOCKS PROXY shadyabhi Linux - Server 1 08-10-2010 04:09 PM
File and proxy server issues keith2045 Linux - Server 1 03-11-2007 02:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration