LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 06-29-2012, 05:00 PM   #1
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Rep: Reputation: Disabled
permissions maybe??


Yeah so after my install of Arch I became bored and started using Ubuntu again. I use my laptop for programming only. Ubunutu makes development super easy!

My other hard drive crapped out on me and I have decided to keep my Arch install on my other HD and install Ubuntu on a USB. So now I am going to build up my Arch box some more.

So, I have a question for the guru's here. I cannot use my terminal while I am logged in as a regular user. Whenever I try to click on the terminal icon, it just won't open.

I assume this is a permission issue? What could the issue/problem be? Thoughts and/or advice?

Last edited by amboxer21; 06-29-2012 at 05:31 PM.
 
Old 06-29-2012, 06:13 PM   #2
Slackyman
Member
 
Registered: Mar 2011
Location: Rome - Italy
Distribution: Slackware 13.1
Posts: 347

Rep: Reputation: 44
Maybe the execute flags?
Are you ruunning a GUI terminal like gnome-terminal or konsole?
If it's so try to check if you have permissions to run gnome-terminal or konsole with "ls -l" or maybe try to check the logs!
 
Old 06-29-2012, 06:59 PM   #3
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Slackyman View Post
Maybe the execute flags?
Are you ruunning a GUI terminal like gnome-terminal or konsole?
If it's so try to check if you have permissions to run gnome-terminal or konsole with "ls -l" or maybe try to check the logs!
Yes, I am running a UI via Gnome-Terminal. I logged into a tty console and logged in as regular user and found the gnome-terminal residing in /usr/bin/gnome-terminal. It had all of the proper permissions set. Oddly had an execute bit set for the other group. I removed it. I even opened the launcher options for the terminal on my cairo dock and added the gnome-term path to the command to run on click argument box. ...And nothing.

Let me scroll through the logs and see if I can find something.
 
Old 06-29-2012, 07:04 PM   #4
Slackyman
Member
 
Registered: Mar 2011
Location: Rome - Italy
Distribution: Slackware 13.1
Posts: 347

Rep: Reputation: 44
Try xtern and check the messages you fet running gnome-terminal from it!
 
1 members found this post helpful.
Old 06-29-2012, 07:20 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
Quote:
Originally Posted by amboxer21 View Post
It had all of the proper permissions set. Oddly had an execute bit set for the other group. I removed it.
Programs in /usr/bin are owned by root. If you remove the execute flag for "other" you remove the permissions for your user to execute it. Add the execute permissions for "other" and it will work again.
 
Old 06-29-2012, 07:21 PM   #6
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Slackyman View Post
Try xtern and check the messages you fet running gnome-terminal from it!
I found this in my auth logs
Code:
Jun 29 17:09:11 localhost dbus[399]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.30" (uid=1000 pid=702 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.5" (uid=0 pid=497 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Ill try xterm now. BRB.


I tried to run the gnome-shell from xterm and received this message:
Code:
Window manager warning: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.

Last edited by amboxer21; 06-29-2012 at 07:27 PM.
 
Old 06-29-2012, 07:29 PM   #7
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Programs in /usr/bin are owned by root. If you remove the execute flag for "other" you remove the permissions for your user to execute it. Add the execute permissions for "other" and it will work again.
I thought that all i needed were the root and user group bits, not the other. But i will change it back. Even still the problem existed before I changed the other user execution bits.
 
Old 06-29-2012, 07:33 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
Quote:
Originally Posted by amboxer21 View Post
I thought that all i needed were the root and user group bits, not the other.
It is quite logical: The programs in /usr/bin are owned by the user root and the group root. Since your user is not root and should not be a member of the group root, the user can only use what is allowed to be done by "Other".
Anyways, restore the permission and try to run it from xterm, as Slackyman suggested.
 
Old 06-29-2012, 07:35 PM   #9
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
It is quite logical: The programs in /usr/bin are owned by the user root and the group root. Since your user is not root and should not be a member of the group root, the user can only use what is allowed to be done by "Other".
Anyways, restore the permission and try to run it from xterm, as Slackyman suggested.
Oh, I didn't know that. Sorry and thanks for informing me! So, I changed the permissions back and I am still having the same problem(running from xterm). Still receiving the same error messages.
 
Old 06-29-2012, 07:36 PM   #10
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by Slackyman View Post
Try xtern and check the messages you fet running gnome-terminal from it!
Good idea!
 
Old 06-29-2012, 07:39 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
You shouldn't run gnome-shell, it is the GUI you use, not a terminal emulator. Try it with gnome-terminal (or something similar, I don't have Gnome installed, so I can't look for the correct name).
 
1 members found this post helpful.
Old 06-29-2012, 07:51 PM   #12
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
You shouldn't run gnome-shell, it is the GUI you use, not a terminal emulator. Try it with gnome-terminal (or something similar, I don't have Gnome installed, so I can't look for the correct name).
Makes sense! I tried running gnome-terminal from xterm and received this errer:
Code:
**
ERROR:terminal-app.c:1449:terminal_app_init: assertion failed: (app->default_profile_id != NULL)
I have no idea what that means.

UPDATE:
I removed and reinstalled the gnome-terminal and it fixed the issue. Wish I wold have done that initially instead of wasting yall time! I am sorry and really appreciate the help! Thank you guys!

Last edited by amboxer21; 06-29-2012 at 07:55 PM.
 
Old 06-29-2012, 07:58 PM   #13
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
There seems to be a problem with the configuration file. Move the configuration file (~/.gconf/gnome-terminal) to a different place, the log out and in again and test if the terminal starts.
 
Old 06-29-2012, 08:15 PM   #14
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Gentoo
Posts: 291

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
There seems to be a problem with the configuration file. Move the configuration file (~/.gconf/gnome-terminal) to a different place, the log out and in again and test if the terminal starts.
I dont think the moving of the conf file will make a difference now since the re-installation fixed the issue.

What concerns me is why would this problem exist anyway? Since my install, I have not touched anything relevant to the terminal. Wish I could have tried your suggestion before I removed and reinstalled. Sorry Tobi! Thanks again!

BTW, the file wasn't here --> ~/.gconf/gnome-terminal it was here --> ~/.gconf/apps/gnome-terminal/

Last edited by amboxer21; 06-29-2012 at 08:24 PM.
 
Old 06-29-2012, 09:08 PM   #15
Slackyman
Member
 
Registered: Mar 2011
Location: Rome - Italy
Distribution: Slackware 13.1
Posts: 347

Rep: Reputation: 44
Just want to say that's one of the WHY I don't like gnome: gconf-things are messy!
And I don't like Ubuntu (neither Debian) since they "customize" everything! I search for a cfg file where IT SHOULD BE, but it's in another position and maybe with another name, I search for a binary and it's in the wrong place!
Messy = wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
relation between programs permissions and permissions of the files they use rblampain Linux - Security 1 07-10-2011 08:40 PM
[SOLVED] filesystem permissions question - making so user can't change permissions? c0pe Linux - Security 4 07-12-2010 09:06 AM
[SOLVED] Lack basic understanding of permissions(apache permissions problem) cK` Linux - Newbie 7 04-08-2010 11:49 PM
File permissions v. directory permissions Completely Clueless Linux - Newbie 7 07-09-2009 08:33 AM
getting a directory's permissions and creating a new one with the same permissions newbie1000101 Programming 1 04-10-2004 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 01:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration