LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (https://www.linuxquestions.org/questions/arch-29/)
-   -   Pacman update including latest XOrg (https://www.linuxquestions.org/questions/arch-29/pacman-update-including-latest-xorg-457069/)

ethics 06-21-2006 07:45 PM

Pacman update including latest XOrg
 
Just a heads up peeps, i just did my daily update on pacman, which included xorg. Once i quit X and tried starting it again it was executing the xinitrc from /etc/X11/xinit/xinitrc NOT from my ~.

Further investigation showed that my ~/.xinitrc had been deleted with the upgrade, so i'd back it up if you have anything special or complicated in there :)

xpromisex 06-23-2006 09:25 AM

Thank you for the heads up. As a fellow Arch user, I appreciate it.

BobNutfield 06-23-2006 04:31 PM

Hi ethics...

Thanks for the heads up..I just checked the updates and there are 299MB worth of updates, including xorg-server-utils. Before I do the updates, how did you fix the problem you encountered getting X to work again?

By the way, I am still getting ¨anonymous login failed¨ on three of the repos, but none of the mirrors are commented out. I have current, extras, unstable and community enabled. Any ideas why this is happening? It doesn´t seem to matter because it still downloads and installs OK. Just annoying.

Bob

xpromisex 06-23-2006 05:27 PM

I get the same errors, Bob. They seem to not be doing anything, but they ARE annoying. Is anyone else having problems connecting to the ftp.archlinux.org mirror? I just commented it out, but I'd like to add the official repo back to my pacman, if you know what I mean.

ozar 06-23-2006 05:49 PM

I upgraded yesterday (right before the big update was issued) and didn't have any problems with xorg being upgraded. My .xinitrc file got through it with no problems.

However, I'm waiting a day or two before going with the big upgrade. Every time I don't wait a few days for the dust to clear, I end up wishing I had. ;)

BobNutfield 06-23-2006 05:51 PM

Well, as long as the updates work, I can endure. This update is really large. Also, it seems strange that this update includes the header files for kernel 2.6.12. Why would it suggest that as an update when my kernel is 2.6.16-ARCH? I have held off doing this update (which is from the current repo) until I investigate further. There seems to be at least 50 or so apps being upgraded. Don´t want to hose my long hard work getting Arch where I want it.

Bob

xpromisex 06-23-2006 07:51 PM

I updated this afternoon and, while not all of the items were sync'd, I haven't had a problem so far. I've had some problems with CPU scaling since 2.6.16 was introduced into current.

Ipsofacto 06-24-2006 02:33 AM

lol. I dont seem to have come out of the upgrade as unscathed as others.

My messenger client is broken (mercury) and so is Gdesklets. Not exactly world-shattering but annoying nonetheless. I tried reinstalling mercury and received the following error, and have included the gdesklets error

{links removed as expoired - see my post below}

Anyone wanna throw in their :twocents: ?

JunctaJuvant 06-25-2006 10:04 AM

Quote:

Originally Posted by Ipsofacto
... I tried reinstalling mercury and received the following error, and have included the gdesklets error

messenger

gdesklets

Anyone wanna throw in their :twocents: ?

I'm afraid these links give me 404 errors, which makes it rather difficult to diagnose the problem ;-)

Ipsofacto 06-25-2006 06:56 PM

@JunctaJuvant

Thanks the response. Apologies for the links, I just read the site and noticed that the links expire after 24 hours. Doh .....

As regards the problems the gdesklets now fine. I think the mirros werent fully synced when I run pacman -Syu. As regards Mercury then ive since found out that its a problem with Glib C, this from the AUR:

Quote:

Mercury will not function with Glibc2.4
Im now using gaim so no big deal. It was more of a case of wanting to know what was wrong, as opposed to the problems per se.

Thanks again.


All times are GMT -5. The time now is 08:44 AM.