-   Arch (
-   -   pacman error (

sharky 11-06-2004 05:58 PM

pacman error
Executed pacman -S and I get the following error.

config: line 26: syntax error

It was working until I attempted to upgrade pacman. I guess using pacman to upgrade pacman was a bad Idea.

Any ideas on what I can do now.


TheShemeta 11-07-2004 01:43 PM

actually pacman -S doesn't do anything. you need to run apcman -S foo (foo is for example the name of the program you want to install) or pacman -Syu to upgrade your system. try that.

running pacman -Q pacman will show you if you have pacman installed.

sharky 11-07-2004 09:54 PM

Actually I would still get the same error using pacman -S foo. As a matter of fact I got this error returned for any pacman command. I grabbed the tar.gz from archlinux ftp site and did the configure, make, make install thing. This almost fixed it except that the new pacman got installed into /usr/local/bin and the old corrupt version in /usr/bin was not touched. I removed the old version in /usr/bin and created a link point to /usr/local/bin.

That seemed to have fixed the issue.


TheShemeta 11-08-2004 04:45 AM

for installing pacman in /usr you had to do


./configure --prefix=/usr
but i am glad you got it solved. have fun now.

All times are GMT -5. The time now is 08:46 PM.