-   Arch (
-   -   "mawk" dependency missing in CD install (

lilsirecho 10-15-2003 10:52 PM

"mawk" dependency missing in CD install
:) Attempting to install arch-0.5...base package selected..install packages selected...pacman initial entry followed by error staement "mawk" dependency not on CD... abort install and connect to this forum:confused: :cry: :scratch:

The CD program is automatic such that the user cannot determine what is going on or what to do if error messages appear. An expert in the arch program is needed to answer the question what to do if "mawk" error message is displayed.

Downloaded the CD iso, recorded the CD and re-ran the install with same result when loading packages.

Examination of the CD in windows shows a package for "mawk" as a tar.gz in the CD contents.

Whazzup:confused: :mad: :cry: :scratch:

lilsirecho 10-18-2003 05:03 AM

Re-downloaded arch-0.5...attempted to load packages...same result...."mawk" not included in CD October 18, 2003

Rico16135 10-21-2003 02:22 PM

same problem here... i was told to try an ftp install, but am currently having problems configuring the proper module for my nic. But maybe you can get past where i can't... try it let me know btw its not just a mawk dependency issue, if you unselect autoconf, which has a dependency to mawk you just get another dependency warning altogether so something is very wrong with their cd.

lilsirecho 10-21-2003 02:37 PM

Many thanks for response...have since re-tried load of arch using auto-load steps with Lilo boot..get kernel panic with init. missing in kernel. No reason to panic, it's just our policy!!

I love work...I can sit and watch it all day!!!!

What next?

ferrix 10-21-2003 10:42 PM

Guys, I don't have the answer for you but I'd suggest posting about your problems on the actual arch forums at
I certainly didn't see any problems with mawk, or anything else for that matter, with my install of 0.5. But I downloaded my version a while back, perhaps there have been some changes in the iso...

Rico16135 10-22-2003 03:38 PM

well i visited the arch irc where i didn't get any help. some people tried, but to no avail. said screw it, (and believe me i gave it an ample amount of time) and reinstalled mandrake 9.1, and will wait for 9.2. I guess. I was just shocked to find out my beloved distro was manufactured by the french, and started looking around.. but maybe its not that big of a deal.

jlowell 10-25-2003 11:22 PM

One known cause of this problem is a user failure to select "DONE" at the bottom of the menu after partitioning and mounting file systems. It's easy to overlook, particularly if your drive has several partitions. You've got to scroll all the way down to the bottom to find it. The documentation available at the distro's website instructs users to take this step. I missed it the first time around and got the mawk message. The installation concludes that the initial steps aren't completed and reacts this way. So don't quit, certainly not for something as bloated as Mandrake. Read the instructions carefully and follow them closely as you install. Good luck!


Rico16135 10-26-2003 01:09 AM

ok, in an effort to eliminate my need for Mandrake, I will reformat, and try what you described above. I hope it works, but if it doesn't that's the last time I'm trying Arch. I'll let you know what happens. Thanks for the tip by the way.

jlowell 10-26-2003 11:14 AM


While I'm certainly pleased to learn that its your intention to attempt a reinstallation of Arch, I would hasten to reemphasize the other main point in my post: That the problem here is due, quite possibly, to user error. I would think that you'd owe yourself at least enough of an effort to ensure that that contingency is ruled out whatever your doing so may require. So if you are interested in learning about GNU/Linux at any deeper level than that offered by the Reddrakes and the Manhats - I know I didn't learn very much about Linux from them in the two years I worked with them - I encourage you to persist until you can, in conscience, lay your problem at Arch's doorstep. Do that one for Rico, eh?


All times are GMT -5. The time now is 09:10 AM.