LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 04-18-2015, 12:55 PM   #1
mcompton1973
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Rep: Reputation: 0
Manjaro Gnome update and add programs issues


I have been using Linux for years, but always as a pretty basic user. Not doing much on the cl etc.

I am interested in getting better at really KNOWING Linux. I want to use ARCH, but feel my skills are not there yet which drew me to Manjaro.

I installed it with Gnome and I can use it...I am having some issues with pacman apparently. I can not open add/remove programs app. When I try, the curser spins, like it is about to open, and then it just disappears, I am back where I was, and nothing has happened.

I have tried to update using sudo pacman -Syu and get this. i have tried all kinds of combinations of Y and N, and always the same...
Attached Thumbnails
Click image for larger version

Name:	ss.jpg
Views:	153
Size:	84.5 KB
ID:	18160  
 
Old 04-18-2015, 02:25 PM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Kubuntu 18.04, Manjaro, Win 10
Posts: 2,155

Rep: Reputation: 157Reputation: 157
You have to remove eiter mesa or mesa-dri, as displayed on the console.
 
Old 04-18-2015, 04:14 PM   #3
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,408
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
mcompton1973,

Quote:
I am interested in getting better at really KNOWING Linux. I want to use ARCH, but feel my skills are not there yet which drew me to Manjaro.
I felt the same as you and I recently bit the bullet and installed Arch from scratch on a spare PC.

I basically used Tutorial 1 and the two official Arch guides.

The author of Tutorial 1 has broken the article into several pages, like a book, so that you deal with just one step at a time without getting intimidated by a long page.

I found that very helpful and reassuring.

Tutorial 1:
http://www.linuxveda.com/2015/02/18/...ated-feb-2015/

Tutorial 2:
http://news.softpedia.com/news/A-Beg...x-352365.shtml

Arch Beginners' Guide:
https://wiki.archlinux.org/index.php/Beginners%27_guide

Arch Installation Guide:
https://wiki.archlinux.org/index.php/Installation_guide

You will learn nowhere near as much by installing Manjaro, Chakra, Archbang, Antergos, Bridge instead of Arch itself.

Have a read first and then give it a try.
 
Old 04-18-2015, 04:54 PM   #4
mcompton1973
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Geez....that was a dumb miss. This is what I am usually seeing.

[mrcomptonranch@MSCLaptop ~]$ sudo pacman -Syu
[sudo] password for mrcomptonranch:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
:: Replace lib32-mesa-dri with multilib/lib32-mesa? [Y/n] y
:: Replace libreoffice-still-calc with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-common with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-en-US with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-gnome with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-impress with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-math with extra/libreoffice-still? [Y/n] y
:: Replace libreoffice-still-writer with extra/libreoffice-still? [Y/n] y
:: Replace mesa-dri with extra/mesa? [Y/n] y
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency

Packages (475) accountsservice-0.6.40-1 alsa-firmware-1.0.29-1
alsa-lib-1.0.29-1 alsa-plugins-1.0.29-2 alsa-utils-1.0.29-1
apache-2.4.12-2 archlinux-keyring-20150212-1 automake-1.15-1
avahi-0.6.31-15 bash-4.3.033-1 binutils-2.25-2 bison-3.0.4-1
blueman-1.99.alpha2-1 bluez-5.30-1 bluez-libs-5.30-1
boost-libs-1.57.0-3 brltty-5.2-2 btrfs-progs-3.19-1
ca-certificates-20140923-9 ca-certificates-mozilla-3.18-3
ca-certificates-utils-20140923-9 cairo-1.14.2-1
cantarell-fonts-0.0.16-2 caribou-0.4.17-1 cifs-utils-6.4-1
ckbcomp-1.120-1 clutter-1.20.0-4 clutter-gst-2.0.14-1
cogl-1.20.0-1 colord-1.2.9-2 colord-gtk-0.1.26-2
cpupower-3.19-1 cups-2.0.2-3 cups-filters-1.0.67-1
curl-7.41.0-1 cython-0.22-2 dbus-1.8.16-2
device-mapper-2.02.116-1 dhclient-4.3.2-1 dhcpcd-6.8.1-1
dialog-1:1.2_20150225-1 ding-libs-0.4.0-3 djvulibre-3.5.27-1
e2fsprogs-1.42.12-2 ecryptfs-utils-106-1 elfutils-0.161-3
empathy-3.12.7-2 encfs-1.8-1 eog-3.14.3-1 ethtool-1:3.18-1
evince-3.14.2-1 evolution-3.12.11-1
evolution-data-server-3.12.11-1 exempi-2.2.2-1
farstream-0.2.7-1 ffmpeg-1:2.6.1-1 file-5.22-1
file-roller-3.14.2-2 filesystem-2015.02-1 firefox-37.0.1-1
flashplugin-11.2.202.451-1 folks-0.10.1-1
foomatic-db-3:20150308-1 foomatic-db-engine-3:20150308-1
foomatic-db-nonfree-3:20150308-1
freerdp-1:1.2.0_beta1+android9-1 freetype2-2.5.5-1
gcc-libs-multilib-4.9.2-4 gcc-multilib-4.9.2-4 gd-2.1.1-1
gdk-pixbuf2-2.31.3-1 gedit-3.14.3-1 gettext-0.19.4-1
ghostscript-9.16-1 giflib-5.1.1-1 git-2.3.5-1 gitg-3.15.1-1
glew-1.12.0-1 glib-networking-2.42.1-1 glib2-2.42.2-1
glibc-2.21-2 gmp-6.0.0-2 gnome-control-center-3.14.2-2
gnome-font-viewer-3.14.1-1 gnome-menus-3.13.3-1
gnome-music-3.14.3.1-1 gnome-online-accounts-3.14.3-1
gnome-shell-3.14.3-2 gnome-shell-extensions-3.14.3-1
gnupg-2.1.2-3 gnutls-3.3.14-2 gparted-0.22.0-1
gperftools-2.4-1 gpgme-1.5.3-1 gptfdisk-1.0.0-1 grep-2.21-2
groff-1.22.3-3 grub-2.02.beta2-9 gsfonts-20150122-1
gssdp-0.14.11-1 gssproxy-0.3.1-3 gst-libav-1.4.5-1
gst-plugins-bad-1.4.5-1 gst-plugins-base-1.4.5-1
gst-plugins-base-libs-1.4.5-1 gst-plugins-good-1.4.5-1
gst-plugins-ugly-1.4.5-2 gstreamer-1.4.5-1
gstreamer0.10-ugly-0.10.19-14
gstreamer0.10-ugly-plugins-0.10.19-14
gtk-update-icon-cache-2.24.27-1 gtk2-2.24.27-1 gtk3-3.14.9-1
gtksourceview3-3.14.3-1 gtkspell3-3.0.7-1 gufw-15.04.4-1
gummiboot-48-1 gupnp-0.20.13-1 gupnp-av-0.12.7-1
gvfs-1.22.3-2 gvfs-afc-1.22.3-2 gvfs-afp-1.22.3-2
gvfs-gphoto2-1.22.3-2 gvfs-mtp-1.22.3-2 gvfs-smb-1.22.3-2
harfbuzz-0.9.40-1 harfbuzz-icu-0.9.40-1 haveged-1.9.1-2
hplip-3.15.2-3 hwids-20150129-1 hwinfo-21.10.1.1-1
imagemagick-6.9.1.0-1 intel-ucode-20150121-1 inxi-2.2.19-1
iproute2-3.19.0-1 iptables-1.4.21-3 ipython-3.0.0-4
iso-codes-3.57-1 jasper-1.900.1-13 jre7-openjdk-7.u75_2.5.4-1
jre7-openjdk-headless-7.u75_2.5.4-1 kitemmodels-5.8.0-1
kmod-20-1 krb5-1.13.1-1 ldb-1.1.20-1 less-471-1
lib32-alsa-lib-1.0.29-1 lib32-alsa-plugins-1.0.29-2
lib32-cairo-1.14.2-1 lib32-colord-1.2.8-2 lib32-curl-7.41.0-1
lib32-elfutils-0.161-2 lib32-freetype2-2.5.5-1
lib32-gcc-libs-4.9.2-4 lib32-gdk-pixbuf2-2.31.3-1
lib32-glew-1.12.0-1 lib32-glib2-2.42.2-1 lib32-glibc-2.21-2
lib32-gnutls-3.3.13-1 lib32-gtk2-2.24.27-1
lib32-gtk3-3.14.9-1 lib32-harfbuzz-0.9.40-1
lib32-krb5-1.13.1-1 lib32-libcups-2.0.2-1
lib32-libcurl-gnutls-7.40.0-0 lib32-libdbus-1.8.16-1
lib32-libdrm-2.4.60-1 lib32-libgcrypt-1.6.3-1
lib32-libgpg-error-1.18-1 lib32-libgusb-0.2.4-2
lib32-libjpeg-turbo-1.4.0-1 lib32-libltdl-2.4.5-1
lib32-libpciaccess-0.13.3-1 lib32-libpng-1.6.16-1
lib32-libpng12-1.2.52-1 lib32-libpulse-6.0-1
lib32-libtasn1-4.3-1 lib32-libx11-1.6.3-1
lib32-libxdmcp-1.1.2-1 lib32-libxshmfence-1.2-1
lib32-libxxf86vm-1.1.4-1 lib32-llvm-libs-3.6.0-1
lib32-mesa-10.5.2-1 lib32-mesa-dri-10.3.5-1 [removal]
lib32-nspr-4.10.8-1 lib32-nss-3.18-1
lib32-nvidia-utils-346.47-1 lib32-openssl-1.0.2.a-1
lib32-p11-kit-0.23.1-1 lib32-speex-1.2rc2-1
lib32-speexdsp-1.2rc3-1 lib32-sqlite-3.8.8.3-1
lib32-systemd-218-1 lib32-tdb-1.3.4-1 lib32-wayland-1.7.0-1
lib32-xz-5.2.1-1 libass-0.12.1-1 libbluray-0.7.0-1
libcacard-2.2.1-2 libcanberra-0.30-5 libcanberra-pulse-0.30-5
libcdr-0.1.1-1 libcups-2.0.2-3 libdatrie-0.2.8-1
libdbus-1.8.16-2 libdc1394-2.2.3-1 libdmapsharing-2.9.30-1
libdnet-1.12-9 libdrm-2.4.60-2 libdvdnav-5.0.2-1
libdvdread-5.0.1-1 libedit-20141030_3.1-1 libetonyek-0.1.1-1
libevdev-1.4-1 libevent-2.0.22-1 libgcrypt-1.6.3-2
libgda-5.2.2-1 libgdiplus-3.12-1 libgee-0.16.1-1
libgit2-1:0.22.1-1 libgit2-glib-0.22.0-1 libgpg-error-1.18-1
libgphoto2-2.5.7-1 libgsf-1.14.32-1 libgsystem-2015.1-1
libgusb-0.2.4-1 libgweather-3.14.3-1 libibus-1.5.10-1
libical-1.0.1-2 libidn-1.30-1 libimobiledevice-1.2.0-1
libinput-0.13.0-1 libiscsi-1.13.0-1 libjpeg-turbo-1.4.0-1
libldap-2.4.40-2 libmariadbclient-10.0.17-2 libmbim-1.12.2-1
libmm-glib-1.4.6-1 libmpc-1.0.3-1 libmspub-0.1.2-1
libndp-1.4-1 libnewt-0.52.18-2 libnice-0.1.10-1
libnm-glib-1.0.0-2 libnm-gtk-1.0.0-1 libodfgen-0.1.3-1
libpciaccess-0.13.3-1 libplist-1.12-1 libpng-1.6.16-1
libproxy-0.4.11-5 libpulse-6.0-1 libqmi-1.12.6-1
libquvi-0.9.4-3 libquvi-scripts-0.9.20131130-2
libreoffice-still-4.3.6-2
libreoffice-still-calc-4.2.8-1 [removal]
libreoffice-still-common-4.2.8-1 [removal]
libreoffice-still-en-US-4.2.8-1 [removal]
libreoffice-still-gnome-4.2.8-1 [removal]
libreoffice-still-impress-4.2.8-1 [removal]
libreoffice-still-math-4.2.8-1 [removal]
libreoffice-still-writer-4.2.8-1 [removal] librevenge-0.0.2-1
librsvg-1:2.40.9-1 libseccomp-2.2.0-1 libsigc++-2.4.1-1
libsoup-2.48.1-1 libspiro-1:0.3.20150131-1 libssh-0.6.4-1
libsystemd-218-2 libtasn1-4.4-1 libteam-1.14-2
libthai-0.1.21-1 libtool-2.4.6-1 libtracker-sparql-1.2.5-1
libtxc_dxtn-1.0.1-6 libunistring-0.9.5-1 libunwind-1.1-2
libusbmuxd-1.0.10-1 libutil-linux-2.26.1-3 libva-1.5.0-1
libvdpau-1.1-1 libvisio-0.1.1-1 libwbclient-4.2.0-1
libwebp-0.4.3-1 libwpd-0.10.0-1 libwpg-0.3.0-1
libwps-0.3.1-1 libx11-1.6.3-1 libx264-2:144.20150223-1
libxdmcp-1.1.2-1 libxfont-1.5.1-1 libxshmfence-1.2-1
libxxf86vm-1.1.4-1 linux-api-headers-3.18.5-1
linux-firmware-20150206.17657c3-1 linux316-3.16.7.9-1
linux316-ndiswrapper-1.59-10 linux316-nvidia-346.47-2
llvm-libs-3.6.0-4 locale-info-2.21-2 logrotate-3.8.9-1
lua-5.2.4-1 lua-bitop-1.0.2-5 lua-expat-1.3.0-1
lua-socket-3.0rc1-4 lvm2-2.02.116-1 lz4-128-1 lzo-2.09-1
man-pages-3.82-1 manjaro-documentation-0.8.12-1
manjaro-keyring-20150204-1 manjaro-release-0.8.12-1
manjaro-settings-manager-0.4.9-1 manjaro-welcome-0.8.12-1
mesa-10.5.2-1 mesa-demos-8.2.0-4 mesa-dri-10.3.5-1 [removal]
mhwd-0.5.2-1 mhwd-catalyst-15.200-1 mhwd-db-0.5.2-1
mhwd-nvidia-346.47-1 mhwd-nvidia-340xx-340.76-1
modemmanager-1.4.6-1 mono-3.12.1-1 mpfr-3.1.2.p11-1
mpg123-1.22.0-1 mutter-3.14.3-3 nano-2.4.0-1 nbd-3.10-1
net-snmp-5.7.3-1 netctl-1.10-1 network-manager-applet-1.0.0-1
networkmanager-1.0.0-2 networkmanager-openconnect-1.0.0-1
networkmanager-openvpn-1.0.0-2 networkmanager-pptp-1.0.0-1
networkmanager-vpnc-1.0.0-1 nfs-utils-1.3.2-6
nilfs-utils-2.2.3-1 nspr-4.10.8-1 nss-3.18-3
nvidia-utils-346.47-1 openconnect-1:7.06-1 openresolv-3.6.1-1
openssl-1.0.2.a-1 orc-0.4.23-1 orca-3.14.3-1
os-prober-1.65-0.1 p11-kit-0.23.1-2 p7zip-9.38.1-1
package-query-1.5-1 pacman-mirrorlist-20150310-1
pamac-2.2.2-1 parted-3.2-2 patch-2.7.5-1 perl-5.20.2-1
perl-clone-0.37-2 perl-dbi-1.633-1 perl-error-0.17023-1
perl-xml-libxml-2.0118-3 perl-xml-namespacesupport-1.11-3
perl-xml-sax-0.99-4 perl-xml-sax-base-1.08-3 poppler-0.31.0-1
poppler-glib-0.31.0-1 postgresql-libs-9.4.1-1
procps-ng-3.3.10-2 pulseaudio-6.0-1 pv-1.6.0-1
py3parted-3.10.3-1 pyqt4-common-4.11.3-4 python-3.4.3-2
python-cairo-1.10.0-5 python-pycups-1.9.72-2
python-pycurl-7.19.5.1-2 python-requests-2.6.0-1
python-setuptools-1:15.0-1 python-six-1.9.0-1
python2-pybluez-0.20-3 python2-pyqt4-4.11.3-4
python2-sip-4.16.6-1 qt5-base-5.4.1-2 qt5-declarative-5.4.1-2
qt5-location-5.4.1-2 qt5-sensors-5.4.1-2
qt5-webchannel-5.4.1-2 qt5-webkit-5.4.1-2
qt5-xmlpatterns-5.4.1-2 randrproto-1.4.1-1 refind-efi-0.8.7-1
rpcbind-0.2.2-2 rtkit-0.11-5 s-nail-14.7.11-1 sdparm-1.09-1
seahorse-3.14.1-1 serf-1.3.8-1 shadow-4.2.1-3
shared-color-targets-0.1.5-1 shared-mime-info-1.4-1
sip-4.16.6-1 slang-2.3.0-1 smartmontools-6.3-2
smbclient-4.2.0-1 spandsp-0.0.6-1 speex-1.2rc2-1
speexdsp-1.2rc3-1 sqlite-3.8.8.3-1 subversion-1.8.13-1
sudo-1.8.13-1 syslinux-6.03-3 system-config-printer-1.5.6-1
systemd-218-2 systemd-sysvcompat-218-2 tcl-8.6.4-1
tcpdump-4.7.3-1 tdb-1.3.4-1 telepathy-farstream-0.6.2-2
telepathy-glib-0.24.1-1 telepathy-logger-0.8.1-1
telepathy-mission-control-5.16.3-1 tevent-0.9.24-1 tlp-0.7-2
totem-3.14.2-1 totem-plparser-3.10.4-1 tracker-1.2.5-1
ttf-dejavu-2.34-2 ttf-inconsolata-20090215-5
ttf-indic-otf-0.2-8 ttf-khmer-5.0-5 ttf-liberation-2.00.1-5
ttf-tlwg-0.6.1-2 tzdata-2015b-1 udisks2-2.1.5-1
unrar-1:5.2.6-1 unzip-6.0-10 upower-0.99.2-2
uriparser-0.8.1-1 usb_modeswitch-2.2.1-1 usbmuxd-1.1.0-2
usbredir-0.7-1 util-linux-2.26.1-3 v4l-utils-1.6.2-1
vala-0.26.2-1 vde2-2.3.2-7 vpnc-0.5.3.svn550-1
wayland-1.7.0-1 webkit2gtk-2.6.5-1 webkitgtk-2.4.8-1
webkitgtk2-2.4.8-1 wget-1.16.3-1 which-2.21-1 whois-5.2.7-1
wildmidi-0.3.8-1 x265-1.5-1 xdg-utils-1.1.0.git20150323-1
xf86-input-evdev-2.9.2-1 xf86-input-synaptics-1.8.2-1
xf86-input-wacom-0.29.0-1 xkeyboard-config-2.14-1
xorg-bdftopcf-1.0.5-1 xorg-font-util-1.3.1-1
xorg-fonts-misc-1.0.3-3 xorg-iceauth-1.0.7-1
xorg-mkfontscale-1.1.2-1 xorg-server-1.17.1-4
xorg-server-common-1.17.1-4 xorg-sessreg-1.1.0-1
xorg-xinit-1.3.4-2 xproto-7.0.27-1 xz-5.2.1-1 yaourt-1.5-1.3
zip-3.0-6 zita-alsa-pcmi-0.2.0-2 zita-resampler-1.3.0-3

Total Download Size: 10.93 MiB
Total Installed Size: 3385.81 MiB
Net Upgrade Size: 189.49 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
lzo-2.09-1-x86_64 79.4 KiB 105K/s 00:01 [#####################] 100
dhcpcd-6.8.1-1-x86_64 142.8 KiB 118K/s 00:01 [#####################] 100%
syslinux-6.03-3-x86_64 1501.0 KiB 123K/s 00:12 [#####################] 100%
alsa-firmware-1.0.2... 3.5 MiB 131K/s 00:28 [#####################] 100%
alsa-lib-1.0.29-1-x... 407.5 KiB 133K/s 00:03 [#####################] 100%
alsa-plugins-1.0.29... 60.8 KiB 53.0K/s 00:01 [#####################] 100%
alsa-utils-1.0.29-1... 928.1 KiB 170K/s 00:05 [#####################] 100%
apache-2.4.12-2-x86_64 1309.1 KiB 111K/s 00:12 [#####################] 100%
libgee-0.16.1-1-x86_64 240.2 KiB 89.2K/s 00:03 [#####################] 100%
dhclient-4.3.2-1-x86_64 663.5 KiB 89.6K/s 00:07 [#####################] 100%
v4l-utils-1.6.2-1-x... 603.7 KiB 92.0K/s 00:07 [#####################] 100%
ethtool-1:3.18-1-x86_64 83.8 KiB 53.8K/s 00:02 [#####################] 100%
vala-0.26.2-1-x86_64 1565.3 KiB 92.2K/s 00:17 [#####################] 100%
(466/466) checking keys in keyring [#####################] 100%
(466/466) checking package integrity [#####################] 100%
error: alsa-firmware: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-firmware-1.0.29-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: alsa-lib: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-lib-1.0.29-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: alsa-plugins: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-plugins-1.0.29-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: alsa-utils: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-utils-1.0.29-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: apache: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/apache-2.4.12-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: lzo: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/lzo-2.09-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: libgee: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/libgee-0.16.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: dhclient: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/dhclient-4.3.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: dhcpcd: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/dhcpcd-6.8.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: v4l-utils: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/v4l-utils-1.6.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: ethtool: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/ethtool-1:3.18-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: syslinux: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/syslinux-6.03-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: vala: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/vala-0.26.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[mrcomptonranch@MSCLaptop ~]$
 
Old 04-18-2015, 05:46 PM   #5
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Firstly, check the system time is set correctly; those error messages may be the result of an incorrect clock.

If the system time is correct, try this:
Code:
# pacman-key --refresh-keys
If that doesn't work, use this:
Code:
# rm -r /etc/pacman.d/gnupg
# pacman-key --init
# pacman-key --populate archlinux
Finally, you could try removing any stale packages and run the update again.
Code:
# rm /var/cache/pacman/pkg/badpackage*
I would personally advise against following any guides that are not on the official Arch site -- they tend to be outdated and/or error-ridden and may omit important details.

Also, please use code tags when posting terminal output, like this:
[code]terminal output here[/code]
 
Old 04-19-2015, 04:50 AM   #6
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,408
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
Quote:
I would personally advise against following any guides that are not on the official Arch site -- they tend to be outdated and/or error-ridden and may omit important details.

In general I would agree with you but in the case of Tutorial 1, Swapnil updates this every month.

The feedback to his tutorial is overwhelmingly positive and the less intimidating layout encourages Linux users who want to know more about their systems to dip their toes in Arch's water.

In my case I also referred to both official Arch guides.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't update Manjaro 0.8.8 Chriscrof Linux - Desktop 8 05-22-2014 05:35 AM
Fedora 12 add/remove programs issues divijvaidya13 Linux - Newbie 2 02-18-2010 02:28 AM
Gusty - Can't update, add/remove programs, syn...etc SonicStream Ubuntu 3 05-07-2008 06:58 PM
Manually add programs into the Gnome Application Browser in 10.2 Hawky SUSE / openSUSE 2 02-22-2007 06:23 PM
canot update add/remove programs sources vzzt! Linux - Newbie 3 02-27-2003 08:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 11:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration