LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 08-23-2011, 10:24 PM   #1
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Rep: Reputation: 47
Logging out... But can't get back to GUI without rebooting


I'm running Arch and have everything running perfectly (with the exception of my Dell V515W all-in-one printer and log out, log back in to the GUI.

What can I do so that in my Gnome session (I use fallback mode), when I log out, I can log back in without rebooting?

I have tried pkill x and many other things. What is the magic command (I am using slim as my login manager)?

Last edited by kasl33; 08-23-2011 at 10:24 PM. Reason: typo
 
Old 08-24-2011, 01:07 AM   #2
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: Arch + X.org + IceWM
Posts: 1,193

Rep: Reputation: Disabled
Maybe
Code:
sudo /etc/rc.d/gdm start
?
 
Old 08-24-2011, 12:34 PM   #3
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
Well, it's actually slim that I'm using - not gdm. However, regardless, the problem lies within Xorg somewhere. Here are some details of the problem:

I log out of the GUI and, instead of bringing up SLIM again, it leaves me to login at the command prompt:

Code:
Fatal Error: no screens found

xinit: giving up
xinit: unable to connect to x server: Connection refused
xinit: Server Error

------------------

kris@localhost$ sudo rc.d restart slim
Stopping Simple Login Manager                [FAILED] (probably because it is already stopped
Starting Simple Login Mangaer                  [DONE]

------------------

startx then fails again (or sudo rc.d start slim as well) and I get the same errors as listed above.

Last edited by kasl33; 08-24-2011 at 01:04 PM.
 
Old 08-24-2011, 06:04 PM   #4
dodgefan
Member
 
Registered: Apr 2008
Location: Kannapolis NC USA
Distribution: Debian, Mint, Arch
Posts: 32

Rep: Reputation: 0
have you tried going right to runlevel 5?

edit /etc/inittab and comment out the line for runlevel 3 and uncomment the line for runlevel 5

Code:
#id:3:initdefault:
id:5:initdefault:
and also uncomment the line to start Slim

Code:
x:5:respawn:/usr/bin/slim >& /dev/null
 
Old 08-24-2011, 06:43 PM   #5
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
Question

Quote:
Originally Posted by dodgefan View Post
have you tried going right to runlevel 5?

edit /etc/inittab and comment out the line for runlevel 3 and uncomment the line for runlevel 5

Code:
#id:3:initdefault:
id:5:initdefault:
and also uncomment the line to start Slim

Code:
x:5:respawn:/usr/bin/slim >& /dev/null
Yep. Tried those too. Just tried them again and had no luck. I typically ignore the /etc/inittab file during setup and just ad slim to the DAEMONS array in /etc/rc.conf. I wonder if this could be a bug in X?
 
Old 08-24-2011, 08:44 PM   #6
dodgefan
Member
 
Registered: Apr 2008
Location: Kannapolis NC USA
Distribution: Debian, Mint, Arch
Posts: 32

Rep: Reputation: 0
and slim is the last item in the daemons list?

that is weird, i'll have to try that when i get home. im using xfce, but i do use slim. i'll load it from rc.conf and see if i can get the same result
 
Old 08-25-2011, 07:34 PM   #7
dodgefan
Member
 
Registered: Apr 2008
Location: Kannapolis NC USA
Distribution: Debian, Mint, Arch
Posts: 32

Rep: Reputation: 0
no go, i loaded slim as a daemon with runlevel set at 3. slim loads fine, i can log into xfce and when i logout, it takes me to the slim login screen
 
Old 09-01-2011, 12:05 PM   #8
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
Sorry for the long delay. I went camping for the weekend in the mountains.

Anyway, I have the runlevel 3 option uncommented (and slim commented out below) in the /etc/inittab file. I also have slim listed as the last to load in the daemons array.

I wonder if it could be some kind of bug with video drivers or something. It's as if X doesn't properly shut down. Even if I run pkill x or other commands.
 
Old 09-06-2011, 01:58 PM   #9
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
I'm still stuck on this. Does anybody else have any good ideas?
 
Old 09-07-2011, 10:31 AM   #10
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Quote:
Originally Posted by kasl_33 View Post
Anyway, I have the runlevel 3 option uncommented (and slim commented out below) in the /etc/inittab file. I also have slim listed as the last to load in the daemons array
If you speak of the daemons array in the /etc/rc.conf file, you cannot use together the inittab file and the rc.conf file to start slim at boot. You need to choose one or the other, but not both of them.
 
Old 09-07-2011, 12:52 PM   #11
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
That's not it either. I removed slim from rc.conf and only have runlevel 5 and slim uncommented in /etc/inittab
 
Old 09-17-2011, 02:23 PM   #12
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 350

Original Poster
Rep: Reputation: 47
Update: I believe this might be an error with the Nvidia drivers. I decided to play with Archbang the other day and had the exact same issue. Even now, with stock Arch on here and no login manager, it still happens. Runlevel 3 is the only thing not commented in the /etc/inittab file and startx is my command for starting x. When I logout, I always have to reboot before I can log back into a GUI environment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I export the display back to get a GUI interface after logging in via SSH dslinkard Linux - Newbie 1 07-02-2010 02:12 PM
[SOLVED] Logging in sends me back to Xubuntu login screen.. I'm trapped!! drTronic Linux - General 3 02-17-2010 10:23 PM
gui read out of back end command lines from gui front end activation? how? Siljrath Linux - General 0 10-24-2008 10:11 AM
Mouse action reverts when logging back on tetpt Linux - Newbie 1 01-12-2006 10:44 AM
My entire GUI crashed - rebooting does not help... paul.nel Red Hat 1 11-18-2004 05:20 AM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration