-   Arch (
-   -   I installed Arch! (

ArchIsGood 05-24-2004 12:43 PM

I installed Arch!
Hi everybody,

I'm a new archer, and I will be sticking around! Been dabbling in linux for years, but no distribution was exactly what I was looking for.

Anyway - for anyone using a Logitech Optical Mouse via USB, make sure to add OHCI-HCD to your modules list in rc.conf - it helps a lot ;)

I have a few questions, obviously because I'm a relative n00b ;)

When I boot up, I see a message about EHCI - from what I understand, OHCI-HCD is to support USB 1.x and EHCI is for USB 2.0 (which my board does support - Asus A7N8X) - but I can't modprobe ehci or ehci-hcd ... tried a locate -u, locate ehci and didn't find much help there either. Maybe I need to play with it more... any pointers?

A few other issues:

1. I did a pacman -Ss gnome and for some reason I never saw a package just named gnome - maybe I'm blind, but I ended up syncing a gnome-desktop, which clearly was not everything I needed :) so - do "pacman -S gnome" you new archers!

Lets see.. next.. I feel like I kinda hacked this into working and its not exactly what I was looking for - when I installed gnome, of course, doing startx did not bring up gnome, so I'm assuming there is some exec SOMETHINGHERE command I need to put in my ~/.xinitrc - for KDE its exec startkde .. what is it for gnome? What I ended up doing was just setting up GDM to start on init 3 (init 5 doesn't seem to get triggered on startup?) and when you login via GDM, it kicks you into gnome ... and I want to know how to do it if I didn't use GDM :)

After that - the /etc/X11/xinit/xinitrc file - is this only triggered when the user doesn't have an xinitrc file in their home directory, or is it triggered BEFORE the home xinitrc is sourced, or after, or what? I'm a bit confused - I did edit out the exec terms that were in this file immediately following install though.

Thats all I have at the moment - on a side note, I did mention my A7N8X board (non-deluxe) and I was able to get the onboard ethernet working by modprobing for "forcedeth" - it worked perfectly after that - I love this community!

A little help here? :)

zeppelin 05-26-2004 07:46 AM

hello ArchIsGood,

I'm not sure what kernel you have. do see if it's a module (M) or built-in (Y)
cat /boot/kconfig26 | grep USB | less

then replace 2.6.6 with yours:
cd /lib/modules/2.6.6/kernel
find . -iname *.ko

gnome is a group of packages. maybe you also want gnome-extra ? (pacman -S gnome-extra)

in ~/.xinitrc

exec gnome-session


equinox 05-30-2004 07:28 AM

why doesn't init 5 get triggered?

zeppelin 05-30-2004 09:55 AM

just make 3 --> 5
in /etc/inittab

All times are GMT -5. The time now is 08:07 PM.