LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 01-01-2017, 03:43 AM   #1
ShaunXenon
LQ Newbie
 
Registered: Jan 2017
Posts: 6

Rep: Reputation: Disabled
gnome DE neither starting from . xinitrc(root user) nor from systemctl enable gdm.service


Gnome desktop environment was installed using command pacman -S gnome, pacman -S gnome-extra gnome-tweak-tools. Every packages were installed correctly but gnome is no starting. I don't like display managers so I added this line "exec gnome-session" in my .xinitrc file of root( I always use the root account) and then "startx" command which gives me error "xinit can't connect to Xserver " and just fails to start. I checked the log files but nothing important there. I also tried by running command "systemctl enable gdm.service" and "reboot" but it just get stuck at "[OK] Reached Target Graphical Interface" and nothing happens then. I also have two other desktop environment "lxde,kde" which starts normally from .xinitrc when I uncomment lines "start kde" and "start lxde" respectively and "startx" . I searched a lot to start gnome DE in my case, but found nothing. Also checked the version by "pacman -Qi" everything seems up to date. Thanks in advance
 
Old 01-01-2017, 09:19 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,025
Blog Entries: 7

Rep: Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777
Quote:
Originally Posted by ShaunXenon View Post
Gnome desktop environment was installed using command pacman -S gnome, pacman -S gnome-extra gnome-tweak-tools. Every packages were installed correctly but gnome is no starting. I don't like display managers so I added this line "exec gnome-session" in my .xinitrc file of root( I always use the root account) and then "startx" command which gives me error "xinit can't connect to Xserver " and just fails to start.
right.
so you heard the warnings, but decided to ignore them and run a graphical interface as root.
and now you're expecting somebody else to help because it doesn't work.

Quote:
I checked the log files but nothing important there.
which log files, what did you "check" for and how did you decide what is important?

Quote:
I also tried by running command "systemctl enable gdm.service"
gdm is a display manager, and you just said you don't use them?

Quote:
I searched a lot to start gnome DE in my case, but found nothing.
what did you search for?
and you found nothing? maybe your internet connection isn't working?

PS:
what did wiki.archlinux.org tell you?
 
Old 01-01-2017, 11:31 AM   #3
ShaunXenon
LQ Newbie
 
Registered: Jan 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
I checked Xorg.0.log , Xorg.1.log file(2 files for two sessions) and found "xinit: connection to X server lost" while rest are regular normal logs, and also compared with old ones ie Xorg.0.log.old, just the above mentioned line is added.

I tried enabling gdm.service bcoz gnome-session was not starting up from .xinitrc, and I don't use any display manager.

In the meanwhile, I also tried to execute gnome.desktop file from /use/share/xsessions dir. which gives this error "Trace/breakpoint trap(core dumped)" as a display manager always starts .desktop file (like lxde.desktop)
In Ubuntu forums, in a thread, a guy said there may be compatibility issues with gnome, hence downgrade it or the gnome binary not working properly. I am waiting for better solution.

I am trying my best and also hoping for a smart experienced person to solve this.

And I throughly searched wiki.archlinux.org but was unable to find the solution, that starts the gnome de.
 
Old 01-03-2017, 04:55 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,025
Blog Entries: 7

Rep: Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777
you aren't telling us anything that would enable us to help you.

anyhow...
Quote:
Originally Posted by ShaunXenon View Post
In Ubuntu forums, in a thread, a guy said...
but you are using archlinux?

i'd say you're in way over your head.

save important data and reinstall - preferably ubuntu or linux mint.
stick to the defaults until yu learn some more about linux.
and don't be root.
 
Old 01-07-2017, 10:05 AM   #6
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,080

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Hey ShaunXenon,

I realize that ondoho and teckk have already commented on this, but using the root account may be part of your problem. Besides all the security-related reasons not to habitually use the root account, it is possible that many packages may expect to be run by a non-root user and store certain settings according to these expectations. This is a bit of a guess, but I don't have anything else to add. I CAN tell you that I have a multi-DE setup on one of my Arch laptops (LXDE, XFCE and Gnome) and all 3 function as expected .. I DO however use a display manager (in my case lxdm) which simplifies the issue. Could you explain your reluctance to use a display manager to start your DE ?

Cheers,

Last edited by Rickkkk; 01-07-2017 at 10:08 AM.
 
Old 01-07-2017, 10:44 AM   #7
FredGSanford
Senior Member
 
Registered: Nov 2005
Location: USA
Distribution: Mageia Cauldron - VoidLinux - Devuan
Posts: 1,098
Blog Entries: 5

Rep: Reputation: 181Reputation: 181
Have you tried creating a non-root user and see if gnome will start? Just a thought!
 
Old 01-07-2017, 12:35 PM   #8
ShaunXenon
LQ Newbie
 
Registered: Jan 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks for reply,

Initially, I tried starting gnome as normal user, but that failed. After reading from some arch threads, many users solve their problems by running cmd "exec gnome-session"(or including in .xinitrc) as root so I tried that, that also failed, generating the error "bin bash crashed / Trace/breakpoint trap(core dumped) ". I wnat to inform that I ussually works as normal user.

The commands "exec startkde or exec startlxde" works properly.

As per suggestion, I also tried strating gnome from lxdm, didnt worked. The same login screen comes-up after loading for some-time. While KDE PLASMA and LXDE starts-up normally.

I already have searched related wiki.archlinux.org pages, found nothing relevant to my problem and when googled, found a ubuntu thread with a similar problem, they said to downgrade the gnome, as there may be compatibilty issue, I am waiting for better solution and have nothing to do with ubuntu.

Extremely appreciates Rickkk's "Multi-DE" setup and want to do the same (KDE,LXDE,GNOME) as I previously worked on kali, liked the gnome gui

I am posting my Xorg.0.log file, generated after insertion of "exec gnome-session" in .xinitrc, which gives the output "xinit failed to connect to XServer" error, as described earlier,
the last 23 lines in log files are suspicious for failure:

[ 112.787]
X.Org X Server 1.18.1
Release Date: 2016-02-08
[ 112.789] X Protocol Version 11, Revision 0
[ 112.789] Build Operating System: Linux 4.2.5-1-ARCH x86_64
[ 112.790] Current Operating System: Linux shaun 4.4.1-2-ARCH #1 SMP PREEMPT Wed Feb 3 13:12:33 UTC 2016 x86_64
[ 112.790] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=f39e9d27-8165-d101-a010-91278165d101 rw quiet
[ 112.792] Build Date: 11 February 2016 09:57:03AM
[ 112.792]
[ 112.793] Current version of pixman: 0.34.0
[ 112.795] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 112.795] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 112.798] (==) Log file: "/home/xenon/.local/share/xorg/Xorg.0.log", Time: Sat Jan 7 22:36:21 2017
[ 112.878] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 112.879] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 112.915] (==) No Layout section. Using the first Screen section.
[ 112.920] (==) No screen section available. Using defaults.
[ 112.920] (**) |-->Screen "Default Screen Section" (0)
[ 112.920] (**) | |-->Monitor "<default monitor>"
[ 112.921] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 112.921] (==) Automatically adding devices
[ 112.921] (==) Automatically enabling devices
[ 112.921] (==) Automatically adding GPU devices
[ 112.921] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 112.990] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 112.990] Entry deleted from font path.
[ 112.990] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 112.990] Entry deleted from font path.
[ 112.990] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 112.991] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 112.991] Entry deleted from font path.
[ 112.991] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 112.991] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/
[ 112.991] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 112.991] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 112.991] (II) Loader magic: 0x81ad60
[ 112.991] (II) Module ABI versions:
[ 112.991] X.Org ANSI C Emulation: 0.4
[ 112.991] X.Org Video Driver: 20.0
[ 112.991] X.Org XInput driver : 22.1
[ 112.991] X.Org Server Extension : 9.0
[ 112.993] (++) using VT number 1

[ 112.993] (--) controlling tty is VT number 1, auto-enabling KeepTty
[ 112.996] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[ 112.997] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 112.997] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[ 112.999] (--) PCI:*(0:0:2:0) 8086:0166:1028:0558 rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[ 112.999] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 112.999] (II) LoadModule: "glx"
[ 113.010] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 113.151] (II) Module glx: vendor="X.Org Foundation"
[ 113.151] compiled for 1.18.1, module version = 1.0.0
[ 113.151] ABI class: X.Org Server Extension, version 9.0
[ 113.151] (==) AIGLX enabled
[ 113.151] (==) Matched intel as autoconfigured driver 0
[ 113.151] (==) Matched intel as autoconfigured driver 1
[ 113.151] (==) Matched modesetting as autoconfigured driver 2
[ 113.151] (==) Matched fbdev as autoconfigured driver 3
[ 113.151] (==) Matched vesa as autoconfigured driver 4
[ 113.151] (==) Assigned the driver to the xf86ConfigLayout
[ 113.151] (II) LoadModule: "intel"
[ 113.152] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 113.195] (II) Module intel: vendor="X.Org Foundation"
[ 113.195] compiled for 1.18.0, module version = 2.99.917
[ 113.195] Module class: X.Org Video Driver
[ 113.195] ABI class: X.Org Video Driver, version 20.0
[ 113.195] (II) LoadModule: "modesetting"
[ 113.196] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 113.197] (II) Module modesetting: vendor="X.Org Foundation"
[ 113.197] compiled for 1.18.1, module version = 1.18.1
[ 113.197] Module class: X.Org Video Driver
[ 113.197] ABI class: X.Org Video Driver, version 20.0
[ 113.197] (II) LoadModule: "fbdev"
[ 113.197] (WW) Warning, couldn't open module fbdev
[ 113.197] (II) UnloadModule: "fbdev"
[ 113.197] (II) Unloading fbdev
[ 113.197] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 113.197] (II) LoadModule: "vesa"
[ 113.197] (WW) Warning, couldn't open module vesa
[ 113.197] (II) UnloadModule: "vesa"
[ 113.198] (II) Unloading vesa
[ 113.198] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 113.198] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 113.198] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[ 113.198] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[ 113.198] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[ 113.198] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 113.198] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[ 113.215] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20151010
[ 113.215] (II) intel(0): SNA compiled from 2.99.917-519-g8229390
[ 113.218] (WW) Falling back to old probe method for modesetting
[ 113.218] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 113.220] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000
[ 113.220] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx; using a maximum of 2 threads
[ 113.220] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 113.220] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 113.220] (==) intel(0): RGB weight 888
[ 113.220] (==) intel(0): Default visual is TrueColor
[ 113.220] (II) intel(0): Output LVDS1 has no monitor section
[ 113.240] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output LVDS1
[ 113.240] (II) intel(0): Enabled output LVDS1
[ 113.240] (II) intel(0): Output VGA1 has no monitor section
[ 113.240] (II) intel(0): Enabled output VGA1
[ 113.240] (II) intel(0): Output HDMI1 has no monitor section
[ 113.240] (II) intel(0): Enabled output HDMI1
[ 113.240] (II) intel(0): Output DP1 has no monitor section
[ 113.240] (II) intel(0): Enabled output DP1
[ 113.240] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[ 113.240] (II) intel(0): Output VIRTUAL1 has no monitor section
[ 113.240] (II) intel(0): Enabled output VIRTUAL1
[ 113.240] (--) intel(0): Output LVDS1 using initial mode 1366x768 on pipe 0
[ 113.240] (==) intel(0): TearFree disabled
[ 113.240] (==) intel(0): DPI set to (96, 96)
[ 113.240] (II) Loading sub module "dri2"
[ 113.240] (II) LoadModule: "dri2"
[ 113.240] (II) Module "dri2" already built-in
[ 113.240] (II) Loading sub module "present"
[ 113.240] (II) LoadModule: "present"
[ 113.240] (II) Module "present" already built-in
[ 113.240] (II) UnloadModule: "modesetting"
[ 113.240] (II) Unloading modesetting
[ 113.241] (==) Depth 24 pixmap format is 32 bpp
[ 113.276] (II) intel(0): SNA initialized with Ivybridge (gen7, gt2) backend
[ 113.276] (==) intel(0): Backing store enabled
[ 113.276] (==) intel(0): Silken mouse enabled
[ 113.287] (II) intel(0): HW Cursor enabled
[ 113.287] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 113.289] (==) intel(0): DPMS enabled
[ 113.289] (==) intel(0): Display hotplug detection enabled
[ 113.289] (II) intel(0): [DRI2] Setup complete
[ 113.289] (II) intel(0): [DRI2] DRI driver: i965
[ 113.289] (II) intel(0): [DRI2] VDPAU driver: va_gl
[ 113.289] (II) intel(0): direct rendering: DRI2 enabled
[ 113.289] (II) intel(0): hardware support for Present enabled
[ 113.289] (--) RandR disabled
[ 113.476] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 113.476] (II) AIGLX: enabled GLX_ARB_create_context
[ 113.476] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 113.476] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[ 113.476] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 113.476] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 113.476] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[ 113.476] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[ 113.476] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 113.476] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[ 113.477] (II) AIGLX: Loaded and initialized i965
[ 113.477] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 113.481] (II) intel(0): switch to mode 1366x768@60.0 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 113.482] (II) intel(0): Setting screen physical size to 361 x 203
[ 113.810] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[ 113.811] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 113.811] (II) LoadModule: "evdev"
[ 113.811] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 113.839] (II) Module evdev: vendor="X.Org Foundation"
[ 113.839] compiled for 1.18.0, module version = 2.10.1
[ 113.839] Module class: X.Org XInput Driver
[ 113.839] ABI class: X.Org XInput driver, version 22.1
[ 113.840] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 12 paused 0
[ 113.840] (II) Using input driver 'evdev' for 'Power Button'
[ 113.840] (**) Power Button: always reports core events
[ 113.840] (**) evdev: Power Button: Device: "/dev/input/event4"
[ 113.840] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 113.840] (--) evdev: Power Button: Found keys
[ 113.840] (II) evdev: Power Button: Configuring as keyboard
[ 113.840] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event4"
[ 113.840] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 113.840] (**) Option "xkb_rules" "evdev"
[ 113.841] (II) config/udev: Adding input device Video Bus (/dev/input/event8)
[ 113.841] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 113.842] (II) systemd-logind: got fd for /dev/input/event8 13:72 fd 13 paused 0
[ 113.842] (II) Using input driver 'evdev' for 'Video Bus'
[ 113.842] (**) Video Bus: always reports core events
[ 113.842] (**) evdev: Video Bus: Device: "/dev/input/event8"
[ 113.842] (--) evdev: Video Bus: Vendor 0 Product 0x6
[ 113.842] (--) evdev: Video Bus: Found keys
[ 113.843] (II) evdev: Video Bus: Configuring as keyboard
[ 113.843] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input9/event8"
[ 113.843] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[ 113.843] (**) Option "xkb_rules" "evdev"
[ 113.843] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[ 113.843] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 113.844] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 14 paused 0
[ 113.844] (II) Using input driver 'evdev' for 'Power Button'
[ 113.844] (**) Power Button: always reports core events
[ 113.844] (**) evdev: Power Button: Device: "/dev/input/event2"
[ 113.844] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 113.844] (--) evdev: Power Button: Found keys
[ 113.844] (II) evdev: Power Button: Configuring as keyboard
[ 113.844] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input3/event2"
[ 113.844] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[ 113.844] (**) Option "xkb_rules" "evdev"
[ 113.845] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[ 113.845] (II) No input driver specified, ignoring this device.
[ 113.845] (II) This device may have been added with another device file.
[ 113.846] (II) config/udev: Adding input device Sleep Button (/dev/input/event3)
[ 113.846] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 113.847] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 15 paused 0
[ 113.847] (II) Using input driver 'evdev' for 'Sleep Button'
[ 113.847] (**) Sleep Button: always reports core events
[ 113.847] (**) evdev: Sleep Button: Device: "/dev/input/event3"
[ 113.847] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[ 113.847] (--) evdev: Sleep Button: Found keys
[ 113.847] (II) evdev: Sleep Button: Configuring as keyboard
[ 113.847] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input4/event3"
[ 113.847] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[ 113.847] (**) Option "xkb_rules" "evdev"
[ 113.848] (II) config/udev: Adding input device Laptop_Integrated_Webcam_HD (/dev/input/event12)
[ 113.848] (**) Laptop_Integrated_Webcam_HD: Applying InputClass "evdev keyboard catchall"
[ 113.849] (II) systemd-logind: got fd for /dev/input/event12 13:76 fd 16 paused 0
[ 113.849] (II) Using input driver 'evdev' for 'Laptop_Integrated_Webcam_HD'
[ 113.849] (**) Laptop_Integrated_Webcam_HD: always reports core events
[ 113.849] (**) evdev: Laptop_Integrated_Webcam_HD: Device: "/dev/input/event12"
[ 113.849] (--) evdev: Laptop_Integrated_Webcam_HD: Vendor 0xc45 Product 0x6473
[ 113.849] (--) evdev: Laptop_Integrated_Webcam_HD: Found keys
[ 113.849] (II) evdev: Laptop_Integrated_Webcam_HD: Configuring as keyboard
[ 113.849] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5:1.0/input/input13/event12"
[ 113.850] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_HD" (type: KEYBOARD, id 10)
[ 113.850] (**) Option "xkb_rules" "evdev"
[ 113.850] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event5)
[ 113.850] (II) No input driver specified, ignoring this device.
[ 113.850] (II) This device may have been added with another device file.
[ 113.851] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event6)
[ 113.851] (II) No input driver specified, ignoring this device.
[ 113.851] (II) This device may have been added with another device file.
[ 113.851] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event7)
[ 113.851] (II) No input driver specified, ignoring this device.
[ 113.851] (II) This device may have been added with another device file.
[ 113.852] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[ 113.852] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 113.853] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 17 paused 0
[ 113.853] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 113.853] (**) AT Translated Set 2 keyboard: always reports core events
[ 113.853] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[ 113.853] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 113.853] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 113.853] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 113.853] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[ 113.853] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[ 113.853] (**) Option "xkb_rules" "evdev"
[ 113.854] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event10)
[ 113.854] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
[ 113.854] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
[ 113.854] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "Default clickpad buttons"
[ 113.854] (II) LoadModule: "synaptics"
[ 113.854] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 113.862] (II) Module synaptics: vendor="X.Org Foundation"
[ 113.862] compiled for 1.18.0, module version = 1.8.3
[ 113.862] Module class: X.Org XInput Driver
[ 113.862] ABI class: X.Org XInput driver, version 22.1
[ 113.863] (II) systemd-logind: got fd for /dev/input/event10 13:74 fd 18 paused 0
[ 113.863] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS GlidePoint'
[ 113.863] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 113.863] (**) Option "Device" "/dev/input/event10"
[ 113.893] (II) synaptics: AlpsPS/2 ALPS GlidePoint: ignoring touch events for semi-multitouch device
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1280 (res 0)
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 640 (res 0)
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
[ 113.893] (II) synaptics: AlpsPS/2 ALPS GlidePoint: device does not report finger width.
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: buttons: left right middle double triple
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: Vendor 0x2 Product 0x8
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: invalid finger width range. defaulting to 0 - 15
[ 113.893] (**) Option "TapButton1" "1"
[ 113.893] (**) Option "TapButton2" "2"
[ 113.893] (**) Option "TapButton3" "3"
[ 113.893] (--) synaptics: AlpsPS/2 ALPS GlidePoint: touchpad found
[ 113.893] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 113.893] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input10/event10"
[ 113.893] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD, id 12)
[ 113.893] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) MinSpeed is now constant deceleration 2.5
[ 113.893] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) MaxSpeed is now 1.75
[ 113.893] (**) synaptics: AlpsPS/2 ALPS GlidePoint: (accel) AccelFactor is now 0.140
[ 113.894] (**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
[ 113.894] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration profile 1
[ 113.894] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
[ 113.894] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
[ 113.894] (--) synaptics: AlpsPS/2 ALPS GlidePoint: touchpad found
[ 113.895] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse0)
[ 113.895] (**) AlpsPS/2 ALPS GlidePoint: Ignoring device from InputClass "touchpad ignore duplicates"
[ 113.895] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
[ 113.895] (II) No input driver specified, ignoring this device.
[ 113.895] (II) This device may have been added with another device file.
[ 113.896] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event11)
[ 113.896] (**) Dell WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[ 113.897] (II) systemd-logind: got fd for /dev/input/event11 13:75 fd 19 paused 0
[ 113.897] (II) Using input driver 'evdev' for 'Dell WMI hotkeys'
[ 113.897] (**) Dell WMI hotkeys: always reports core events
[ 113.897] (**) evdev: Dell WMI hotkeys: Device: "/dev/input/event11"
[ 113.897] (--) evdev: Dell WMI hotkeys: Vendor 0 Product 0
[ 113.897] (--) evdev: Dell WMI hotkeys: Found keys
[ 113.897] (II) evdev: Dell WMI hotkeys: Configuring as keyboard
[ 113.897] (**) Option "config_info" "udev:/sys/devices/virtual/input/input12/event11"
[ 113.897] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD, id 13)
[ 113.897] (**) Option "xkb_rules" "evdev"
[ 115.241] (II) intel(0): EDID vendor "LGD", prod id 827
[ 115.241] (II) intel(0): Printing DDC gathered Modelines:
[ 115.241] (II) intel(0): Modeline "1366x768"x0.0 76.50 1366 1402 1450 1546 768 771 776 824 -hsync -vsync (49.5 kHz eP)
[ 115.241] (II) intel(0): Modeline "1366x768"x0.0 51.00 1366 1402 1450 1564 768 771 776 814 -hsync -vsync (32.6 kHz e)
[ 117.928] (II) evdev: Dell WMI hotkeys: Close
[ 117.929] (II) UnloadModule: "evdev"
[ 117.929] (II) systemd-logind: releasing fd for 13:75
[ 117.943] (II) UnloadModule: "synaptics"
[ 117.943] (II) systemd-logind: releasing fd for 13:74
[ 117.980] (II) evdev: AT Translated Set 2 keyboard: Close
[ 117.980] (II) UnloadModule: "evdev"
[ 117.980] (II) systemd-logind: releasing fd for 13:64
[ 118.006] (II) evdev: Laptop_Integrated_Webcam_HD: Close
[ 118.021] (II) UnloadModule: "evdev"
[ 118.021] (II) systemd-logind: releasing fd for 13:76
[ 118.046] (II) evdev: Sleep Button: Close
[ 118.046] (II) UnloadModule: "evdev"
[ 118.046] (II) systemd-logind: releasing fd for 13:67
[ 118.066] (II) evdev: Power Button: Close
[ 118.066] (II) UnloadModule: "evdev"
[ 118.066] (II) systemd-logind: releasing fd for 13:66
[ 118.080] (II) evdev: Video Bus: Close
[ 118.080] (II) UnloadModule: "evdev"
[ 118.080] (II) systemd-logind: releasing fd for 13:72
[ 118.093] (II) evdev: Power Button: Close
[ 118.093] (II) UnloadModule: "evdev"
[ 118.093] (II) systemd-logind: releasing fd for 13:68
[ 118.171] (II) Server terminated successfully (0). Closing log file.
 
Old 01-07-2017, 01:52 PM   #9
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,080

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Wow. I'll let some of the more X-knowledgeable people out there evaluate that log. As an anectdotal piece of advice, the last time I ran into something like this (GNOME problem on multiple-DE system), I had to uninstall ALL of GNOME and reinstall it (and I had to force it to remove certain dependencies in the interim). Unfortunately, I couldn't tell you what the underlying issue was, but GNOME functioned as expected after this.

It's good to hear you usually use a standard user account. Again, I would stay away from running as root - I stick to sudo for instances where a particular command needs root privileges.

Cheers,
 
Old 01-07-2017, 10:02 PM   #10
ShaunXenon
LQ Newbie
 
Registered: Jan 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks Rickkk for such an optimistic reply, I am waiting for more X-knowledgeable people to evaluate the log.

As per your suggestion, I unistall gnome, but there was dependency issue, so I ran "pacman -Rdd gnome" for complete unistallation, and again install it using "pacman -S gnome".

The pacman installs 2 more packages( might be because, I yesterday sync the database as "pacman -Sy" ) from repository, then just logout and starting gnome from LXDM as normal user.
But gnome wont fired up (same LXDM login screen comes up after loading, as mentioned earlier)

Waiting for responses.
 
Old 01-07-2017, 11:45 PM   #11
FredGSanford
Senior Member
 
Registered: Nov 2005
Location: USA
Distribution: Mageia Cauldron - VoidLinux - Devuan
Posts: 1,098
Blog Entries: 5

Rep: Reputation: 181Reputation: 181
I'm currently using Antergos Linux, based on Arch more so then Manjero, from what I hear. My initial install was Openbox only, using LXDM. Today, I installed Gnome3 v3.22 and no problems logging in. Just a thought!
 
Old 01-08-2017, 02:12 AM   #12
ShaunXenon
LQ Newbie
 
Registered: Jan 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hello FredGSanford, the steps I performed for gnome installation are:
pacman -Sy
pacman -S gnome gnome-extra gnome-tweak-tool
reboot
launching gnome from lxdm
(in my case, gdm also not starts-up, mentioned in previous posts)

Did you performed any other steps? So that I can try the same

And more request, can you please compare the Xorg.0.log(located in /var/log/xorg/ or /home/.local/xorg dir) of mine posted above with yours.
Thanks
 
Old 01-09-2017, 12:32 PM   #13
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,025
Blog Entries: 7

Rep: Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777Reputation: 2777
why do you think archlinux is a good distro for you?

whatever.

first of all, you need to run
Code:
# pacman -Syu
before installing anything.

then, your Xorg.0.log does not show me anything beyond:

- it initializes normally
- loads intel graphics driver
- shuts down immediately after init

now i'm not the best reading these logs and might have missed something.

also, are we looking at the right log file? where'd you get it from? full path and filename please.

anyhow, USUALLY this means that something is wrong with the way you start X and/or you're looking at the wrong logs.

if you start X without a display manager, the usual way is:

- add a line to ~/.xinitrc a la "exec gnome-session"
- log out
- at the text console, log in as normal user.
- issue the command "startx" or "exec startx"

=> success?

if not, you also need to look at the logs generated by the session you're starting.

Last edited by ondoho; 01-09-2017 at 12:34 PM.
 
Old 01-09-2017, 02:03 PM   #14
FredGSanford
Senior Member
 
Registered: Nov 2005
Location: USA
Distribution: Mageia Cauldron - VoidLinux - Devuan
Posts: 1,098
Blog Entries: 5

Rep: Reputation: 181Reputation: 181
Quote:
Originally Posted by ShaunXenon View Post
Hello FredGSanford, the steps I performed for gnome installation are:
pacman -Sy
pacman -S gnome gnome-extra gnome-tweak-tool
reboot
launching gnome from lxdm
(in my case, gdm also not starts-up, mentioned in previous posts)

Did you performed any other steps? So that I can try the same

And more request, can you please compare the Xorg.0.log(located in /var/log/xorg/ or /home/.local/xorg dir) of mine posted above with yours.
Thanks
I have since reinstalled Antergos yesterday do to an issue with my initial installation, nothing to do with Gnome. I originally use Openbox as my main environment.

sudo pacman -Syu
sudo pacman -S gnome-shell gnome-tweak-tool, I want a minimum Gnome.
I then logout and before logging back in, I choose Gnome from the DM (Lightdm)

I didn't do anything special, everything went as planned. In your log you posted, I see (EE) listed, these should represent an error with any lines it's showing in. But you mention other DE are working, so not sure.

Once I install Gnome again, I can post my X log if you still want to see it.
 
Old 01-11-2017, 02:52 PM   #15
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,080

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Hey again ShaunXenon ... I know this is not what you want to hear, but I'm beginning to suspect there may be some unwanted artifact in your Gnome installation, maybe due to some of your past troubleshooting attempts (especially those where you were logging in as root), that is preventing it from functioning as expected. I am more of an LXDE fan myself, so my experience with Gnome is rather basic - especially since the extent of my problems with it were the issue I described in my previous post.

Soooo ..... It may be worth your while to do a complete reinstall, or at a minimum, uninstall all of your DE's and all of X - essentially bringing your system back to CLI mode. Then reinstall X, test it; reinstall Gnome, test it; reinstall other DE's one by one, testing them. A hassle, I know, but you may otherwise be searching for the proverbial haystack needle ... :-(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
systemctl start,enable service in one command. gctaylor1 Fedora 5 11-24-2018 12:20 PM
unable to START MySQL server at BOOT "systemctl enable mysqld.service" does not work cyberdome Linux - Newbie 2 03-11-2014 02:35 AM
[SOLVED] systemctl enable mysqld.service, command not working. cyberdome Fedora 5 03-10-2014 12:36 PM
hi,I enable the krb5-telnet service,but root user can't login hodge Linux - Newbie 2 07-17-2007 12:21 AM
Starting a service as non root user? dee3lmo Linux - General 2 07-30-2004 07:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration