-   Arch (
-   -   gdm-binary: /var/run/dbus/system_bus_socket: No such file or directory (

Kenny_Strawn 10-22-2010 09:53 PM

gdm-binary: /var/run/dbus/system_bus_socket: No such file or directory
Update: Now, I *CAN* get the installation to boot, but I can't get it to load past twm despite having a full desktop environment (GNOME), GDM, and even non-standard apps installed.

As for the error message that GDM is putting out, it's something like:


***(gdm-binary)***: /var/run/dbus/system_bus_socket: No such file or directory
I'm still trying to figure out how to hook dbus into the initrd.

linus72 10-22-2010 10:04 PM

needs to be sdb1 sdb2, etc right?
not /dev/sdb

change the fstab and grub boot line manually for /dev/sdb1 /, root=/dev/sdb1, etc

did you DD it to the drive?

Kenny_Strawn 10-22-2010 10:10 PM

Yeah, my mistake, I did try that. It still caused the same problem.

Kenny_Strawn 10-22-2010 10:19 PM

Also tried editing /etc/fstab. No change. :banghead:

linus72 10-22-2010 10:30 PM

how did you transfer it to the drive, unsquashfs'd it and then copied it?
does the drive have a sdb1?
whats the output of fdisk -l as root?

Kenny_Strawn 10-22-2010 10:45 PM

I decided to 'unsquashfs' it directly to the drive, using

unsquashfs root-image.sqfs -fd /mnt
with the drive mounted in /mnt. Then, I installed the needed and wanted packages on the drive, installed GRUB, and updated GRUB. Yet, I've run into these roadblocks every time I tried to boot it!

Kenny_Strawn 10-22-2010 10:47 PM

And yes, it does have an sdb1; I specifically created it in GParted so that I could use GRUB on it.

sandman 10-22-2010 11:21 PM

i forget the command, but you need to delay mounting root, which is your external drive, to allow archlinux time to discover it first. I used to use 6 seconds which was fine for my external.

here is the command you need to put on your kernel line in grub
change the 6 to however many seconds you feel is needed.

Kenny_Strawn 10-22-2010 11:24 PM

The default is 10 seconds, and the kernel still isn't finding it. How do you modify that value?

sandman 10-22-2010 11:33 PM

you need to edit /boot/grub/menu.lst as root and look for your kernel line. here is an example with the rootdelay=6 added to it

kernel /vmlinuz26 root=/dev/sdb10 rootdelay=6 ro

Kenny_Strawn 10-22-2010 11:34 PM

Actually, that's for legacy GRUB. I have GRUB 2.

Kenny_Strawn 10-22-2010 11:38 PM

I decided to edit my /etc/default/grub and include "rootdelay=30" in the "GRUB_CMDLINE_LINUX" variable, then update GRUB. Hopefully, this will solve the problem. At 10 seconds, it still isn't working.

sandman 10-22-2010 11:39 PM

you can still add kernel options in grub.cfg using grub 2
here is wiki page for grub 2

Kenny_Strawn 10-22-2010 11:43 PM

Still, 30 seconds doesn't fly.

I wonder if it registers as a different device, say /dev/sda1, on the external device? I will try to see if that is the case.

sandman 10-22-2010 11:48 PM

try labeling the drive and then boot by-label instead of by-uuid or by device. info here

All times are GMT -5. The time now is 03:05 AM.