LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 12-02-2011, 10:24 PM   #1
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Rep: Reputation: 0
Exclamation Error while configuring LAVA 720G data card


I recntly purchased LAVA 720G data card [in for form a USB dongle]. After attaching card to the laptop I tried the following:
Code:
[sudeep@myhost ~]$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 004: ID 1c4f:000e SiGma Micro 
Bus 001 Device 003: ID 0a5c:21b2 Broadcom Corp. 
Bus 001 Device 004: ID 0408:2fb1 Quanta Computer, Inc. 
Bus 002 Device 005: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 007: ID 1c9e:9605 
and then, after a little digging, I tried:

Code:
modprobe cdc_acm
modprobe usbserial vendor=0x1c9e product=0x9605
then,

Code:
[root@myhost etc]# ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1  /dev/ttyUSB2
and,

Code:
[root@myhost etc]# wvdial bsnl
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 7200000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon Nov 28 07:48:02 2011
--> Pid of pppd: 2448
--> Using interface ppp0
--> Disconnecting at Mon Nov 28 07:48:32 2011
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: at+cgdcont=1,"ip","bsnlnet"
at+cgdcont=1,"ip","bsnlnet"
OK
--> Modem initialized.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: at+cgdcont=1,"ip","bsnlnet"
at+cgdcont=1,"ip","bsnlnet"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
ERROR
--> Invalid dial command.
--> Disconnecting at Mon Nov 28 07:48:37 2011
So as you can see, I cannot connect to internet. What could be the problem?
 
Old 03-15-2012, 09:48 PM   #2
chakramu
LQ Newbie
 
Registered: Mar 2012
Location: Bangkok, Thailand
Distribution: Linux Mint
Posts: 5

Rep: Reputation: Disabled
Hi,

I have the same datacard and using Airtel 3G currently. Can someone please help me connect this data card on Linux Mint12 (Lisa)?

Thanks in advance
 
Old 03-17-2012, 03:12 AM   #3
chakramu
LQ Newbie
 
Registered: Mar 2012
Location: Bangkok, Thailand
Distribution: Linux Mint
Posts: 5

Rep: Reputation: Disabled
Hi,

I am finally able to use Lava 720G with LinuxMint12.

It automatically detects the mobile broadband and I was able to configure my Airtel 3G and access internet successfully.

-Chakradhar
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use BSNL Data Card(Mobi Data 0x1c9e:0xf000) in Fedora 13 jitenderpal Linux - Newbie 1 11-18-2010 10:38 PM
How to send data to WAN Interface card at Data link Layer in linux environment krishna_karne Linux - Software 0 05-09-2008 04:01 AM
lava sybolic link firefox won't stsrt tewaru Mandriva 1 06-06-2004 12:04 AM
Modprobe Error !!...while configuring sound card on RH 7.1 vimalkumar_v Linux - Hardware 0 12-29-2002 11:14 AM
configuring sound card and ethernet card justlearning Linux - General 1 05-14-2001 02:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration