LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (https://www.linuxquestions.org/questions/arch-29/)
-   -   error during reinstall while attempting to keeping home partition (https://www.linuxquestions.org/questions/arch-29/error-during-reinstall-while-attempting-to-keeping-home-partition-4175658403/)

paintpenguin 08-01-2019 05:39 AM

error during reinstall while attempting to keeping home partition
 
Hello :-)
I did this install about a week ago, and, being both new to Arch and using a separate home partition, I'd been excited to see how keeping the separate home would work, but an error message came up.

Using fdisk to set up and write 4 partitions. I used exactly the same sizes for partitions as before. I hadn't formatted the home partition [didn't type mkfs.ext4 /dev/sda4], and then continued with mounting, but the error message came up when attempting to mount home ... wrong fs type, bad option, bad superblock, missing codepage or helper program, or other error.

An increase in how much there would be to setup afterwards, so I'd be more than grateful to know what I'd done wrong and how to keep data if a reinstall is needed.

colorpurple21859 08-01-2019 06:08 AM

Quote:

Using fdisk to set up and write 4 partitions
how many partitions did you have originally and what did you do before using fdisk to create the 4 partitions. Maybe run fsck on home partition will fix things.

paintpenguin 08-01-2019 06:48 AM

Thank you for your message. :-) I read various guides (over an entire month, lol), ending up focussing most of all on AverageLinuxUser's guide, so I run loadkeys, run a ping, then type fdisk -l. Then fdisk /dev/sda, going on to choose gpt, creating 4 partitions: boot/sda1, swap/sda2, root/sda3, and home/sda4. I do the process for each partition, then 'w' to write. I then am at formatting, but do not type mkfs.ext4 /dev/sda4 for the home partition. After that I mount the 3 other partitions, but then am hitting the issue with the home partition, when I type mount /dev/sda4 /mnt/home. System runs great with the 4 partitions otherwise. I'll try fsck for sure next time; thank you ... just fsck /dev/sda4 when that error message comes up?

colorpurple21859 08-01-2019 06:55 AM

did you rerun
Code:

mkfs.ext4 /dev/sda4

paintpenguin 08-01-2019 07:05 AM

Sorry, I should clarify that it was about 5 days ago I hit the error, and ended up doing a full reinstall and setting everything up fresh. I'd love to test out a format and run fsck, and I suppose I could, lol, just to know, but I'd need to do all backups and be ready incase program reinstalls needed. I just wondered if there was something I'd got wrong, and hoped to prepare for next time. Sorry for any confusion. I had tried to rerun the command again 5 days ago though, yes.

colorpurple21859 08-01-2019 08:56 AM

If I'm reading this right, you was wanting to keep your home partition intact and redo the other 3 partitions, with fdisk, delete the other three paritions and then recreate them, not create a new partition table and make 4 new partitions again

paintpenguin 08-01-2019 03:47 PM

Thank you. I'm looking up fsck more, so will add commands to notes, to use next time there's a reinstall, and will remember to manage the partitions also.

Rickkkk 11-16-2019 11:20 AM

Hi paintpenguin,

As with colorpurple21859, I am not 100% clear on what you've done or are trying to do.

That said, you seem to be trying to mount a partition with no file system on it. You can't do that. Mounting requires a file system. So when you say you stopped short of "formatting" your home partition (/dev/sda4), that is the explanation for the error message you are receiving.

Other than that, it would be best if you more fully described your objective if you need further assistance.

Cheers,


***EDIT *** Apologies - I just realized the last post in this thread is several months old.


All times are GMT -5. The time now is 03:04 AM.