LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 09-06-2011, 11:56 AM   #16
volumen1
LQ Newbie
 
Registered: Sep 2011
Location: Missoula, MT
Distribution: Gentoo
Posts: 7

Rep: Reputation: Disabled

I do have VMWare workstation and I think I would be interested in this. I'm not sure I see the java directory you are mentioning. I ran the .deb.sh file like this "./dell-inkjet-09-driver-1.0-1.i386.deb.sh --keep" and now I have a tmp/ directory that the installer created. But, I don't see any files or folder with java in the name at all.
 
Old 09-06-2011, 11:57 AM   #17
kasl33
Member
 
Registered: Oct 2004
Location: USA
Distribution: Ubuntu-Server, Mac OS X, Arch Linux
Posts: 356

Original Poster
Rep: Reputation: 48
Ah yes. You know the directory with dlnet and dlusb, etc in it? Well, go there and run 'ls -a' and you will see a .scripts directory. It's in there.

I'll get the VM over to my server and put a link up shortly
 
Old 09-06-2011, 12:14 PM   #18
volumen1
LQ Newbie
 
Registered: Sep 2011
Location: Missoula, MT
Distribution: Gentoo
Posts: 7

Rep: Reputation: Disabled
Ahh yeah! I got it working now. For some reason, dpkg installed the dell09 folder to /usr/local/dell/ So, I used deb2targz and I unpacked the .deb file. Then I copied everything from the "usr/local/dell" folder that it wanted to create to /usr/dellinkjet/. After that, my /usr/dellinkjet/ folder looked like this:

Code:
total 16
drwxr-xr-x  3 root root   40 Sep  6 11:05 .
drwxr-xr-x 15 root root 4096 Sep  6 08:10 ..
drwxr-xr-x  7 root root   40 Sep  6 11:05 dell09
-rwxr-xr-x  1 root root 2875 Sep  6 11:03 inkjet-09-driver.link
-rwxr-xr-x  1 root root  999 Sep  6 11:03 inkjet-09-driver.unlink
lrwxrwxrwx  1 root root   22 Sep  6 11:03 jre -> /usr/local/jre1.6.0_12
Then I added a new printer using the CUPS interface (and now I was able to see Dell Network Backend #1 as a backend option). However, I didn't specify an IP for my printer. It seemed to automagically find it via the hardware address. Regardless of how it worked, I just now printed a test page!

Lemme know if you get anywhere on the scanner. I expect that to be total pain. I'll probably just resort to my Windows 7 VM to do scanning.
 
Old 09-06-2011, 12:17 PM   #19
kasl33
Member
 
Registered: Oct 2004
Location: USA
Distribution: Ubuntu-Server, Mac OS X, Arch Linux
Posts: 356

Original Poster
Rep: Reputation: 48
I'm glad to hear it! I'll start that scanner post now. I am guessing you don't need the Ubuntu VM anymore, so I'll cancel the transfer.
 
Old 09-06-2011, 06:49 PM   #20
volumen1
LQ Newbie
 
Registered: Sep 2011
Location: Missoula, MT
Distribution: Gentoo
Posts: 7

Rep: Reputation: Disabled
@kasl_33 Yup, I'm good. Thanks for the offer, though. I appreciate it.

I'm going to repeat this whole process on my Gentoo laptop, so I'll try and dial it in by just copying files from the tar.gz file that I create from the .deb. I'll post my results.
 
Old 09-06-2011, 06:56 PM   #21
kasl33
Member
 
Registered: Oct 2004
Location: USA
Distribution: Ubuntu-Server, Mac OS X, Arch Linux
Posts: 356

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by volumen1 View Post
@kasl_33 Yup, I'm good. Thanks for the offer, though. I appreciate it.

I'm going to repeat this whole process on my Gentoo laptop, so I'll try and dial it in by just copying files from the tar.gz file that I create from the .deb. I'll post my results.
That would be great! If you don't mind, let me know what differences you come up with in relation to the tutorial I made about it and I can add them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Lexmark x4975 printer on Fedora 10 using Dell Inspiron 1720 chas1 Linux - Hardware 3 03-28-2009 11:23 AM
Lexmark X1185 printer installation marbletn Linux - Hardware 0 01-06-2006 02:32 AM
lexmark z23 printer installation with REDHAT FEDORA CORE 2 samurai Linux - General 2 09-04-2004 06:31 PM
lexmark z605 printer installation ksgill Linux - Newbie 23 04-07-2004 07:18 PM
Which inkjet printer? RecoilUK Linux - General 3 12-28-2001 08:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration