LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 07-16-2015, 01:30 AM   #1
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Rep: Reputation: Disabled
Can't load graphics environment


Hello all,

I have been trying to install KDE on Arch Linux but when I start sddm, it turns into a blank screen with a cursor and if I boot with sddm turned on, it won't let me log in.

When I try to use startx, it outputs a message something like no screens found.

Computer specs: uefi boot, K2100m graphics card

Couple of things I have noticed, there is no Intel entry in /etc/X11/xorg.conf, when running 'lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA' both graphics cards (intel and Nvidia K2100m) ends in VGA controller and there is no sddm.conf file after installing sddm.

Here is the xorg.conf file:
Code:
>nvidia-xconfig: X configuration file generated by nvidia-xconfig
>nvidia-xconfig:  version 352.21  (buildmeister@swio-display-x64-rhel04-13)  Tue Jun  9 22:44:03 PDT 2015


>Section "ServerLayout"
>    Identifier     "Layout0"
>   Screen      0  "Screen0" 0 0
>    InputDevice    "Keyboard0" "CoreKeyboard"
>   InputDevice    "Mouse0" "CorePointer"
>EndSection

>Section "Files"
>EndSection

>Section "InputDevice"

 >   # generated from default
 >   Identifier     "Mouse0"
 >   Driver         "mouse"
 >   Option         "Protocol" "auto"
 >   Option         "Device" "/dev/psaux"
 >   Option         "Emulate3Buttons" "no"
 >   Option         "ZAxisMapping" "4 5"
>EndSection

>Section "InputDevice"

>    # generated from default
>    Identifier     "Keyboard0"
>    Driver         "kbd"
>EndSection

>Section "Monitor"
>    Identifier     "Monitor0"
>    VendorName     "Unknown"
>    ModelName      "Unknown"
>    HorizSync       28.0 - 33.0
>    VertRefresh     43.0 - 72.0
>    Option         "DPMS"
>EndSection

>Section "Device"
>    Identifier     "Device0"
>    Driver         "nvidia"
>    VendorName     "NVIDIA Corporation"
>EndSection

>Section "Screen"
>    Identifier     "Screen0"
>    Device         "Device0"
>    Monitor        "Monitor0"
>    DefaultDepth    24
>    SubSection     "Display"
>        Depth       24
>    EndSubSection
>EndSection
Here are the lines I have used to install x and graphics drivers:
pacman -S xorg-server xorg-server-utils xorg-xinit xorg-twm xorg-xclock xterm
pacman -S nvidia lib32-nvidia-utils
pacman -S mesa xf86-video-intel

The only thing I have done previously is blacklist nouveau from starting as otherwise, the computer won't boot to login. I have installed both the intel and nvidia drivers.

Thanks.
 
Old 07-16-2015, 02:13 AM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by thinkrorbot View Post
both graphics cards (intel and Nvidia K2100m)
https://wiki.archlinux.org/index.php/Bumblebee
 
Old 07-16-2015, 03:43 AM   #3
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
I have installed and started bumblebee as well as reinstalled mesa, the intel video driver and xorg, it still comes up with 'no screens detected'.
 
Old 07-16-2015, 08:30 AM   #4
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
you cannot run nvidia-xconfig and use bumblebee.
 
Old 07-17-2015, 01:22 AM   #5
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
This is the log file:
Quote:
[ 62.897]
X.Org X Server 1.17.2
Release Date: 2015-06-16
[ 62.897] X Protocol Version 11, Revision 0
[ 62.898] Build Operating System: Linux 4.0.4-2-ARCH x86_64
[ 62.898] Current Operating System: Linux thinkrorbot 4.0.7-2-ARCH #1 SMP PREEMPT Tue Jun 30 07:50:21 UTC 2015 x86_64
[ 62.898] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/sdb7
[ 62.898] Build Date: 30 June 2015 09:00:12PM
[ 62.898]
[ 62.899] Current version of pixman: 0.32.6
[ 62.899] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 62.899] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 62.900] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 17 16:15:16 2015
[ 62.900] (==) Using config file: "/etc/X11/xorg.conf"
[ 62.901] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 62.901] (==) ServerLayout "X.org Configured"
[ 62.901] (**) |-->Screen "Screen0" (0)
[ 62.901] (**) | |-->Monitor "Monitor0"
[ 62.901] (**) | |-->Device "Card0"
[ 62.901] (**) |-->Input Device "Mouse0"
[ 62.901] (**) |-->Input Device "Keyboard0"
[ 62.901] (==) Automatically adding devices
[ 62.901] (==) Automatically enabling devices
[ 62.901] (==) Automatically adding GPU devices
[ 62.901] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 62.901] Entry deleted from font path.
[ 62.901] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 62.901] Entry deleted from font path.
[ 62.901] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 62.901] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 62.901] Entry deleted from font path.
[ 62.901] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 62.901] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 62.901] Entry deleted from font path.
[ 62.901] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 62.901] Entry deleted from font path.
[ 62.901] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 62.901] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 62.901] Entry deleted from font path.
[ 62.901] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 62.901] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/
[ 62.901] (**) ModulePath set to "/usr/lib/xorg/modules"
[ 62.901] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 62.901] (WW) Disabling Mouse0
[ 62.901] (WW) Disabling Keyboard0
[ 62.901] (II) Loader magic: 0x816d60
[ 62.901] (II) Module ABI versions:
[ 62.901] X.Org ANSI C Emulation: 0.4
[ 62.901] X.Org Video Driver: 19.0
[ 62.901] X.Org XInput driver : 21.1
[ 62.901] X.Org Server Extension : 9.0
[ 62.902] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[ 62.902] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 62.902] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 8 paused 0
[ 62.903] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 62.903] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 9 paused 0
[ 62.905] (--) PCI:*(0:0:2:0) 8086:0416:17aa:221e rev 6, Mem @ 0xb1400000/4194304, 0xa0000000/268435456, I/O @ 0x00005000/64
[ 62.905] (--) PCI: (0:1:0:0) 10de:11fc:17aa:221e rev 161, Mem @ 0xb0000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[ 62.905] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 62.905] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 62.905] (II) LoadModule: "glx"
[ 62.906] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 62.906] (II) Module glx: vendor="X.Org Foundation"
[ 62.906] compiled for 1.17.2, module version = 1.0.0
[ 62.906] ABI class: X.Org Server Extension, version 9.0
[ 62.906] (==) AIGLX enabled
[ 62.906] (II) LoadModule: "nvidia"
[ 62.906] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 62.906] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 62.906] compiled for 4.0.2, module version = 1.0.0
[ 62.906] Module class: X.Org Video Driver
[ 62.906] (II) NVIDIA dlloader X Driver 352.21 Tue Jun 9 20:58:55 PDT 2015
[ 62.906] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 62.906] (++) using VT number 1

[ 62.906] (--) controlling tty is VT number 1, auto-enabling KeepTty
[ 62.906] (II) Loading sub module "fb"
[ 62.906] (II) LoadModule: "fb"
[ 62.906] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 62.907] (II) Module fb: vendor="X.Org Foundation"
[ 62.907] compiled for 1.17.2, module version = 1.0.0
[ 62.907] ABI class: X.Org ANSI C Emulation, version 0.4
[ 62.907] (II) Loading sub module "wfb"
[ 62.907] (II) LoadModule: "wfb"
[ 62.907] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 62.907] (II) Module wfb: vendor="X.Org Foundation"
[ 62.907] compiled for 1.17.2, module version = 1.0.0
[ 62.907] ABI class: X.Org ANSI C Emulation, version 0.4
[ 62.907] (II) Loading sub module "ramdac"
[ 62.907] (II) LoadModule: "ramdac"
[ 62.907] (II) Module "ramdac" already built-in
[ 62.907] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 62.907] (==) NVIDIA(0): RGB weight 888
[ 62.907] (==) NVIDIA(0): Default visual is TrueColor
[ 62.907] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 62.907] (**) NVIDIA(0): Enabling 2D acceleration
[ 62.907] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 62.907] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 62.907] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 62.907] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 62.907] (EE) NVIDIA(0): reinstalling the NVIDIA driver.
[ 63.092] (II) NVIDIA: Allocated GPU:0 (GPU-1e33a5f7-544a-c04f-acb1-bf87dd96bc15) @
[ 63.092] (II) NVIDIA: PCI:0000:01:00.0
[ 63.093] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[ 63.093] (--) NVIDIA(0): DFP-0
[ 63.093] (--) NVIDIA(0): DFP-1
[ 63.093] (--) NVIDIA(0): DFP-0: disconnected
[ 63.093] (--) NVIDIA(0): DFP-0: Internal TMDS
[ 63.093] (--) NVIDIA(0): DFP-0: 165.0 MHz maximum pixel clock
[ 63.094] (--) NVIDIA(0):
[ 63.094] (--) NVIDIA(0): DFP-1: disconnected
[ 63.094] (--) NVIDIA(0): DFP-1: Internal DisplayPort
[ 63.094] (--) NVIDIA(0): DFP-1: 960.0 MHz maximum pixel clock
[ 63.094] (--) NVIDIA(0):
[ 63.094] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[ 63.095] (II) NVIDIA(0): NVIDIA GPU Quadro K2100M (GK106GL) at PCI:1:0:0 (GPU-0)
[ 63.095] (--) NVIDIA(0): Memory: 2097152 kBytes
[ 63.095] (--) NVIDIA(0): VideoBIOS: 80.06.63.00.1a
[ 63.095] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 63.104] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0.
[ 63.104] (EE) NVIDIA(0): Set AllowEmptyInitialConfiguration if you want the server
[ 63.104] (EE) NVIDIA(0): to start anyway
[ 63.104] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 63.111] (II) NVIDIA: Freed GPU:0 (GPU-1e33a5f7-544a-c04f-acb1-bf87dd96bc15) @
[ 63.111] (II) NVIDIA: PCI:0000:01:00.0
[ 63.125] (II) UnloadModule: "nvidia"
[ 63.125] (II) UnloadSubModule: "wfb"
[ 63.125] (II) UnloadSubModule: "fb"
[ 63.125] (EE) Screen(s) found, but none have a usable configuration.
[ 63.125] (EE)
Fatal server error:
[ 63.125] (EE) no screens found(EE)
[ 63.125] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 63.125] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 63.125] (EE)
[ 63.128] (EE) Server terminated with error (1). Closing log file.
And here is the new xorg.conf file after running Xorg :0 -configure
Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 07-17-2015, 03:50 AM   #6
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
I looks like the screen is still being run by the nvidia card that's your conflict BBswitch is shutting down the card and your screen is being run by it. Your screen should be run by the iGPU and your virtual screen run by the nVidia card when you enable it.
 
Old 07-17-2015, 11:56 PM   #7
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Germany_chris View Post
I looks like the screen is still being run by the nvidia card that's your conflict BBswitch is shutting down the card and your screen is being run by it. Your screen should be run by the iGPU and your virtual screen run by the nVidia card when you enable it.
How do I select the card running or disable the Nvidia card from starting?
 
Old 07-18-2015, 07:01 AM   #8
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
Quote:
Originally Posted by thinkrorbot View Post
How do I select the card running or disable the Nvidia card from starting?
You don't want to disable the card from running it needs to start when you start computer then shut down. It also needs to start again as you power down bbswitch should take care of that for you. You will have two screens in you xorg logs, in my case screen 0 and 8. Screen 0 is my actual display and 8 is my virtual display where the nVidia card runs.

When I made the mistake of using nvidia-xconfig I couldn't fix it so I reinstalled.
 
Old 07-18-2015, 07:05 PM   #9
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Germany_chris View Post
You don't want to disable the card from running it needs to start when you start computer then shut down. It also needs to start again as you power down bbswitch should take care of that for you. You will have two screens in you xorg logs, in my case screen 0 and 8. Screen 0 is my actual display and 8 is my virtual display where the nVidia card runs.

When I made the mistake of using nvidia-xconfig I couldn't fix it so I reinstalled.
What did you reinstall and in which order did you install? I removed mesa and all its dependencies and all that depended on it and removed nvidia, nvidia-utils, xf86-video-intel, and xorg-server, xorg-server-utils. I then reinstalled xorg, then nvidia, then the intel driver followed by bumblebee. The xorg.conf file remained the same so I added 20-intel.conf to xorg.conf.d. Here is 20-intel.conf:
Code:
Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"
	Option  "AccelMethod" 	"uxa"
	#Option "AccelMethod"	"sna"
EndSection
It ended up with getting a similar log as the Nvidia card was not disabled.
 
Old 07-19-2015, 03:48 AM   #10
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
I reinstalled everything I just couldn't get it to work now what and how I removed stuff.
 
Old 07-19-2015, 05:30 AM   #11
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by thinkrorbot View Post
The xorg.conf file remained the same
Remove the auto-generated xorg.conf and write your own instead if necessary -- you should only *need* such a file for multiple monitor set ups or similar.

The file generated by `Xorg :0 -configure` looks like it is still specifying the NVIDIA card -- that command is not mentioned at all in the ArchWiki page I linked and will conflict with the 20-intel.conf file you have created which specifies the Intel card.
 
Old 07-20-2015, 02:01 AM   #12
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
I have decided to reinstall arch. The xorg.conf file didn't come back after reinstalling xorg-server. Thank you for all the help.
 
Old 07-20-2015, 05:51 AM   #13
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
this time just install xf86-video-intel and get a working setup then bumblebee/bbswitch/primus/nvidia.
 
Old 07-22-2015, 02:17 AM   #14
thinkrorbot
Member
 
Registered: Feb 2015
Location: Sydney, Australia
Distribution: Linux mint 17.1
Posts: 39

Original Poster
Rep: Reputation: Disabled
Got KDE working now. Just having issues with sound and wifi.
 
Old 07-22-2015, 03:32 AM   #15
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
So you're headed back to the arch wiki?

I've found it best to read the whole entry before doing anything rather than just reading the section I think I need.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bashrc environment doesn't load vielmaj Linux - Server 1 01-31-2011 01:50 PM
E-book for C graphics under Linux environment aarsh Programming 3 01-19-2011 08:22 AM
I need independent cd or dvd that i can load in a windows environment sr_eng Solaris / OpenSolaris 3 10-24-2006 02:11 PM
Graphics and CPU Load BobNutfield Linux - Hardware 3 05-22-2006 05:19 PM
Graphical environment doesn't load anymore xstealthrtx Linux - Newbie 3 11-23-2004 12:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration