LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 03-13-2017, 08:35 AM   #16
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740

ifconfig to get your interphase name. The psy0 is just a psychical connection 0 - I'd say a zero based numbering system.
 
Old 03-13-2017, 09:29 AM   #17
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
WPA supplicant
 
Old 03-13-2017, 01:39 PM   #18
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
As I stated in an earlier post the problem starts with the n and the numbers after it. I don't know what to put. and as I discovered it is not wan0. it has a different name but at the moment I can't tell you because I was in a chroot enviroment.
 
Old 03-13-2017, 01:56 PM   #19
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
wlan0 for most -- I have a distro that names my wifi card bsd style -- I do not know how Arch names its devices.

again sudo ifconfig gets you the device name
this gives detailed step by step on how to it is ArchLinux how to
https://wiki.archlinux.org/index.php/WPA_supplicant
 
Old 03-13-2017, 02:12 PM   #20
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
I have followed the wpa_supplicant and everything else I could find until I think I am losing my mind. Literally for two days I got up at 5 a.m. skipped breakfast and lunch so I could keep working on what to do. And once gain arch uses iw.
 
Old 03-13-2017, 02:13 PM   #21
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Quote:
Originally Posted by bsth123 View Post
I have followed the wpa_supplicant and everything else I could find until I think I am losing my mind. Literally for two days I got up at 5 a.m. skipped breakfast and lunch so I could keep working on what to do. And once gain arch uses iw.
that ArchLinux webpage is for archlinux by archlinux you show you're using wpa_supplicant not iw if they are not the same. I do not use wpa_supplicant I stop doing that a long long time ago. Opted for something easier to setup.

Last edited by BW-userx; 03-13-2017 at 02:16 PM.
 
Old 03-13-2017, 02:25 PM   #22
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
I meant it does not use ifcong it uses iw. I'm through with arch. Onto something else.
 
Old 03-13-2017, 02:43 PM   #23
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Quote:
Originally Posted by bsth123 View Post
I meant it does not use ifcong it uses iw. I'm through with arch. Onto something else.
are you sure you spelt it right wlan0 not wan0
google what arch uses for name wifi device.

in my /etc/wpa_supplicant.conf is this
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
#i ran this
userx@slackwhere⚡️~⚡️$ sudo  wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
#then ran this
userx@slackwhere⚡️~⚡️$ sudo wpa_cli
wpa_cli v2.6

Selected interface 'wlan0'

Interactive mode

> scan
OK

Last edited by BW-userx; 03-13-2017 at 02:44 PM.
 
Old 03-13-2017, 02:46 PM   #24
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Code:
userx@slackwhere⚡️~⚡️$ sudo iw dev
phy#0
	Interface wlan0
		ifindex 2
		wdev 0x1
		addr 00:24:d7:cf:9e:a4
		type managed
		channel 11 (2462 MHz), width: 20 MHz (no HT), center1: 2462 MHz
		txpower 15.00 dBm

Last edited by BW-userx; 03-13-2017 at 02:55 PM.
 
Old 03-13-2017, 03:12 PM   #25
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
I tried what you said but it must be different in arch. Accordung to the arch wiki everything worked fine until I got to wpa_cli. After that I'm supposed to get > instead I get
Code:
wpa_cli
wpa_cli v2.6
Copyright (c) 2004-2016, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.



Interactive mode

Could not connect to wpa_supplicant: (nil) - re-trying
 
Old 03-13-2017, 03:12 PM   #26
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
double post

Last edited by bsth123; 03-13-2017 at 03:14 PM.
 
Old 03-13-2017, 03:20 PM   #27
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
use sudo -- (root) see if that works. it is a root thing --

you did all of this right right?
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
Code:
userx@slackwhere⚡️~⚡️$ sudo  wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
where in their instructions it states to create a .conf file with this
Code:
/etc/wpa_supplicant/example.conf

ctrl_interface=/run/wpa_supplicant
update_config=1
are you using sudo or root user to issue your commands?

Last edited by BW-userx; 03-13-2017 at 03:24 PM.
 
Old 03-13-2017, 03:26 PM   #28
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Code:
                           interface  -c path to conf file
 sudo  wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf

#so yours should look like this

 sudo  wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/example.conf

Last edited by BW-userx; 03-13-2017 at 03:33 PM.
 
Old 03-13-2017, 03:38 PM   #29
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,298

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Enabling and disabling network interfaces

You can activate or deactivate network interfaces using:
Code:
# ip link set eth0 up
# ip link set eth0 down
where your wifi should then be this
as root or using sudo
Code:
#ip link set wlan0 up
#wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/example.conf
#wpa_cli
 
Old 03-13-2017, 04:04 PM   #30
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
Code:
wpa_cli
wpa_cli v2.6
Copyright (c) 2004-2016, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.



Interactive mode

Could not connect to wpa_supplicant: (nil) - re-trying
I'm running this as root
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking not working (Wireless and wired) MintCin.64, does work in 32 iSeth Linux - Networking 8 05-09-2015 12:40 AM
[SOLVED] Getting wireless/wired hardware to work with Debian griffsterb Linux - Hardware 16 12-03-2011 01:47 AM
Can't get Wireless or Wired connection to work leavage Linux - Newbie 5 12-27-2010 03:28 PM
Gutsy wireless connection does not work/ wired works aio85 Linux - Newbie 5 01-14-2008 12:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration