LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 03-11-2017, 02:55 PM   #1
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Rep: Reputation: Disabled
can't get wireless to work


I can't get wireless to work
Code:
	Subsystem: Dell Device 06b0
06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
	Subsystem: Intel Corporation Dual Band Wireless AC 3160
	Kernel driver in use: iwlwifi
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
	Subsystem: Dell Device 06b0
	Kernel driver in use: r8169
Code:
 dmesg | grep iwlwifi
[   56.886133] iwlwifi 0000:06:00.0: irq 62 for MSI/MSI-X
[   56.886488] iwlwifi 0000:06:00.0: Unsupported splx structure
[   57.375636] iwlwifi 0000:06:00.0: firmware: direct-loading firmware iwlwifi-3160-9.ucode
[   57.375790] iwlwifi 0000:06:00.0: loaded firmware version 23.214.9.0 op_mode iwlmvm
[   58.234718] iwlwifi 0000:06:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[   58.234781] iwlwifi 0000:06:00.0: L1 Enabled - LTR Enabled
[   58.235010] iwlwifi 0000:06:00.0: L1 Enabled - LTR Enabled
[  150.441622] iwlwifi 0000:06:00.0: L1 Enabled - LTR Enabled
[  150.441860] iwlwifi 0000:06:00.0: L1 Enabled - LTR Enabled
If you need anymore info please let me know. I've been working on this for several days trying to troubleshoot.

Last edited by bsth123; 03-11-2017 at 02:56 PM.
 
Old 03-11-2017, 03:41 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,457
Blog Entries: 15

Rep: Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157
Hi:

You're not alone.
I read all of the Arch Linux Documentation on how to get the wifi working and it's not the easiest to understand. If I understand it correctly you need to set up the wifi one of the three ways. Wicd, iw, or wpa_supplicant.

https://wiki.archlinux.org/index.php..._configuration

If I find a way to get the wireless working I'll certainly post it for you.

Good Luck-
 
Old 03-11-2017, 03:58 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
try
Code:
#!/bin/bash
sudo ifconfig wlan0 up
sudo  iwlist wlan0 scan
sudo iwconfig wlan0 essid "provider name" key "off" or number
 
Old 03-12-2017, 01:43 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,478
Blog Entries: 8

Rep: Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011
Quote:
Originally Posted by bsth123 View Post
If you need anymore info please let me know. I've been working on this for several days trying to troubleshoot.
it certainly looks like everything is working.
so what isn't working exactly?
how are you connecting (try what the previous poster suggested)?
 
Old 03-12-2017, 09:49 AM   #5
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
No offense but those commands don't work in arch. It uses iw, I'm trying to use wpa_supplicant because according to the wiki if you use wpa you have to. I can get this far
Code:
# wpa_supplicant -D nl80211,wext -i wlan0 -c <(wpa_passphrase "your_SSID" "your_key")
the problem is the portion that starts with a n. That's suppposed to be the accesspoint discovery but when I run the commands to find it I can't, even though it's picking up all my networks. I've been reading a lot about it and I have found some posts where they solved it but they don't give the solution. Others were just too old. I'm using a wired connection. Thanks
 
Old 03-12-2017, 01:40 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
Quote:
Originally Posted by bsth123 View Post
No offense but those commands don't work in arch. It uses iw, I'm trying to use wpa_supplicant because according to the wiki if you use wpa you have to. I can get this far
Code:
# wpa_supplicant -D nl80211,wext -i wlan0 -c <(wpa_passphrase "your_SSID" "your_key")
the problem is the portion that starts with a n. That's suppposed to be the accesspoint discovery but when I run the commands to find it I can't, even though it's picking up all my networks. I've been reading a lot about it and I have found some posts where they solved it but they don't give the solution. Others were just too old. I'm using a wired connection. Thanks
I'd tell you to just install then package but that is silly, you got no wifi. So, then why not try what arch has to say about it then?


Wireless network configuration
ArchLinux
 
Old 03-12-2017, 02:37 PM   #7
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
I've tried all that trust me.
 
Old 03-12-2017, 02:46 PM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
rfkill - but chances are the package that deals with that called, rfkill is not installed as that is more common place then not in every Linux Distro I've tried.
Code:
rfkill list all
#to see if it actually is blocked
#if yes then.
rfkill unblock all
as root or sudo.
Quote:
userx@slackwhere⚡️~⚡️$ sudo rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Last edited by BW-userx; 03-12-2017 at 02:49 PM.
 
Old 03-12-2017, 03:10 PM   #9
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
I had to install rfkill. this is what I got

Code:
rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
 
Old 03-12-2017, 03:36 PM   #10
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
I googled "arch linux Intel Corporation Wireless 3160 arch linux driver" because that is what it is looking like it is boiling down to? Their were a few hits for this Intel 3160 and archLinux issues. you'd probably be better off looking into that yourself, because that is all I can do is google for you.

https://bbs.archlinux.org/viewtopic.php?id=193570
 
Old 03-12-2017, 03:50 PM   #11
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
Thanks I appreciate. I'll keep googling.
 
Old 03-12-2017, 04:05 PM   #12
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
Quote:
Originally Posted by bsth123 View Post
Thanks I appreciate. I'll keep googling.
I do not know dick about ArchLinux - but if it has NetworkManager - that is what I always use, it always deals with wifi rather well. it does whatever s needed to connect other then selecting the provider.
 
Old 03-12-2017, 05:33 PM   #13
bsth123
Member
 
Registered: Feb 2017
Distribution: Kubuntu, Debian, FreeBSD
Posts: 195

Original Poster
Rep: Reputation: Disabled
It's not that easy in arch. It has network manager also. The problem is you still need wpa_supplicant. I tried googling some more but the posts I found were old. Arch now (supposedly) has built in support. I've been messing with this for too long. Any suggestions about other distros that would be challenging but not impossible?

Last edited by bsth123; 03-12-2017 at 05:36 PM.
 
Old 03-12-2017, 06:43 PM   #14
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,522

Rep: Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778Reputation: 1778
Quote:
Originally Posted by bsth123 View Post
It's not that easy in arch. It has network manager also. The problem is you still need wpa_supplicant. I tried googling some more but the posts I found were old. Arch now (supposedly) has built in support. I've been messing with this for too long. Any suggestions about other distros that would be challenging but not impossible?
anyone you want to download give a try and see what happens. The choice is yours really.
I'd suggest straight Debian, Slackware, VOID before going with the "knockoffs."
 
Old 03-13-2017, 01:32 AM   #15
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,478
Blog Entries: 8

Rep: Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011Reputation: 3011
Quote:
Originally Posted by bsth123 View Post
Code:
# wpa_supplicant -D nl80211,wext -i wlan0 -c <(wpa_passphrase "your_SSID" "your_key")
the problem is the portion that starts with a n. That's suppposed to be the accesspoint discovery
no, that's supposed to be the driver you use, and from your post #1 i see that your wireless uses a different driver.
in fact it seems you simply copied over text from "man wpa_supplicant".
i also suspect that you don't necessarily need to specify the driver at all.

i also don't think your interface is called "wlan0".
from rfkill output, i'd say "phy0", but make sure with the command "ip link".

Last edited by ondoho; 03-13-2017 at 01:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking not working (Wireless and wired) MintCin.64, does work in 32 iSeth Linux - Networking 8 05-09-2015 12:40 AM
[SOLVED] Getting wireless/wired hardware to work with Debian griffsterb Linux - Hardware 16 12-03-2011 01:47 AM
Can't get Wireless or Wired connection to work leavage Linux - Newbie 5 12-27-2010 03:28 PM
Gutsy wireless connection does not work/ wired works aio85 Linux - Newbie 5 01-14-2008 12:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration