LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 05-01-2012, 02:38 PM   #1
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Rep: Reputation: 1
Can't finish Arch's installation 'cos "can't replace module-init-tools with kmod".


Hi folks. First it cannot be coincidence that I have this problem all the times I try to install Arch, I've done it 4 different times on a virtual machine using VirtualBox and I can asure you that everything looks alright until the troubles start. Here is what happens: I do the main part of the installation a-ok until installing the grub and then rebooting. After that comes creating a new user, creating a password for the user and then upgrading some files, typing: "pacman -Syu" and that's where the trouble begins, there is some conflict shows up between module- init-tools and kmod also when I try to install kde or xorg-video then it tells me if I want to cancel the current operation and upgrade the packages now, I say yes and then: "Proceed with installation?" I say yes again and it appears the following:
"checking package integrity 100%
checking for file conflicts 100%
glibc: /usr/bin/tzselect exists in file system
glibc: /usr/sbin/zdump exists in file system
glibc: /usr/sbin/zic exists in file system
Errors ocurred, no packages were upgraded"


This is what doesn't allow me to finish the installation please I need to know the step by step (command by command) to get this solved and finish up with this.
Finally any extra information about my system or the installation process just ask me and I will tell you what you want.
Greetings and thank you in advance.

Last edited by nando321; 05-01-2012 at 02:39 PM.
 
Old 05-01-2012, 03:02 PM   #2
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
Hi,

Is this trying to install via netinstall or with the core image ?

Netinstall doesnt worked for me because im not able to get network connection. But with the core install it worked well. Sure with any troubles caused by filesystem changes and pacman upgrade.

Have you tried to upgrad pacman first via console command "pacman -Sy" and "pacman -S pacman"?

oh i found same issue here https://bbs.archlinux.org/viewtopic.php?id=140188

and here https://bbs.archlinux.org/viewtopic.php?pid=1082344

ok good luck

'rm /usr/bin/tzselect /usr/sbin/zdump /usr/sbin/zic'

Last edited by raleeha; 05-01-2012 at 03:09 PM.
 
Old 05-01-2012, 03:48 PM   #3
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Hi, thank you for the quick reply. I tried with "pacman -S --force" and then "pacman -S kde" (ignoring the conflict) after the kde installation starts it says "module-init-tools removed" and it is working now. But I can't run kde although I've installed it. It says "command does not exist" or something. And by the way, I did the installation with the core CD.
 
Old 05-01-2012, 09:49 PM   #4
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
you have a ~/.xinitrc or have installed a graphical login manager like kdm, gdm or xdm ?

In /etc/skel you can find some default files for configuring your graphical environment. In ~/.xinitrc you need to uncomment 'exec startkde'.
 
Old 05-02-2012, 09:18 AM   #5
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Hey there. I seem to have installed kdm, I could run it with "rc.d start kdm" but when I want to login it takes over 2 minutes to show a black screen, it seems to me that it is my desktop what appears there but after 5 to 10 more minutes nothing else happens and I can't access a terminal.
Thank you for keeping an eye on this thread. Later.

I would like to correct myself, there's a button that allows me to go into a terminal on the screen after doing the login, I don't really know if this has a solution. Maybe I shouldn't have thought that I could do an Arch installation (just because I could reach the point where I compile the kernel on Gentoo a few days back using the minimal installation guide, after compiling the kernel and installing it something fails ALWAYS) So I decided to give Arch a try.
Finally if this has a solution I would like to know how to work on it (I'm self learner here, with help of video tutorials from Youtube)...

Last edited by nando321; 05-02-2012 at 02:46 PM. Reason: Correcting myself, adding.
 
Old 05-02-2012, 04:22 PM   #6
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
1.
Code:
pacman -Syu
2.
Code:
pacman -S kde
or
Code:
pacman -S kde-meta
3.
Code:
pacman -S kde-l10n-yourlanguagehere
using kdm:

Edit /etc/inittab and comment out

Code:
id:5:initdefault:

[...]

x:5:respawn:/usr/bin/kdm -nodaemon
Add kdm to daemons array in /etc/rc.conf

Code:
DAEMONS=(syslog-ng dbus network crond ... kdm)
Using xinitrc

kdebase-workspace provides startkde. Make sure it is installed. Then edit ~/.xinitrc, uncomment

Code:
exec ck-launch-session startkde
After a reboot or/and login, each execution of Xorg (startx or xinit) will start KDE automatically.

see also here:

https://wiki.archlinux.org/index.php/Kde

btw. maybe you need to read about X.org

https://wiki.archlinux.org/index.php/Xorg

Last edited by raleeha; 05-02-2012 at 04:32 PM.
 
Old 05-04-2012, 10:43 AM   #7
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Ok, I can't make it work, I've reinstalled the whole system 3 more times and still I can't login. Thank you for your attention but I'm giving up now.
 
Old 05-05-2012, 03:01 AM   #8
Babertje
Member
 
Registered: Jun 2009
Location: Haarlem, The Netherlands
Distribution: Archlinux
Posts: 125

Rep: Reputation: 20
There is another straight forward method, start your desktop sesion in /etc/inittab now you don't need to use kdm in your daemon array
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "/etc/init.d/apache2" start VS "apache2ctl start" with passenger module (ruby/rails) arond Linux - Server 1 12-13-2010 10:56 AM
[SOLVED] CLFS ch10.43: module-init-tools-3.4 testing fails - "Unknown endian" Bolts Linux From Scratch 1 10-29-2010 04:04 AM
How do you install thinks on Arch? What is arch for "emerge", "apt-get" etc? just a man Arch 8 02-04-2010 11:06 AM
After "kmod-nvidia" installation, X works only till power down linqacc Fedora 3 12-13-2008 11:34 AM
PC speaker still sounding without "pcspkr" module... (Arch) Azzy Linux - Software 2 10-31-2008 08:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 01:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration