-   Arch (
-   -   Arch stopped booting after sysupgrade (

vharishankar 11-23-2005 10:58 PM

Arch stopped booting after sysupgrade
Yes. it did change from devfs to udev, but I sure changed all the fstab entries to match the correct ones.

I get no errors on booting, but what happens is that while hotplug is running, system just shuts off (monitor and all).

Here's my fstab in arch: any problems?

# /etc/fstab: static file system information
# <file system>        <dir>        <type>    <options>          <dump> <pass>
none                  /dev/pts      devpts    defaults            0      0
none                  /dev/shm      tmpfs    defaults            0      0
tmpfs                  /tmp          tmpfs    defaults            0      0
usbfs                  /proc/bus/usb usbfs  defaults            0      0

/dev/hdc              /mnt/cd  auto      ro,user,noauto,unhide  0      0
/dev/hdd                /mnt/dvd  auto      ro,user,noauto,unhide  0      0
/dev/floppy/0          /mnt/fl  vfat      user,noauto            0      0

/dev/hdb2 swap swap defaults 0 0
/dev/hdb3 / reiserfs defaults 0 0

Here's my menu.lst from Debian which I actually use to boot Arch (I didn't install GRUB from Arch. Used the Debian one which is already present)


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb3.
title                Arch Linux 0.7
root                (hd1,2)
kernel                /boot/vmlinuz26 root=/dev/hdb3

vharishankar 11-24-2005 04:19 AM

It was a hotplug problem, but now after removing hotplug my hardware is not detected any more. None of the modules are loaded.

Is there any alternative, because I cannot get my net to work anymore!

slackie1000 11-24-2005 04:32 AM

hi there,
which CD are you using? 0.7? did you make the update? do you have the new initscripts installed?
it is not a solution but i would recommend hwdetect. hotplug is getting deprecated in Arch and the new hardware detection tool looks quite nice - i don't use it.
if you have the possibility, through other distro in your setup, make the download of the necessary things: hwdetect, initscripts and the latest kernel and take hotplug out of your daemons list in rc.conf.

vharishankar 11-24-2005 05:03 AM

Hey Slackie, thanks for the tips. But I got some help from the forums

I just had to copy the newer rc.conf file and put it in place of the old one and make the older changes manually and *poof* it worked.

Now all works. I'm now inside Arch Linux.

juvestar15 11-24-2005 11:26 PM

You can use hwd if hotplug still gives you troubles. When upgrading, conf files can be created, so make sure everytime you do it, check if new conf files were made.

syg00 11-24-2005 11:38 PM


Originally posted by Harishankar
I just had to copy the newer rc.conf file and put it in place of the old one and make the older changes manually and *poof* it worked.
Yep, etc-update would be handy, huh .... :rolleyes: :rolleyes:

vharishankar 11-24-2005 11:39 PM

Yes, hotplug is no longer used to detect hardware. I think it uses hwdetect...

vharishankar 11-24-2005 11:40 PM


Yep, etc-update would be handy, huh .... :rolleyes: :rolleyes:
Your point being...? :confused:

syg00 11-25-2005 12:34 AM

My point being you did a sysupgrade and didn't even know that some config file(s) potentially were updated - or not because you had them set to NoUpgrade.
You apparently didn't even know you had them excluded.
And yes, it *is* covered in the manpage.

This is a significant exposure - obviously some people are going to get caught.

vharishankar 11-25-2005 01:01 AM

I know that config files get updated during upgrades, syg00. I have known it for a long time now since I installed Debian. Only difference is that with Debian I hardly had to do any work myself because it handled the upgrades seamlessly.

You assume too much and you have such a superior attitude.

What I wasn't aware was that the kernel got updated.

Most OSes don't update the kernel by default. I got caught I admit, but the reason was the kernel update. Not the config file. Arch did update the kernel and I should have known better.

Leave it well alone. My problem has been solved... I know that you guys have better knowledge than me but I really don't want to prove any points here.

All times are GMT -5. The time now is 05:43 PM.