-   Arch (
-   -   After-update tweaks... (

ButterflyMelissa 05-19-2012 10:57 AM

After-update tweaks...
Hey gang,

Okay, so I did an update (the most dreaded moment of the weekend) and now, I'm confronted with some "surprises":
- The desktop switcher and clock are no longer "stuck" to the right top but now "float" somewhere along, how do I get them to stick to the upper right corner as before?
- The user (me, in fact) can no longer switch off the box, only log out. I enter in the GDM screen where I do have a shutdown option. How to I allow the user to shut the box down?

I know...I should know this by now, but my weekend is NOT going as planned and ... oh, well, just nudge me in the right direction, please.


Edit : I use XFCE as desktop, and Arch as distro...
Edit 2 : The shutdown has been solved (sorta) - the shutdown is...somewhere else now. In the Applications menu all the way down. That's typically Arch: there's always something different after an update...


Babertje 05-21-2012 02:55 PM

If you use a proprietary video driver like nvidia, re-install it, my KDE-desktop was upsidedown and mirrored
caused by libgl-8.0.3-1-(....).pkg.tar.xz

ButterflyMelissa 05-21-2012 03:01 PM


If you use the NVIDIA driver, re-install it, got mine desktop upsidedown and mirrored
What????????? :confused: Okay, you win, it's not that bad over here. I do use an NVIDIA here but the up is still up.

What I do have is that the clock and desktop switcher are now not anchored to the right top as before. I observed that on an other box as well, so, I know it's not just my main box, but the others as well...

But, thanks for the heads-up...I'll make a note in case I do get into that trouble...


Babertje 05-22-2012 03:27 AM

Yes Nvidia seems to run fine and reports no errors thats the quircky about it.

I recommend that you go to runlevel 3 just do a

NVIDIA*run -a -q -N -s --ui=none
to recompile the nvidia module and straighten the opengl conflicts out.
The above options (-a -q -N -s --ui=none) are: accept-licence,questions:give-standard-anwsers,no-network-update,verbose-off,no-user-interface

jv2112 06-03-2012 03:36 PM

Make sure you avoid calling dbus in your ~.xinitrc file when launching xfce. Slim has issues with it with recent changes.



  1 #!/bin/sh
  2 #
  3 # ~/.xinitrc
  4 #
  5 # Executed by startx (run your window manager from here)
  8 if [ -d /etc/X11/xinit/xinitrc.d ]; then
  9  for f in /etc/X11/xinit/xinitrc.d/*; do
 10    [ -x "$f" ] && . "$f"
 11  done
 12  unset f
 13 fi
 15 # exec gnome-session
 16 # exec startkde
 17 exec startxfce4
 18 exec ch-launch-session /usr/bin/thunar --daemon &
 19 # ...or the Window Manager of your choice
                                                              5,52          All

ButterflyMelissa 06-03-2012 11:03 PM

Thanks jv1212! I just did a quick scan of the thing, no problems there. I was somewhat surprised to see that profound change in behaviour after an update. It is stuff one can learn to live with, but should'nt HAVE to live with.

I'll be curious what the next update will bring. That's why I dont update that often, but only once per two weeks... ;)


All times are GMT -5. The time now is 04:18 PM.