LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (https://www.linuxquestions.org/questions/arch-29/)
-   -   After installing Nvidia drivers black screen? (https://www.linuxquestions.org/questions/arch-29/after-installing-nvidia-drivers-black-screen-4175653896/)

drillsar 05-14-2019 11:43 AM

After installing Nvidia drivers black screen?
 
I get a black screen when rebooting.

I followed these instructions

https://wiki.archlinux.org/index.php/NVIDIA

determined that I have the N130 Family card
installed package nvidia



added this to kernel

after rw nvidia-drm.modeset=1

this is all I did.. and cant see anything..

drillsar 05-14-2019 12:07 PM

if I add nomodeset then I can log in. Maybe its because I didnt configure it yet?

drillsar 05-15-2019 10:08 AM

if I add nvidia-drm.modeset=1 get black screen and nothing happens. What is the difference between nomodeset and Nvidia-drm.modeset=1? I even tried Nvidia-drm.modeset=0. The only thing that worked was if I add nomodeset. added this to mkinitcpio

MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"

At this point I don't know what to do in order to fix this.

drillsar 05-15-2019 12:07 PM

I now did the following and now got rid of black screen but Nvidia Drm not being loaded.

I have Nvidia version 418.74-1

I added this in /etc/modprobe.d/nvidia-drm-modeset.conf

Code:

options nvidia_418.74-1_drm modeset=1
I then added in /etc/makinitcpio.conf

Code:

FILES="/etc/modprobe.d/nvidia-drm-modeset.conf"
I then ran the following to regenerate ti initramfs.. not sure if I am doing that correctly

Code:

mkinitcpio -p linux
I took out the kernel parameter nvidia-drm.modeset=1

I rebooted system and ran the this:

Code:

xrandr --properties | grep PRIME
No output? Output Should be Prime Synchorization 1

so then I checked to see if drm is loaded with this command:

Code:

sudo cat /sys/module/nvidia-drm/parameters/modeset/
The output N

So why isn't this being loaded? Am I missing something here? I am going nuts

drillsar 05-15-2019 12:32 PM

I now got it to work.. not sure if this was correct way of doing it.

Deleted the /etc/modprobe.d/nvidia-drm-modeset.conf

removed FILES="/etc/modprobe.d/nvidia-drm-modeset.conf"

ran this code:

Code:

sudo mkinitcpio -P -M linux
added this to kernel option

Code:

nvidia-drm.modeset=1
rebooted system still goes black and nothing but waited 20 seconds and hit some keys and got a login not sure why..

Checked to see if drm is loaded

Code:

sudo cat /sys/module/nvidia-drm/parameters/modeset/
Output Y

Just curious why I have to hit some keys in order to see login screen?


All times are GMT -5. The time now is 03:49 AM.