LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux
User Name
Password
antiX / MX Linux This forum is for the discussion of antiX and MX Linux.

Notices


Reply
  Search this Thread
Old 07-10-2019, 11:37 AM   #1
LinWinux
LQ Newbie
 
Registered: May 2019
Location: Germany
Distribution: MX Linux & Linux Mint XFCE
Posts: 18

Rep: Reputation: Disabled
Vivaldi Browser Update in MX 18.3 ... BREAKS Vivaldi


Hi everyone. Today I tried installing Vivaldi from the MX package manager. Installation went smoothly, no errors ... but after it was done Vivaldi simply would not start. Not via GUI or via the terminal. No error message from the GUI, but in the terminal there was an error about lib something or another being incorrect and so the command for Vivaldi couldn't be executed.
Looked for that file in Synaptic, but no joy there, file doesn't exist.
(I'm using MX with systemd because otherwise getting PIA and another program of mine to work is a pain in the rear)

This was a huge problem for me becuse Vivaldi has all of the bookmarks and open tabs for some really important & ongoing business work that I'm doing.

No problem though, got myself the latest stable version ... vivaldi-stable_2.4.1488.35-1_amd64.deb file and installed that instead. Wonderful, Vivaldi works like a charm, everything is perfectly okay and all of my settings are working like they should.

Then up comes the MX Update Manager with ... yup, you guessed it, the latest & greatest update to the current Vivaldi 2.6 version. Well, guess what happened after the update ??? That's right, identical to the problem that I had earlier, Vivaldi no longer worked because something must have gotten broken. Try to start Vivaldi via the terminal, nope, exact same error as before with some lib file. I don't remember the specific name of the file because I neglected to write it down before fixing Vivaldi once again by first deleting the updated version, followed by then installing the stable .deb file again. Hurrah, Vivaldi once again works exactly as it should.

PROBLEM IS NOW that the update manager still wants to update Vivaldi to version 2.6 as it did before. Since I already know what's going to happen, I'm obviuosly not going to install the newest Vivaldi update. BUT THAT ALSO MEANS that I can't install any other updates either, since it's not possible to select or deselect what I don't want to update (as in my other setup with Linux Mint). So my question is this:

Does anyone know how to selectively disable an update for a particular package in MX 18.3 Continuum? If I can disable the Vivaldi updates, then I'll be able to update everything else which would obviously be desireable.

.
 
Old 07-10-2019, 12:40 PM   #2
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 3,036

Rep: Reputation: Disabled
Maybe this.

https://www.tecmint.com/disable-lock...tu-debian-apt/
 
Old 07-11-2019, 03:03 AM   #3
LinWinux
LQ Newbie
 
Registered: May 2019
Location: Germany
Distribution: MX Linux & Linux Mint XFCE
Posts: 18

Original Poster
Rep: Reputation: Disabled
Thanks a bunch, but that page didn't help. Some of the directions there don't appear to make sense either, but I tried them anyway. The first suggestion for example yielded no error, but neither did it provide me with any confirmation dialogue as clearly shown in the image. So there's no way for me to know if that worked. Even worse, when you look at the unhold command confirmation, clearly the image displays a ..."apache was already not on hold" ... message which lies in direct conflict with the earlier hold confirmation. How can something be ALREADY NOT on hold if the previous command prompted a hold confirmation?

So I moved on to the next section with the ... "Package / Pin" ... commands. But when I tried that I received an error in the terminal, stating that the command "package" was not recognized. I didn't try it with sudo, but I don't believe that that would have made a difference. The remainer of that page gets into scripts which I wa trying to avoid.

Thanks for trying, but I still don't know how to update MX Linux without updating Vivaldi. Heck, maybe I'll get lucky and a newer working release of Vivaldi appears before I get too far behind in updates. As of last night everything was updated since Vivaldi was the last package that I installed. This problem goes beyond Vivaldi though. I tried installing Iridium Browser as well since that's actually my favorite browser. That didn't work because at the very last command an error appeared in the terminal, having to do with dependencies and a broken package ... even though Synaptic did not confirm that anything was broken.
I wish MX developers would look into these issues ...
Something is clearly behaving buggy with the latest stable Vivaldi & Iridium in the MX repository.

.
Attached Thumbnails
Click image for larger version

Name:	MX-Linux-Hold-Package1.png
Views:	3
Size:	47.6 KB
ID:	30889   Click image for larger version

Name:	MX-Linux-Hold-Package2.png
Views:	3
Size:	104.3 KB
ID:	30890  
 
Old 07-11-2019, 09:21 AM   #4
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17
Posts: 5,783
Blog Entries: 21

Rep: Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823Reputation: 2823
Edit: never mind.

Last edited by rokytnji; 07-11-2019 at 09:22 AM.
 
Old 07-11-2019, 10:04 AM   #5
LinWinux
LQ Newbie
 
Registered: May 2019
Location: Germany
Distribution: MX Linux & Linux Mint XFCE
Posts: 18

Original Poster
Rep: Reputation: Disabled
Stupid me, such a simple way to fix the problem ... Just get into Synaptic, followed by taking a look at the package sources for the updates. No wonder that the package command couldn't be recognized. The updates for Vivaldi aren't presented from an installed package, but rather directly from the Vivaldi update repository. Once I was able to recognize that, I just disabled the Vivaldi upgrade path ... problem solved.
Saved the settings ... refreshed the update manager ... and voila, no more Vivaldi with conflicts to update.
Did some new updates after that, followed by restarting Vivaldi. As stated, problem solved.

.
Attached Thumbnails
Click image for larger version

Name:	MX-Linux-Hold-Package3.jpg
Views:	1
Size:	95.5 KB
ID:	30892  
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Sync your teeth into power browser Vivaldi's largest update so far LXer Syndicated Linux News 0 09-29-2018 07:35 AM
LXer: Vivaldi Continues To Build Amazing Features With Vivaldi 1.11 LXer Syndicated Linux News 0 08-12-2017 06:09 PM
LXer: Vivaldi Technologies Vivaldi Web Browser LXer Syndicated Linux News 0 10-28-2016 07:26 PM
Vivaldi - new browser from the original Opera guys? JWJones Linux - General 9 01-29-2015 05:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux

All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration