LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   antiX / MX Linux (https://www.linuxquestions.org/questions/antix-mx-linux-127/)
-   -   Unable to install AntiX-19-base on Samsung laptop (Via electronics) (https://www.linuxquestions.org/questions/antix-mx-linux-127/unable-to-install-antix-19-base-on-samsung-laptop-via-electronics-4175664684/)

hazel 11-21-2019 10:37 AM

Unable to install AntiX-19-base on Samsung laptop (Via electronics)
 
I downloaded this and burned it on my desktop machine. Checked the md5sum before burning it and used slowest possible speed. It boots successfully on the laptop and I was able to login as root, but the cli-installer script keeps breaking, immediately after asking whether I am using net-install (answer is no obviously). Tried startx and got "Screens found but none have a suitable configuration". The Xorg log showed that the Openchrome driver had been loaded successfully but that was as far as it went.

There seems to be a graphical login screen of some kind on console 7 but clicking on "startx" had no effect.

The attempt has deleted my old AntiX, so I shall need help to get this machine working again.

michaelk 11-21-2019 11:35 AM

As a frame of reference I started the antiX-19_x64-base.iso file in a virtual machine and it automatically booted straight into a desktop. No need to login as root etc. The graphical install worked.

Have you tried booting using safe mode or other options in the boot menu?

hazel 11-21-2019 11:46 AM

No. I'd forgotten there was a GRUB menu! I just took the default. I'll try again and see if safe mode does better.

hazel 11-21-2019 12:36 PM

Thanks, Michael! Booting in safe mode did the trick. The graphical installation went smoothly but there's still a lot of configuration to do. The desktop is a bit weird, lots of ghosts and the aspect ratio doesn't match my screen exactly. I'll have to do some reading.

I haven't got wifi yet but that can wait.

michaelk 11-21-2019 01:17 PM

Good.

hazel 11-22-2019 06:11 AM

I've found out why the video is so bad. It's using the vesa driver instead of openchrome. Maybe that was what was running in the safe mode boot that I installed it from. I suppose I'll have to put a video config file in xorg.conf.d to fix that.

I don't much like the new package installer. It looks Ubuntuish to me, and I think it's going to confuse my friend badly when I update her desktop machine to this version. She's not computer-savvy at all and she's got used to using synaptic. If I install synaptic, will the control centre use that instead? Silly question! I should just try it and see.


All times are GMT -5. The time now is 07:32 AM.