-   antiX / MX Linux (
-   -   Trying to disable spectre mitigations (

Grobe 01-07-2021 06:00 PM

Trying to disable spectre mitigations

Just installed MX on an older computer, that I plan to use to encode video records using AviDemux. The job in question would take several days to complete, and I'll try to disable any spectre mitigations in hope that will maximize the conversion job.

The computer in question is used for this purpose only, there is no personal files on it nor is it connected to internet.MX Linus is just installed and updated.

I came over this article on the web:

And so I entered the grub menu on restart, and made 3 lines after third argument from top: "nospectre_v2", "nospec_store_bypass_disable" and "nospectre_v1".

Unfortunately, the text returned after I started booting said that those arguments was not recognized (can't remember the excact phrase now).

Is there something I've missed? Are those commands not supported by MX Linux? Something else I haven't considered?
Can I somehow boot MX Linux in such a way that the spectre mitigations have as little as possible impact on performance?

Thanks in advance


After I wrote this thread, I found this web page

Where this command is suggested:
mitigations=off will disable all optional CPU mitigations.

I added that line in the grub menu, and couldn't see any message suggesting it isn't valid, so I guess it work.

The only thing left, I don't know if it's related - I had a usb stick where some of the movie clips are stored. I opened the first videofile to VLC from within Caja (just to verify I'd selected the correct clip) and wathc a couple of seconds before I closed VLC. I then opened the next video clip same way, but this time VLC did not started, nor was there any r/w activity on the usb stick (a corsair model with a bright blue led showing activity). Tried to open VLC from main meny, but nothing. Tried to look for VLC using htop, seemingly nothing.
So I forgot about VLC and proceeded using AviDemux both to inspect the video clips and do the encoding.

business_kid 01-08-2021 07:04 AM

The handiest way is to downgrade the cpu microcode to something from pre-spectre days. The main issue IIRC was VMs leaking not being insulated from / in certain circumstances, so the VM could be penetrated, then your server. You're not worried about meltdown, so I take it you have an AMD or Arm CPU?

ondoho 01-08-2021 03:05 PM

Are you sure the mitigations are enabled?
Most search results recommend this:

$ git clone
$ cd spectre-meltdown-checker/
$ sudo ./

Disclaimer: I'm not responsible if you break your machine because of running unknown code with sudo. Check the github repo for comments & issues.

(though I believe the info is written into some file under /proc in plain text)

All times are GMT -5. The time now is 10:14 PM.