LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux
User Name
Password
antiX / MX Linux This forum is for the discussion of antiX and MX Linux.

Notices


Reply
  Search this Thread
Old 02-29-2020, 11:17 AM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,839

Rep: Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118
NTP Issues:


cannot get time to be right every time I login. muilt boot, trying to setup ntp time on all systems starting with this one to keep time right in all of them. not working here...
Code:
$ sudo timedatectl set-ntp false
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
Code:
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: leapsecond file ('/usr/share/zoneinfo/leap-seconds.list'): loaded, expire=2020-06-28T00:00:00Z last=2017-01-01T00:00:00Z ofs=37
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen and drop on 0 v6wildcard [::]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen and drop on 1 v4wildcard 0.0.0.0:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 2 lo 127.0.0.1:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 3 wlan0 172.16.226.210:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 4 lo [::1]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 5 wlan0 [fe80::8454:5c98:9ad2:c367%2]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listening on routing socket on fd #22 for interface updates
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
userx@bobsyouruncle:~
$ sudo ntpdate
29 Feb 05:11:20 ntpdate[13777]: no servers can be used, exiting
userx@bobsyouruncle:~
$ sudo nano /etc/ntp.conf
userx@bobsyouruncle:~
$ sudo ntpdate
29 Feb 05:11:58 ntpdate[13822]: no servers can be used, exiting
userx@bobsyouruncle:~
$ sudo timedatectl set-ntp false
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
userx@bobsyouruncle:~
$ sudo apt install ntpdate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ntpdate is already the newest version (1:4.2.8p12+dfsg-4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
userx@bobsyouruncle:~
$ sudo apt install ntp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ntp is already the newest version (1:4.2.8p12+dfsg-4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
config
Code:
# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
pool 0.debian.pool.ntp.org iburst
pool 1.debian.pool.ntp.org iburst
pool 2.debian.pool.ntp.org iburst
pool 3.debian.pool.ntp.org iburst


#pool 0.us.pool.ntp.org iburst
#pool 1.us.pool.ntp.org iburst
#pool 2.us.pool.ntp.org iburst
#pool 3.us.pool.ntp.org iburst
neither of them work.

source for trying to fix this not working
https://www.maketecheasier.com/sync-...th-ntp-server/
 
Old 02-29-2020, 11:32 AM   #2
sageb1
LQ Newbie
 
Registered: May 2017
Location: BC Canada
Distribution: Mint
Posts: 4

Rep: Reputation: Disabled
# pool.ntp.org maps to about 1000 low-stratum NTP servers. Your server will
# pick a different set every time it starts up. Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>

Set NTP true.

Quote:
Originally Posted by BW-userx View Post
cannot get time to be right every time I login. muilt boot, trying to setup ntp time on all systems starting with this one to keep time right in all of them. not working here...
Code:
$ sudo timedatectl set-ntp false
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
Code:
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: leapsecond file ('/usr/share/zoneinfo/leap-seconds.list'): loaded, expire=2020-06-28T00:00:00Z last=2017-01-01T00:00:00Z ofs=37
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen and drop on 0 v6wildcard [::]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen and drop on 1 v4wildcard 0.0.0.0:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 2 lo 127.0.0.1:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 3 wlan0 172.16.226.210:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 4 lo [::1]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listen normally on 5 wlan0 [fe80::8454:5c98:9ad2:c367%2]:123
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: Listening on routing socket on fd #22 for interface updates
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
Feb 29 03:49:45 bobsyouruncle ntpd[3933]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
userx@bobsyouruncle:~
$ sudo ntpdate
29 Feb 05:11:20 ntpdate[13777]: no servers can be used, exiting
userx@bobsyouruncle:~
$ sudo nano /etc/ntp.conf
userx@bobsyouruncle:~
$ sudo ntpdate
29 Feb 05:11:58 ntpdate[13822]: no servers can be used, exiting
userx@bobsyouruncle:~
$ sudo timedatectl set-ntp false
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
userx@bobsyouruncle:~
$ sudo apt install ntpdate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ntpdate is already the newest version (1:4.2.8p12+dfsg-4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
userx@bobsyouruncle:~
$ sudo apt install ntp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ntp is already the newest version (1:4.2.8p12+dfsg-4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
config
Code:
# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
pool 0.debian.pool.ntp.org iburst
pool 1.debian.pool.ntp.org iburst
pool 2.debian.pool.ntp.org iburst
pool 3.debian.pool.ntp.org iburst


#pool 0.us.pool.ntp.org iburst
#pool 1.us.pool.ntp.org iburst
#pool 2.us.pool.ntp.org iburst
#pool 3.us.pool.ntp.org iburst
neither of them work.

source for trying to fix this not working
https://www.maketecheasier.com/sync-...th-ntp-server/
 
Old 02-29-2020, 11:41 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,839

Original Poster
Rep: Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118
Quote:
Originally Posted by sageb1 View Post
# pool.ntp.org maps to about 1000 low-stratum NTP servers. Your server will
# pick a different set every time it starts up. Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>

Set NTP true.
how will setting it to true do any good ... when you see the message... BUT to humor you
Code:
$ sudo timedatectl set-ntp true
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
I've never had to join a pool ... I just add the us address and it works for every other distro I've ever did this with. this MX is a mix of nuts no systemd but it has systemd and whatever it is using for the init system to get it booted.


Quote:
Originally Posted by that reference page
With MX Linux becoming so popular lately, an example regarding this OS seems fitting to start with. It’s also a special case. It “kind of” has systemd, but it “kind of” doesn’t.
https://www.maketecheasier.com/sync-...th-ntp-server/
 
Old 02-29-2020, 04:07 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,690

Rep: Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215
Quote:
$ sudo timedatectl set-ntp true
System has not been booted with systemd as init system (PID 1). Can't operate.
As far as I know MX still ships with systemd but it is not enabled by default. It is still using sysvinit.

Have you tried starting the ntpd deamon? Have you tried running ntpdate using a time server?

sudo ntpdate -u -q 0.debian.pool.ntp.org

Had to install it as VM to verify...

ntpd was automatically installed and runs by default. Not sure what is causing the time error at the moment...
 
Old 02-29-2020, 04:30 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,839

Original Poster
Rep: Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118
Quote:
Originally Posted by michaelk View Post
As far as I know MX still ships with systemd but it is not enabled by default. It is still using sysvinit.

Have you tried starting the ntpd deamon? Have you tried running ntpdate using a time server?

sudo ntpdate -u -q 0.debian.pool.ntp.org

Had to install it as VM to verify...

ntpd was automatically installed and runs by default. Not sure what is causing the time error at the moment...
install as a VM to verify?
where has linux gone too to have to do such a thing just to get it to keep the right time.... I installed mx so not to have systemd ... looks like its going to be another trash can disto if this keeps up.

that laptop is unavailable to me right now to do anything to it.
 
Old 02-29-2020, 04:50 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,690

Rep: Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215Reputation: 3215
It was just a comment that I installed MX as a VM...

MX is not using systemd but you are running systemd commands which is why you are seeing the error with the timdatectl command.

Will wait...

Last edited by michaelk; 02-29-2020 at 05:06 PM.
 
Old 02-29-2020, 07:41 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,839

Original Poster
Rep: Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118Reputation: 2118
Quote:
Originally Posted by michaelk View Post
It was just a comment that I installed MX as a VM...

MX is not using systemd but you are running systemd commands which is why you are seeing the error with the timdatectl command.

Will wait...
it is like a hybrid so I've read. that is what is confusing me. because it too even says something about not being in a VM too when booting it up... strange that is where i confused what you were saying about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] some issues with CentOSv7 and NTP with timedatectl set-ntp yes lleb Linux - Server 3 03-30-2015 08:45 PM
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 07:35 PM
NTP's ntp.conf pxumsgdxpcvjm Linux - Server 2 08-30-2007 09:34 PM
NTP cannot work with timeserver, NTP-d can jerryvapps Linux - Networking 0 08-04-2004 02:04 PM
NTP cannot use server, NTP -d can jerryvapps Linux - Newbie 0 07-28-2004 02:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux

All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration