LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux
User Name
Password
antiX / MX Linux This forum is for the discussion of antiX and MX Linux.

Notices


Reply
  Search this Thread
Old 01-20-2021, 09:46 AM   #1
etcetera
Member
 
Registered: Aug 2004
Posts: 312

Rep: Reputation: 16
Network speed - AntiX on Dell Dimensions 2400


I have up to 400MB/sec yet the Dell Dimensions 2400 running latest AntiX 19 only runs at 10-12MB/sec download speed according to speedtest . net.

No wifi card in the machine, it's ethernet to the NIC

I get it's a 17 year old machine that's 32-bit but is there anything can be done, is it a hardware issue or a driver issue?

will troubleshoot

$ ifconfig -a
$ iwconfig
$ cat /etc/resolv.conf
$ ping -c4 you're-router's-ip
$ ping -c4 www.google.com

and

full-duplex, half-duplex, and 10/100/1000 settings

ethtool

Open DNS?
OpenDNS as DNS resolvers - addresses are 208.67.222.222 and 208.67.220.220

will post dig times

lsmod and lspci

Last edited by etcetera; 01-20-2021 at 10:07 AM.
 
Old 01-20-2021, 03:42 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 22,285

Rep: Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547
It's a minor grievance but typically network speed tests are in bits versus bytes per second i.e Mb/s versus MB/s.

The builtin Ethernet is only 10/100 (AFAIK) so unless you added a 1000 base-t PCI adapter your not going to get more then 12MB/s or 96mb/s network speeds. There is a bit of tcp/ip overhead which is why you are not getting exactly 12.5 MB/s or 100Mb/s.

There could be other problems with your network. Are other computers on your network seeing 400Mb/s download speeds? Are all of your other deivces i.e. MODEM, router, switches etc 1000 base-t Ethernet?

iperf is a great tool to check networking on your LAN between different computers.

Last edited by michaelk; 01-20-2021 at 08:31 PM.
 
1 members found this post helpful.
Old 01-21-2021, 01:23 AM   #3
etcetera
Member
 
Registered: Aug 2004
Posts: 312

Original Poster
Rep: Reputation: 16
Yeah, other computers are getting the full 400MB/sec. Just this one. It has a 100 Mb/sec network card but only getting 5-10MB.
The issue is with this computer.

Ethtool shows that it's full duplex 100. Ping is awful, 20+ seconds to this site. Tried a different cable.

Tried new DNS entries in /etc/resolv.conf

Out of ideas at this point.
 
Old 01-21-2021, 02:02 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 18,402
Blog Entries: 12

Rep: Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622Reputation: 5622
Quote:
Originally Posted by etcetera View Post
It has a 100 Mb/sec network card but only getting 5-10MB.
10MB/s are 80Mb/s - that's not too far from 100Mb/s.
 
Old 01-21-2021, 05:07 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 22,285

Rep: Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547Reputation: 4547
Please make sure you are using MB and Mb correctly. Again 12 MB is the max for a 100 Mb network adapter.

Have you tried running iperf between computers yet? If so what are the results.

20 seconds ping time does seem excessive but not sure if that is related to speed yet.
 
Old 01-21-2021, 08:16 AM   #6
etcetera
Member
 
Registered: Aug 2004
Posts: 312

Original Poster
Rep: Reputation: 16
I will take a screenshot of the speedtest . net output
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best distro for Dell Dimensions 2400 etcetera Linux - Hardware 14 12-06-2020 02:29 PM
[SOLVED] Conky display gets corrupted since updating Antix-16 to Antix-17 hazel Linux - Distributions 3 12-18-2017 09:55 AM
Need help with my Dell Dimensions 2400 pc jberry46 Linux - Newbie 3 03-19-2008 10:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux

All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration