LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   antiX / MX Linux (https://www.linuxquestions.org/questions/antix-mx-linux-127/)
-   -   Network speed - AntiX on Dell Dimensions 2400 (https://www.linuxquestions.org/questions/antix-mx-linux-127/network-speed-antix-on-dell-dimensions-2400-a-4175688950/)

etcetera 01-20-2021 08:46 AM

Network speed - AntiX on Dell Dimensions 2400
 
I have up to 400MB/sec yet the Dell Dimensions 2400 running latest AntiX 19 only runs at 10-12MB/sec download speed according to speedtest . net.

No wifi card in the machine, it's ethernet to the NIC

I get it's a 17 year old machine that's 32-bit but is there anything can be done, is it a hardware issue or a driver issue?

will troubleshoot

$ ifconfig -a
$ iwconfig
$ cat /etc/resolv.conf
$ ping -c4 you're-router's-ip
$ ping -c4 www.google.com

and

full-duplex, half-duplex, and 10/100/1000 settings

ethtool

Open DNS?
OpenDNS as DNS resolvers - addresses are 208.67.222.222 and 208.67.220.220

will post dig times

lsmod and lspci

michaelk 01-20-2021 02:42 PM

It's a minor grievance but typically network speed tests are in bits versus bytes per second i.e Mb/s versus MB/s.

The builtin Ethernet is only 10/100 (AFAIK) so unless you added a 1000 base-t PCI adapter your not going to get more then 12MB/s or 96mb/s network speeds. There is a bit of tcp/ip overhead which is why you are not getting exactly 12.5 MB/s or 100Mb/s.

There could be other problems with your network. Are other computers on your network seeing 400Mb/s download speeds? Are all of your other deivces i.e. MODEM, router, switches etc 1000 base-t Ethernet?

iperf is a great tool to check networking on your LAN between different computers.

etcetera 01-21-2021 12:23 AM

Yeah, other computers are getting the full 400MB/sec. Just this one. It has a 100 Mb/sec network card but only getting 5-10MB.
The issue is with this computer.

Ethtool shows that it's full duplex 100. Ping is awful, 20+ seconds to this site. Tried a different cable.

Tried new DNS entries in /etc/resolv.conf

Out of ideas at this point.

ondoho 01-21-2021 01:02 AM

Quote:

Originally Posted by etcetera (Post 6210157)
It has a 100 Mb/sec network card but only getting 5-10MB.

10MB/s are 80Mb/s - that's not too far from 100Mb/s.

michaelk 01-21-2021 04:07 AM

Please make sure you are using MB and Mb correctly. Again 12 MB is the max for a 100 Mb network adapter.

Have you tried running iperf between computers yet? If so what are the results.

20 seconds ping time does seem excessive but not sure if that is related to speed yet.

etcetera 01-21-2021 07:16 AM

I will take a screenshot of the speedtest . net output


All times are GMT -5. The time now is 09:08 AM.