LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   antiX / MX Linux (https://www.linuxquestions.org/questions/antix-mx-linux-127/)
-   -   MX Linux Update Manager totally stuck after completing Updates (https://www.linuxquestions.org/questions/antix-mx-linux-127/mx-linux-update-manager-totally-stuck-after-completing-updates-4175653364/)

LinWinux 05-05-2019 05:14 AM

MX Linux Update Manager totally stuck after completing Updates
 
I've been using MX17 and later MX18 for a couple of years. After not doing any updates for about 10 to 12 weeks on one of our lesser used older HP laptops, there were eventually 218 updates available. These were done and I watched the updates happening on the screen. No errors anywhere.But when the terminal finished with them and the window was closed by me, the update manager never refreshed. It still showed the same 218 updates available.

I tried rebooting but that didn't change anything. Tried doing the updates again, but nothing happened at all. That makes sense though, since I saw that the updates were already done earlier. Tried powering off and on again, no change. I simply can't get the update reminder for those 218 updates to go away. Rechecking for updates changes nothing either, it always stays on the same stuck number of updates now. Everything else works perfectly fine, no problems or errors anywhere.

I don't have access to that system right now since the laptop is located at our vacation place. Just hoping that someone heard of this before, with a fix that can be easily implemented once I get my hands on that HP laptop again. The specific model is an HP 6730s with 4GB RAM, Dual-Core 2.54Ghz, Gigabit LAN, WiFi 'n' Draft, and MX Linux 18.1 without any other OS. Thanks in advance for any suggestions.

rokytnji 05-06-2019 06:10 PM

I'd

Code:

sudo apt-get -f install
in MX XFCE Terminal

to look for any left overs that did not complete first.

LinWinux 05-07-2019 08:21 AM

Thank you. I'll try that as soon as I get a chance ...

LinWinux 05-08-2019 10:57 AM

Alright, I was able to figure out what the problem was. Apparently during that long stretch of not applying any updates, a new rolling distribution version of MX Linux was released. The new distribution version apparently included a change or two in the package management which then caused for the update manager not to work correctly anymore. I was able to duplicate the problem on two other machines, all of which had MX Linux 18 Live USB sticks that were used for the installation of MX Linux. Since then, MX 18.1 had been upgraded to MX 18.2 in the repos. With my older Live USB stick the error occurred on both machines. However, as soon as I did a ...

Code:

sudo apt-get dist-upgrade
followed by an immediate ...

Code:

sudo apt-get update
... on each machine, the problem disappeared. :)

I then created a new Live USB stick with the latest MX Linux, followed by testing that on the same two machines. Everything was fine of course, since everything was completely up to date right from the get-go. So no big deal, if this happens to you, just do a dist (version) upgrade and you should be fine. Perhaps this post will help someone else down the road. ;)

.


All times are GMT -5. The time now is 03:08 PM.