LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   antiX / MX Linux (https://www.linuxquestions.org/questions/antix-mx-linux-127/)
-   -   Mouse pointer disappears during installation of antiX 19.2 (https://www.linuxquestions.org/questions/antix-mx-linux-127/mouse-pointer-disappears-during-installation-of-antix-19-2-a-4175673827/)

beachboy2 04-23-2020 04:43 PM

Mouse pointer disappears during installation of antiX 19.2
 
I have made another attempt to install antiX (this time with version 19.2) on my Samsung N220 netbook with 2GB of RAM.

Previously I tried to install version 17.4, here:
https://www.linuxquestions.org/quest...-a-4175656398/

I get so far with the installation (mouse works) and then the usb wired mouse (and touchpad) cease to function. The mouse pointer just disappears.

I then have no functioning mouse or touchpad to allow me to partition the drive or do anything else with the installation.

As before with 17.4, I changed the language option via F2 from US to UK and this time the mouse worked initially.
However, at the next page of the installer the mouse disappeared again.

antiX is normally so straightforward and reliable.

Any suggestions?

Is there anything I can use from the various F options at the very beginning?

anticapitalista 04-24-2020 07:00 AM

Can you try another mouse and/or usb port?

beachboy2 04-24-2020 10:11 AM

anticapitalista,

A different wired mouse and a different usb port makes no difference at all.

The mouse works initially, then as soon as the antiX installer screen comes up, bang goes the mouse pointer.

I had the same problem with antiX 17.4, so I installed MX Linux instead which was faultless.

This netbook has had an earlier version of antiX on it and that was fine.

It is very puzzling.

I may just stick with MX and forget about antiX for now.

anticapitalista 04-24-2020 01:08 PM

Weird indeed since antiX uses the exact same installer as MX.

If you don't mind, helping us to trace the issue would be very useful.

Does this only happen when you open the installer? Does it matter which window manager is used? (F6 at boot menu gives various options). What about different theme? (via lxappearance)
If you run antiX live for a while and open a few apps, type some stuff in leafpad etc before launching the installer, is there any issue with the mouse?

Thanks for any input to help us find out why this is happening.

beachboy2 04-24-2020 01:21 PM

anticapitalista,

Prior to opening the installer the mouse is working perfectly.

Shortly afterwards there is no mouse pointer.

I will have a look at this tomorrow and try to make a few notes about various settings.

Thanks for your help.

beachboy2 04-24-2020 04:20 PM

2 Attachment(s)
anticapitalista,

Settings are:

Boot Options: quietsplasht disable=lxF

F2 Eng US (I decided to leave this alone. I would normally use Eng UK)
F4 Options none
F6 rox-icewm

Mouse is working fine just after the Installer screen is displayed (see attached screenshot-1. This is from a video tutorial on 19.1, so it looks slightly different from 19.2).
This is as far as I get because within a few seconds, before I even manage to click on Menu to look for leafpad, the mouse pointer disappears.

Previously I did reach the next screen (see screenshot-2) and then the mouse pointer disappeared.

It is really strange because I have had an earlier version (prior to version 17.4) of antiX running perfectly on this Samsung N220 netbook.

I was just going to give antiX 19.2 a try just to see how it compared to MX-19.

Please donít waste your time on searching for a solution because I am really happy with MX Linux.

rokytnji 04-25-2020 01:46 AM

Sorry beachboy. I don';t have a clue. Strange issue indeed. Since MX works out . Plus anti mentioned same installer. All I can figure/shady tree guess from my shop computer tonight while drinking red stripe lager is kernel difference that somehow heats up touchpad or mouse on your end.

Since MX works out. Cool Beans.

Coasting on a sore body tonight busting butt on a carport build outside of my shop, while social distancing < construction by lonesome >

beachboy2 04-25-2020 02:53 AM

rokytnji,

Thanks anyway.

I hope the Red Stripe soothed your aching limbs!

@anticapitalista

I think I will just have to mark this as SOLVED, even though it isn't really.

I don't suppose there are an awful lot of netbooks around now. They were all the rage a few years ago.

My Samsung N220 was purchased in almost new condition after a bereavement. It has had little use since and still looks immaculate.

Thumbs up for MX on any machine!

anticapitalista 04-26-2020 11:50 AM

If you feel like helping us out, could you try antiX-19.2_4.19 kernel version (not the runit version).


https://sourceforge.net/projects/ant...9/4.19_kernel/

beachboy2 04-26-2020 02:19 PM

anticapitalista,

Hooray! Success at last.

I used the antiX-19.2-4.19_kernel_x64-full.iso from the link you supplied and my mouse was rock-solid stable.

Is this antiX version using a different kernel from the previous runit one?

Can you explain why I had the problem with one and not the other?

Now I really can mark this as [PROPERLY SOLVED].

Many thanks for your help.

anticapitalista 04-26-2020 04:02 PM

This version uses a newer kernel (4.19), whereas the 'standard' version (with or without runit) uses an older 4.9 kernel.(BTW antiX-17.4.1 also uses a 4.9 kernel)
We stuck with the 4.9 kernel since there were reports of the newer 4.19 one not working well on old hardware (antiX is primarily aimed at rescuing old hardware).

So glad it is working - thanks for helping us get to the bottom of the problem (ie kernel issue).

beachboy2 04-26-2020 04:21 PM

anticapitalista,

Quote:

Originally Posted by anticapitalista (Post 5685032)
So glad it is working - thanks for helping us get to the bottom of the problem (ie kernel issue).

I am only too pleased to assist.

Thanks for supplying a solution to my problem.


All times are GMT -5. The time now is 08:13 PM.