LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   antiX / MX Linux (https://www.linuxquestions.org/questions/antix-mx-linux-127/)
-   -   antix not loading from USB (https://www.linuxquestions.org/questions/antix-mx-linux-127/antix-not-loading-from-usb-4175673130/)

duffsuzi 04-13-2020 09:28 AM

antix not loading from USB
 
I've downloaded a few of the antix iso's and put them on a USB. Whenever I boot any of them, it seems as if the system starts, but then it just shows a black screen with the mouse pointer in the center. At this point the mouse and keyboard both do nothing--everything seems frozen. I have to hold the power button to shut it down.

Anyone can tell me what's going on?

kareempharmacist 04-13-2020 09:58 AM

Please tell us about your hardware. Maybe you have a UEFI bios. Also, how did you make the bootable usb drive? What app did you use? Did you make it on Windows?
UEFI BIOS requires special configuration to make your Linux distro work on it.

duffsuzi 04-13-2020 10:39 AM

I'm booting it on a Dell Inspiron laptop. I'm booting legacy, not EFI. I made the USB from both MXlinux and the MX tool for creating USBs and from Manjaro using dd. The results were identical. I choose to boot from USB from my BIOS options, the USB loads and I can press Alt+F1 to watch it load. Then when you would expect to see the login screen, all I see is a blank screen with the mouse and everything locked.

duffsuzi 04-13-2020 10:46 AM

More Info
 
Used quick reply but I saw nothing show up so I'll post again to make sure.

I made the USBs using MXlinx with the MX tool and also with Manjaro using dd. The results were identical. I'm go to the BIOS on my Dell Inspiron laptop and boot from the USB using legacy not EFI. Then the USB loads and I can press ALt+F1 to watch the process. When the time comes for what you would think should be the login screen, instead I get the black screen with the mouse arrow and everything is locked.

duffsuzi 04-13-2020 01:27 PM

Why aren't my replies showing up?
 
So now the forum doesn't seem to be working for me. What won't these replies show up?

EDIT: Not sure what happened but I replied twice and nothing happened. Did it this time and it went.

So... I have made a USB using both MXlinux and the MX tool as well as Manjaro and dd. The results were identical. On a Dell Inspiron laptop,I choose to boot from USB, with legacy not EFI, from the BIOS options. The USB loads and I can use Alt+F1 to watch the boot process. Then, when you would expect the login window to appear, I get a black screen with the mouse pointer and everything is locked.

fatmac 04-13-2020 02:17 PM

Did you check the md5sums to make sure you got a good download?

duffsuzi 04-13-2020 03:25 PM

i did.
 
I did.

fatmac 04-14-2020 04:14 AM

Well, I'm guessing, but if neither AntiX, MX, nor Manjaro will get any further, that your graphics card may not be supported.

hazel 04-14-2020 04:50 AM

You could try ctrl+alt+F2. This should give you a console where you can log in and do a text mode install. I've forgotten the login details (probably root and root) but I'm sure you can find them on the AntiX website under installation.

duffsuzi 04-14-2020 07:11 AM

My graphics card? I've installed Manjaro, MXlinux, Arch, opensuse, debian... and more with no problems with my graphics card. I've been using linux on this laptop for four years. but you're telling me that antix won't load because of my graphics card--Intel 5500? What?

duffsuzi 04-14-2020 07:14 AM

I tried to switch to another terminal. The keyboard is not functioning. As I've said, it's like it freezes--no mouse, no keyboard. Have to press the power button.

fatmac 04-14-2020 07:59 AM

Quote:

Originally Posted by asscracker (Post 6111479)
My graphics card? I've installed Manjaro, MXlinux, Arch, opensuse, debian... and more with no problems with my graphics card. I've been using linux on this laptop for four years. but you're telling me that antix won't load because of my graphics card--Intel 5500? What?

Your original post suggested that you couldn't get further than a pointer on screen, with AntiX, MX, or Manjaro - that is why I suggested your graphics card - now you say that you have installed MX & Manjaro before(?).

There could still be a driver issue, one that may not be in AntiX.

duffsuzi 04-14-2020 08:12 AM

I was asked how I made the USB with antix on it. I replied that I used MXlinux and Manjaro to make the USB.

kareempharmacist 04-14-2020 11:30 AM

Are you sure it is not a faulty USB flash drive? It is the common element here. You should try another Flash drive. Another thought, What are the exact model and configuration of your laptop? may be you are trying to run a 64-bit distro on an unsupported hardware. It depends on how old is your laptop. How much RAM in it?

anticapitalista 04-14-2020 11:32 AM

Use safe or failsafe boot at menu screen once you know the usb device is not faulty.

Also, F4 at same menu has an option to checkmd5sums of the files on the usb.
(Press Alt F1 to see messages)

duffsuzi 04-14-2020 11:55 AM

...

duffsuzi 04-14-2020 12:04 PM

I booted the USB on my desktop. It loaded antix to a command line in which I could install antix.

I booted the USB on my laptop with safe mode. It booted to rox-icewm live session.

Why would it boot to different places just because of different hardware?
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

But now with safe mode I can use it live on my laptop which is what I wanted, so I'll mark this as solved. Thanks for everyone's responses.

anticapitalista 04-14-2020 12:23 PM

It is because of the hardware.

You could post hardware details.

inxi -Fxz in a terminal

duffsuzi 04-15-2020 09:29 AM

demo@antix1:~
$ inxi -Fxz
System:
Host: antix1 Kernel: 4.9.212-antix.1-amd64-smp x86_64 bits: 64
compiler: gcc v: 8.3.0 Desktop: IceWM 1.6.5
Distro: antiX-19.2-runit_x64-full Hannie Schaft 28 March 2020
base: Debian GNU/Linux 10 (buster)
Machine:
Type: Laptop System: Dell product: Inspiron 3558 v: N/A serial: <filter>
Mobo: Dell model: 0PNFDX v: A00 serial: <filter> UEFI [Legacy]: Dell
v: A19 date: 05/16/2019
Battery:
ID-1: BAT0 charge: 21.1 Wh condition: 21.6/41.4 Wh (52%)
model: SMP DELL VN3N047E status: Discharging
CPU:
Topology: Dual Core model: Intel Core i3-5015U bits: 64 type: MT MCP
arch: Broadwell rev: 4 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 16761
Speed: 2001 MHz min/max: 500/2000 MHz Core speeds (MHz): 1: 2001 2: 2000
3: 1996 4: 2000
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Dell driver: N/A bus ID: 00:02.0
Display: x11 server: X.Org 1.20.4 driver: vesa resolution: 1368x768~N/A
OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.3.6
direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 00:03.0
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.9.212-antix.1-amd64-smp
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: 4040
bus ID: 06:00.0
IF: wlan0 state: down mac: <filter>
Device-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
vendor: Dell RTL810xE driver: r8169 v: 2.3LK-NAPI port: 3000
bus ID: 07:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 945.97 GiB used: 43.6 MiB (0.0%)
ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-75JC3T0
size: 931.51 GiB
ID-2: /dev/sdb type: USB model: USB DISK 3.0 size: 14.46 GiB
Partition:
ID-1: / size: 6.18 GiB used: 40.5 MiB (0.6%) fs: overlay source: ERR-102
Sensors:
System Temperatures: cpu: 38.0 C mobo: 38.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 163 Uptime: 1m Memory: 7.77 GiB used: 644.1 MiB (8.1%)
Init: runit runlevel: 2 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3
inxi: 3.0.36

kareempharmacist 04-19-2020 10:51 AM

This laptop is equipped to run Ubuntu. It has drivers for Ubuntu 12.04 on Dell's website. May be it is kernel problem which Lubuntu 20.04 can handle. I had a dell Inspiron laptop which had Ubuntu preinstalled. Debian liveDVD with non-free firmware didn't even boot on it but MXLinux did. Lubuntu 20.04 is coming after a week. You may give it a try.

duffsuzi 04-20-2020 11:58 AM

This is running live off the USB. I haven't installed it to the harddrive. I did have to boot into safe video mode. Why would antix load Ubuntu drivers?

kareempharmacist 04-22-2020 04:59 AM

I didn't mean you should load Ubuntu driver on AntiX. I meant Ubuntu is suitable for this particular laptop model. May be it has custom firmware for your graphics card. If you can boot into safe mode this rules out the possibility of a faulty USB drive. Lubuntu 20.04 stable will be out tomorrow. You should give it a try.It won't hurt.

duffsuzi 05-15-2020 07:41 AM

I'm using void linux on it. No problems and lighting fast.


All times are GMT -5. The time now is 09:12 PM.