LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux
User Name
Password
antiX / MX Linux This forum is for the discussion of antiX and MX Linux.

Notices


Reply
  Search this Thread
Old 01-10-2019, 02:37 PM   #1
RHTopics
Member
 
Registered: May 2006
Posts: 45

Rep: Reputation: 3
antiX-17.3.1_x64-full: SpaceFM warning message


System information:
Quote:
$ inxi -S
System:
Host: antix1 Kernel: 4.9.0-8-amd64 x86_64 bits: 64 Desktop: IceWM 1.4.2
Distro: antiX-17.3.1_x64-full Helen Keller 27 December 2018
Got the following warning message when running SpaceFM from a terminal window:

Quote:
$ spacefm

(spacefm:3601): SpaceFM-WARNING **: No root settings found in /etc/spacefm/ Setting a root editor in Preferences should remove this warning on startup. Otherwise commands run as root may present a security risk.
Can not find a "Preferences" file or section in /etc/spacefm but here is the contents of my /etc/spacefm/spacefm.conf file:

Quote:
# spacefm.conf
# This file affects all users of SpaceFM on this system.

# Documentation: /usr/share/doc/spacefm/spacefm-manual-en.html#programfiles-etc
# http://ignorantguru.github.io/spacef...ogramfiles-etc

# tmp_dir must be a root-protected user-writable dir like /tmp
# ALL users must be able to write to this dir.
# tmp_dir must NOT contain spaces or special chars - keep it simple
#tmp_dir=/tmp

# Specify an absolute path to an additional terminal su or sudo program:
#terminal_su=/bin/su

# Specify an absolute path to an additional graphical su program:
#graphical_su=/usr/bin/gksu
As you can see everything is commented out in this file.

But I did find a "demo-as-root" file in /etc/spacefm and here is its contents:

Quote:
# SpaceFM As-Root Session File

# THIS FILE IS NOT DESIGNED TO BE EDITED


root_editor-s=leafpad
main_terminal-s=lxterminal
main_terminal-b=2
What should be changed or added to stop the warning message?
 
Old 01-10-2019, 02:55 PM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 6,628
Blog Entries: 2

Rep: Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202Reputation: 2202
I don't run SpaceFM but the manual at http://ignorantguru.github.io/spacef...ogramfiles-etc appears to suggest that there is a menu option View->Preferences which allows you to set the root editor.
 
Old 01-10-2019, 02:57 PM   #3
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17
Posts: 5,619
Blog Entries: 20

Rep: Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673Reputation: 2673
Might help

http://postmyimage.com/img2/614_screenshot.jpg

Edit: That is my AntiX 15 laptop running Jessie.

LXterminal was chosen for AntiX 17 releases.
I still use roxterm in this laptop.

Last edited by rokytnji; 01-10-2019 at 03:00 PM.
 
1 members found this post helpful.
Old 01-10-2019, 04:04 PM   #4
RHTopics
Member
 
Registered: May 2006
Posts: 45

Original Poster
Rep: Reputation: 3
hydrurga and rokytnji,

Thank you for the replies.

My View -> Preferences -> Advanced dialog window looks just like rokytnji's screenshot except as noted the Terminal: is set to lxterminal.
 
Old 01-10-2019, 06:15 PM   #5
RHTopics
Member
 
Registered: May 2006
Posts: 45

Original Poster
Rep: Reputation: 3
In the View -> Preferences -> Advanced dialog window, I put "leafpad %f" in the Root's editor field.

When I clicked the OK button, it popped up the message:

Quote:
Save Root Setting

You will now be asked for your root password to save the root settings for this user to a file in /etc/spacefm/ Supplying the password in the next window is recommended. Because SpaceFM runs some commands as root via su, these settings are best protected by root.
I clicked the OK button in this message window. I was not prompted for root password. But that maybe because I had used "sudo" earlier.

Doing that stops the warning message from appearing when executing "spacefm" from a terminal window.

It also created the file /etc/spacefm/"myuserid"-as-root and contains the following:

Quote:
# SpaceFM As-Root Session File

# THIS FILE IS NOT DESIGNED TO BE EDITED


root_editor-s=leafpad %f
main_terminal-s=lxterminal
main_terminal-b=2

Last edited by RHTopics; 01-10-2019 at 06:54 PM. Reason: additional information
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SpaceFM Needs A New Maintainer LQSlacker Linux - General 8 12-31-2017 04:20 PM
[SOLVED] Conky display gets corrupted since updating Antix-16 to Antix-17 hazel Linux - Distributions 3 12-18-2017 09:55 AM
LXer: SpaceFM: Highly Customizable, Multi-Pane File Manager LXer Syndicated Linux News 0 02-16-2012 01:21 AM
Can't Compile and/or Install Guarddog on Slack 13.1_x64 Multilib beartooth91 Slackware 3 08-08-2010 10:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > antiX / MX Linux

All times are GMT -5. The time now is 04:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration