-   Amigo (
-   -   GCC not installling..also yahoo messenger,grub &linmodem (

liny1984 06-15-2006 01:36 PM

GCC not installling..also yahoo messenger,grub &linmodem
1.Could someone please point me to a version of gcc that installs correctly.i tried installing from the pkg(.tgz) given in amigo main downld area (2.95/3.1/3.2.3)..all install correctly but when i try to compile even 1 line c programs ,it says 'cc1 executable not found'..same with c++ progs.Are there any other pkgs reqd? i installed binutils ,glibc still no effect...some times when compiling it fills the screen with errors in stdio.h like namespace errors etc & then finds an error in my test.c program.i tried installing on amigo9.1 with a system that has windowsXP in c: and amigo in f:\Linux folder...please help me out as i am unable to program anything in linux.KDE installs perfectly!..

2.also is grub available for amigo as tgz pkg? for lilo i chose 800*600 mode for initial display yet i get the command line (text mode) menu. no penguin :(

3.also how do i install tar.gz pkgs yahoo messenger for example is available as tar.gz

4.also can anyone point me to a stable driver for linmodems i got a" SoftV92 Data Fax Modem" card from D-Link

liny1984 06-15-2006 01:41 PM

Some help on AmigoXP too
Could someone also tell me which version of amigo xp to downld & is stable
or amigoxprc2
..also has all the forums been shifted here??
this is still the home page right??

gnashley 06-16-2006 01:12 AM

Are you using the wrapper to run gcc-2.95? You'll find it in the sources directory:

It just does this:
export PATH=/opt/gcc-2.95/bin:$PATH
export LD_LIBRARY_PATH=/opt/gcc-2.95/lib
exec "$@"

Or you can just do
export PATH=/opt/gcc-2.95/bin:$PATH
from the command line, then 'make'. This puts the gcc binary in your path before your regular compiler.

I don't have GRUB packaged yet, though I've been working on some custom versions the last few days and will make packages soon.

If you are seeing tar.gz packages then you are in the Sources area. Look for the same program name under Packages:

I don't recommend that you use amigoxprc1 or rc2. You'll notice that they are not on my site anymore, only on some sites that mirror mine and don't refresh their content.

gnashley 06-16-2006 04:50 PM

The tar.gz from yahoo messenger is probably a tarball with an install script, like for opera or other progs like that -usually non-open-source.

tar xvf yayhue.tar.gz will unpack it. Then look for a README or install script to run

liny1984 06-18-2006 02:26 PM

amigoXP link
could u plz give me the xact link for d/l amigoxp ..its done right ??

gnashley 06-18-2006 04:21 PM

There is no dowload for AmigoXP.

liny1984 06-19-2006 04:53 AM

Ok i am facing more problems:-

1.i ran gcc with wrapper as
sh wrap cc test.c

'wrap' is the wrapper u mentioned:-
export PATH=/opt/gcc-2.95.3/bin:$PATH
export LD_LIBRARY_PATH=/opt/gcc-2.95.3/lib

exec "$@"

test.c is as follows:-
#include <stdio.h>

int main(int argc,char *argv[])
return 0;

test.c:1:stdio.h: No such file or directory

So i installed the kernel headers and kernel change.Also stdio.h is
not present inside the include directory of gcc.So fine i changed the 1st line
to #include<stddef.h> so now it compiles but stops asking for 'as' i
install binutils now it assembles(i guess) & n ow it says:-
/usr/bin/ld:cannot open crt1.o:No such file or directory

so i go hav a look at /dev & there is no crt1.o .Is the output device
incorrectly mentioned somewhere. I tried compiling with -o option as
sh wrap cc -o a.o test.c
(i think i am using the -o option incorrectly...but i
am not sure....newbie here :) )
still same reply .....cant open crt1.o
collect2:ld returned 1 exit status

So now i try c++
sh wrap cc test.cpp

#include <iostream.h>

int main(int argc,char *argv[])
return 0;

result: big error basically it says
cant find libio.h which is #included in streambuf.h which in turn is #included in

2.Is there a way to startx automatically just before or after login....this would
then display the login screen if kde is installed or automatically start kde after
logging in at cmd line
i tried to modify some scripts in rc.d but there is no script for run level 3 rc.3
there are scripts only for rc.4 & rc.6...buts its mentioned that run level 3 is do i automatically start programs just before or after login??

3.u mentioned 'make' after exporting the PATH ...make what...could you please be slightly more detailed here...i am a relative noob

liny1984 06-19-2006 04:54 AM

Isnt amigoXP ready for release yet...and which is tthe main site you are maintaining from where amigoXP is available?

gnashley 06-19-2006 06:53 AM

If you downloaded the binary package for gcc, then you also need to install the cxx32-libs package. These are the kernel libraries.
You might try commenting out the line for LD_LIBRARY_PATH or change it to this:
export LD_LIBRARY_PATH=/opt/gcc-2.95.3/lib:$LD_LIBRARY_PATH
which will include the regular lib directories.

Unless your code is really old, you'll find it easier to use the gcc-3.1 (or 3.2.3)version as it links to the smae libs as your regular compiler.

Your question 2 is a Slackware question, actually. You need to edit /etc/inittab.
Change this:

to this:

#3 The way I use the wrappers is to make them executable and put them in /usr/local/bin and execute them by name with calling 'sh'. This line: exec "$@" simply tells it to do whatever the rest of the command is. I give the example of using the command 'make' since most people use Makefiles to control their builds. Sounds like you are learning from the ground up which is great. Dig around through the directories there on my site and read the notes and README'S. I keep it short usually, but I've been told I lay a treasure around sometimes...

About AmigoXP. Perhaps there won't be a release by that name. As you notice, the site changed completely. As stated there, the only thing I offer or support is what's there and all of the content is new -lotta GB'2 there.

On the way to making the next distro, I needed to do several things, like get my sources better organized, with repeatable build scripts, get more GPL conformant by only distributing packages for stuff that I compile and with the sources available locally. Better documentation for both packages and sources which I have modified.

The new site is the result of these policies and practices.More than 300 prgrams and adding stuff everyday.
When I get back to creating the next Amigo distro, it'll be something refreshing for several groups of users -probably under 256MB base size and still windows friendly.
Actually I nearly have something nearly ready especially made for running from external devices like mp3 players and iPods, etc. I've released some pretty good distros before. The next should be even better, but I'm still making decisions about what to push for. It's a *big* responsablility and lot's of work.

liny1984 06-21-2006 03:22 PM

sorry double post...removing this

liny1984 06-21-2006 03:24 PM

Close but no!!
1.ok installed gcc3.2.3 & set up the paths as u said.the readme.AMIGO file instrucs were followed & i set up the compiler for
strict compiling against the libraries. i also chked the path using 'gcc which' and its setup ok. So after setting up for strict compilation it locates stdio.h (it couldn't before) and tries to compile.Then it spews up a whole set of errors in stdio.h!! something like
i think i am close but so many syntax errors in stdio.h in gcc323 folder that i just installed is not possible

my program is absolutely correct namespace std or anything specific reqd??


#include <stdio.h>

int main(int argc,char *argv[])
return 0;

2.the system starts up xdm automatically now after i modified inittab...thanks for i know i should be knowing this but could you please tell me if there is file explorer like the one you provide with the default rox-filler....i saw just xterm when i logged in graphically with xdm(and some other stuff)

gnashley 06-23-2006 03:58 PM

xdm is just a login manager which by default starts the famous TWM desktop!
If you want to build a desktop and use the same filer or desktop stuff that I use, look around the site, especially in GUIcomponents and in the
AmigoProjects area.

As far as the gcc problem, as I said you should probably *not* alter the LD_LIBRARY_PATH at all, just the PATH.

All times are GMT -5. The time now is 07:38 AM.