LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Amigo
User Name
Password
Amigo This forum is for the discussion of Amigo Linux.

Notices


Reply
  Search this Thread
Old 05-21-2005, 10:27 AM   #1
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Rep: Reputation: 0
Cannot connect to internet


Hi ! I cannot connect to the internet : I connect through a lan .I can reach through internet from win98 but I cannot connect from amigo. My lan card is installed(I used lsmod and it is there)---- Realtek 8139. So far i used netconfig like this:
 
Old 05-21-2005, 10:37 AM   #2
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Original Poster
Rep: Reputation: 0
these are taken from windows for dhcp

hostname Argos
domainname Argos.p24.pub.ro
dhcp : 10.24.2.207
when loading says something that it doesnt find dhcpcd


also tried with an static IP

hostname , domainname 10.24.13.7 (my Ip) gateway and nameserver
10.24.2.207
but says when loading : siocaddrt : Network is unreachable
I had Amigo installed 5months ago and I have connected that time using dhcp and with the same IP s.

Thank you !
 
Old 05-21-2005, 10:50 AM   #3
marvin00001
Member
 
Registered: Apr 2005
Posts: 59

Rep: Reputation: 15
What are the netmasks for the ip address you have given here
 
Old 05-21-2005, 11:09 AM   #4
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Original Poster
Rep: Reputation: 0
Hi : win98 says 255.255.0.0
i tried both 255.255.0.0 and 255.255.255.0
 
Old 05-22-2005, 02:44 AM   #5
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Have you run ifconfig?
 
Old 05-22-2005, 03:33 AM   #6
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Original Poster
Rep: Reputation: 0
I did :


bash-2.05b# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
Old 05-22-2005, 07:26 AM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Read the man pages for ifconfig. I think you need to do ifconfig down, then ifconfig up.
 
Old 05-22-2005, 08:22 AM   #8
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Original Poster
Rep: Reputation: 0
I finally got it working : I downloaded this package from slackware site (dhcp and dhcpcd)
I installed them and after reboot it just worked

thanks a lot

Peter
 
Old 05-22-2005, 09:25 AM   #9
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
You must be using an rc version of Amigo -Amigo-2.0 has those packages pre-installed.
 
Old 05-22-2005, 02:02 PM   #10
PeterP24
LQ Newbie
 
Registered: May 2005
Location: Romania
Distribution: amigo - slackware
Posts: 11

Original Poster
Rep: Reputation: 0
I dont know if it does matter but the image bootdisk was called amigo2rc10
 
Old 05-22-2005, 03:34 PM   #11
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Yeah it does. The final version includes several more packages. In fact, dhcp and dhcpd were the first things to be added in to Amigo-2.0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 12:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 06:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 07:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 07:58 PM
How to connect to the internet??? Hachaso Linux - Software 2 04-12-2002 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Amigo

All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration