-   Amigo (
-   -   Build Fails - Arguments? (

tronayne 02-10-2008 12:41 PM

Build Fails - Arguments?
I've tried building lifelines-3.0.62.tar.bz2 with src2pkg version-1.9.4 with this command:

src2pkg -p=/usr/local -C lifelines-3.0.62.tar.bz2
It consistently fails with

src2pkg -p=/usr/local -C lifelines-3.0.62.tar.bz2
Found source archive: lifelines-3.0.62.tar.bz2
Creating working directories:
Unpacking source archive - Done
Correcting source permissions - Done
Checking for patches - Found
  Applying: vpnclient-linux-2.6.22.diff
Found configure script - Configuring sources using:
  CFLAGS=-O2 -march=i486 -mtune=i686 ./configure --prefix=/usr/local
Configuration has been - Successful!
Compiling sources - Using: 'make'
Compiling has been - Successful!
Installing in jail root - Using: 'make install'
FATAL! Running '' has failed with error: 1
Try using INSTALL_LINE 'make -i install'  Exiting...
src2pkg FAILURE in make_install

(It does the vpnclient patch because the file is sitting in /usr/local/src where I keep non-distribution source files; no big deal.) I've tried different argument combinations with no luck.

I can configure and make LifeLines with no problems or error messages manually and I really can't seem to figure out what I need to do to get this working properly.

Any hints?


gnashley 02-10-2008 02:04 PM

First, update to the latest src2pkg-1.9.5 from here:

Then, if you are still having problems with the lifelines build, try using the -DESTDIR option:
src2pkg -p=/usr/local -C -DESTDIR lifelines-3.0.62.tar.bz2

I would recommend you to place each tarball in its' own directory -this will help ensure good builds and is a good pratice anyway. I also recommend avoiding using /usr/local as your prefix for packaged software. Some of the src2pkg functions which
help make sure your packages are complete and correct are disabled when you use -p=/usr/local

P.S. - I just downloaded the sources and it compiled just fine using the default -JAIL installation method. There were some problems with 'make install' in the last couple of versions of src2pkg -seem to be all worked out now.
This should work fine:
src2pkg -C lifelines-3.0.62.tar.bz2

tronayne 02-10-2008 02:32 PM

Ah! The new version works, thank you.

I built LifeLines with

src2pkg -D -DEST -p=/usr/local -C lifelines-3.0.62.tar.bz2
and all is well with the world.

My standards are that non-distribution software be installed in /usr/local; "packaged" software; e.g., OpenOffice, Scribus and the like I install in /opt. Been doing things that way for... cripes! decades, already. Lordy, time do fly when you're having fun, eh? I've tried to follow what I think of as the Bell Labs, System V, Solaris model by doing that and, so far, it's been less a pain than installing add-ons in /usr (at least for me). For a long time the checkinstall utility did a nice job, but, well, that's the end of that apparently; scr2pkg seems the next step in the evolutionary trail (and, now that it works, a step in the right direction, methinks).

Thank you for both the development effort and for the help.

All times are GMT -5. The time now is 12:45 AM.