LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 03-23-2004, 09:05 AM   #1
zepplin611
Member
 
Registered: Jan 2004
Distribution: AIX 4.3 RH 7,8,9 / Fedora C1/
Posts: 187

Rep: Reputation: 30
XL Fortran / Parallel Environ. Error on IBM SP2


Greetings,

I have compiled a fortran pgm on an IBM SP2 node running AIX 4.3.3 and XL
Fortran v7.1 --> I have implemented MPI in the pgm and i used the
following compile options:

mpxlf -O2 -qmaxmem=-1 -o ab ab.f

the compilation is successful b/c the following kicks out:

1501-510 Compilation successful for file ab.f


now i execute:

setenv MP_EUILIB ip
setenv MP_RESD no
setenv MP_PROCS 4

these set the MPI environment...all set fine, w/o error.


Now to run this pgm, I execute poe (Parallel Operating Environment)
poe ./ab

the following error results:

ERROR: 0031-382 Error obtaining authentication methods in use on local
host, errno: 2

the PE message guide gives very little further help...can any provide
insight into this error?

Note: I have correctly set my host.list file to indicate 4 cpu's.

Thanks,

zepplin611
 
Old 03-31-2004, 04:52 AM   #2
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Just read this again. I don't really have a clue, but I wonder if it might be an SP kerberos problem.

Check :
lsauthent : see what authentication is being used
If kerberos, check that kerberos is correct (can you rsh from the node to the other nodes OK).
 
Old 03-31-2004, 09:06 AM   #3
zepplin611
Member
 
Registered: Jan 2004
Distribution: AIX 4.3 RH 7,8,9 / Fedora C1/
Posts: 187

Original Poster
Rep: Reputation: 30
i did a thorough check of kerberos prior to submitting...that's what i initially thought too...the problem was this: sysctld and haemd daemons were not started on the node...i tried several things and the only one that worked (the daemons remained running) was when i rebooted the node...i no longer get that error...sysctld and haem daemons are very vital to poe...communication among the nodes and just the cpu's on its own node require it.
Fortunately the reboot helped and continued production was achieved.

zepplin611
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error Linux Fortran compiler: libimf.so terrence Programming 6 06-15-2012 03:51 PM
g77 Fortran - run time error (fmt: read unexpected character) rajeshdorai Programming 1 08-16-2006 07:07 AM
does linux fortran compiler in fedora 4 support VAX FORTRAN? terrence Programming 17 08-31-2005 08:59 AM
wiping an IBM SP2 disk clean zepplin611 AIX 8 05-11-2005 08:33 AM
setting the environ albean Linux - Newbie 1 10-06-2002 09:14 PM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 01:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration