LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   AIX (https://www.linuxquestions.org/questions/aix-43/)
-   -   vios and san disk newbie problem (https://www.linuxquestions.org/questions/aix-43/vios-and-san-disk-newbie-problem-673531/)

javier_ccs 10-01-2008 09:02 AM

vios and san disk newbie problem
 
hello, im a linux user and recently my company purchased some pseries and js21 blade servers, they told me that some training is coming, but i have to configure some servers urgently (as usual), however i have done some reading over the Internet but i haven't found anything yet and i really could use some help...

i have a js21 blade server with two lpars and the vios, i need to add a san disk to one of my lpars, so i send the wwn (on the vios) to the storage guys and they told me that the disk was configured (24Gb disk), so i

Code:

$ lsdev | grep hdisk
hdisk0          Available  SCSI RAID 10 Disk Array
hdisk1          Defined    EMC Symmetrix FCP Raid1
hdisk2          Available  EMC Symmetrix FCP Raid1
hdisk3          Available  EMC Symmetrix FCP Raid5
hdisk4          Available  EMC Symmetrix FCP Raid5
hdisk5          Available  EMC Symmetrix FCP Raid5
hdisk6          Available  EMC Symmetrix FCP Raid5
hdiskpower0    Available  PowerPath Device
hdiskpower1    Available  PowerPath Device

on the web interface of the vios i only see 40GB disks, anyway, i guess my questions is this (please be gentle)...

how can i configure one of those san disk to a lpar?

javier_ccs 10-01-2008 10:15 AM

oh i forgot to mention....

i did some reading and found out that i should run some commands on the aix:

cfgmgr and then
/opt/emc/SYMCLI/V6.3.2/bin/powermt config
/opt/emc/SYMCLI/V6.3.2/bin/syminq | more
/opt/emc/SYMCLI/V6.3.2/bin/powermt save

now... on the vios i did a cfgmgr and i got:
rksh: cfgmgr: not found.
i tried to change the directory to /opt and i got:
rksh: cd: 0403-019 The operation is not allowed in a restricted shell.

so i went to the lpar's...

and i did a cfgmgr, everything is fine...

# lsdev | grep hd
hd1 Defined Logical volume
hd2 Defined Logical volume
hd3 Defined Logical volume
hd4 Defined Logical volume
hd5 Defined Logical volume
hd6 Defined Logical volume
hd8 Defined Logical volume
hd10opt Defined Logical volume
hd9var Defined Logical volume
hdisk0 Available Virtual SCSI Disk Drive

and on the other lpar:

# lsdev | grep hd
hd1 Defined Logical volume
hd2 Defined Logical volume
hd3 Defined Logical volume
hd4 Defined Logical volume
hd5 Defined Logical volume
hd6 Defined Logical volume
hd8 Defined Logical volume
hd10opt Defined Logical volume
hd9var Defined Logical volume
hdisk0 Available Virtual SCSI Disk Drive

so i guess, both lpar are watching the disks, but theres no /opt/emc folder on /opt.... what is going on?, is it not installed? if its not installed, how come it recognizes some disks????

please!!!

javier_ccs 10-01-2008 02:59 PM

for future reference, in case some other newbie (as me) searchs for this particular issue...

*.- inside the vios...

powermt display dev=all

that syncronizes the devices and shows the disks added...

then go to the web interface of the vios and assign the disk to the lpar, then all we need to do is create the volume group (im trying to do it), and the create the file system (me guessing)...

will update later...

centos82 10-03-2008 09:05 PM

On a VIO Server by default you log into a restricted shell. cfgdev is the equivalant of cfgmgr in the restricted shell. Also in the restricted shell you cannot change directories or call commands using an absolute path. To get out of the restricted shell run "oem_setup_env" Then you will be able to switch directories and run cfgmgr.

To assign a virtual disk to a server you will need to create a vhost device file and create a virtual target disk.

To create the vhost, using the HMC, on the virtual server or the VIO server (your choice) select to create a new virtual scsi adapter. Give it a slot number, and assign it to the server you want it assigned to. Then run cfgdev (in restricted shell) or cfgmgr on the VIO server. In the restricted shell run "lsmap -all" This will list all of your vhost devices.

Note: To get back to the restricted shell after running oem_setup_env just type exit.


You should now see your vhost. If this is the first virtual scsi adapter you have created it will probably be vhost0. To create the virtual target disk run the command

mkvdev -vdev <hdisk on vioserver> -vadapter vhost0 -dev <a name you pick..e.g. servernamedisk1>

An example would be:

mkvdev -vdev hdiskpower0 -vadapter vhost0 -dev servernamedisk1

This command also needs to be run from the restricted shell.

Hope this helps.

membit 11-05-2008 05:45 PM

Just notice that if you have fault tolerant VIO-server environment
- one path to LUN-0 goes via VIOS-A
- one path to LUN-0 goes via VIOS-B
and LPAR does have 2 VSCSI adapters, where one is configured for VIOS-A and one for VIOS-B


You should do following for every device on VIO-servers:

execute (I don't remember was it after or before oem_setup_env, just try which one works;))
Code:

lsattr -El hdiskpower0
Then you probably see parameter 'reserve_lock'
In powerpath, it is 'yes' as a default. It should be change to 'no'

Code:

chdev -l hdiskpower0 -a reserve_lock=no
EDIT:
Oh, almost forgot;
This is because if VIOS-A gets the LUN-0 first, VIOS-B cannot show it to the LPAR.
You notice this by executing lspath on LPAR (assuming LPAR is AIX).


All times are GMT -5. The time now is 03:42 AM.