LinuxQuestions.org
Help answer threads with 0 replies.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 01-31-2005, 08:50 AM   #1
Risc91
Member
 
Registered: Jan 2002
Location: Macomb, MI
Distribution: Ubuntu|Red Hat ES|AIX
Posts: 161

Rep: Reputation: 30
System info. command


Is there any command that will give me a summary of system information, such as # of CPUs and speed, Total Memory, # of HDDs and size?

If not is there one that will at least give me proc. speed? (I know the individual commands for memory and hard drive size)
 
Old 01-31-2005, 09:05 AM   #2
nixcraft
Member
 
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Use dmesg command

Code:
dmesg | less
Then change directory to /proc

cd /proc
ls -l
Here most of the files has system info like cpuinfo file just cat them

Or try shell script
http://www.cyberciti.biz/nixcraft/li...st/scripts/q18

Last edited by nixcraft; 01-31-2005 at 09:07 AM.
 
Old 01-31-2005, 09:34 AM   #3
Risc91
Member
 
Registered: Jan 2002
Location: Macomb, MI
Distribution: Ubuntu|Red Hat ES|AIX
Posts: 161

Original Poster
Rep: Reputation: 30
I was not aware that the 'dmesg' command was available in AIX. I don't think that it is.
 
Old 01-31-2005, 10:01 AM   #4
zorba4
Member
 
Registered: Feb 2004
Location: Paris
Posts: 398

Rep: Reputation: 31
nmon gives a lot of useful info.
You may also want to do it my way :
# bindprocessor -q
The available processors are: 0 1 2 3
# lsattr -E -l mem0
goodsize 512 Amount of usable physical memory in Mbytes False
size 512 Total amount of physical memory in Mbytes False
# lsattr -E -l proc0
frequency 374999808 Processor Speed False
smt_enabled false Processor SMT enabled False
smt_threads 0 Processor SMT threads False
state enable Processor state False
type PowerPC_604e Processor type False
# lspv
hdisk0 00439c5bb7a4ec67 rootvg active
hdisk1 00439c5be10d6265 rootvg active

bindprocessor -q shows all available processor. As you can see I also use lsattr and lpv.
lsvg rootvg shows available space, lsdev -Ccdisk shows disk type.
 
Old 01-31-2005, 10:40 AM   #5
Risc91
Member
 
Registered: Jan 2002
Location: Macomb, MI
Distribution: Ubuntu|Red Hat ES|AIX
Posts: 161

Original Poster
Rep: Reputation: 30
Cool, thanks Zorba. I think I'm going to throw these into a script.
 
Old 02-08-2005, 10:20 AM   #6
Mark Taylor
Member
 
Registered: Apr 2004
Posts: 60

Rep: Reputation: 15
prtconf works well on v5+ ...
 
Old 02-09-2005, 01:48 PM   #7
looseCannon
Member
 
Registered: Dec 2003
Location: Little Rock, AR
Distribution: Fedora Core 2, AIX, HP-UX, Solaris, Whitebox
Posts: 193

Rep: Reputation: 31
Quote:
Code:
dmesg | less
That's funny. Two things wrong with that. 'dmesg' doesn't exist in AIX. Neither does 'less'.

And /proc contains none of the information typically found there on a Linux system. At least, it's not as easy to find.
 
Old 02-10-2005, 09:07 PM   #8
abyss
Member
 
Registered: May 2001
Location: New York, USA
Distribution: AIX, Ubuntu
Posts: 113

Rep: Reputation: 16
Another quick and dirty way to get the processor speed is:

pmcycles

HTH
 
Old 03-16-2005, 01:00 PM   #9
boyd98
Member
 
Registered: Oct 2003
Posts: 156

Rep: Reputation: 15
lsattr -El sys0

displays quite abit of info - you might try it
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to find out if my system is i386, i486, or i586? Is there a system info command? mlsbraves Linux - General 6 02-17-2009 04:08 PM
info command walruswalrus Linux - Software 1 12-02-2005 12:14 PM
System info command downinthemine Linux - Software 3 11-29-2003 12:30 PM
System Info Command? tenraek Linux - General 1 05-20-2003 04:59 PM
System Info / System Audit munyard Linux - Software 1 01-08-2003 01:33 PM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration