LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 10-18-2005, 06:55 AM   #1
krusty_lab
LQ Newbie
 
Registered: Oct 2005
Location: rom,italy
Distribution: redhat,fedora,AIX
Posts: 24

Rep: Reputation: 15
SSH X forwarding


I've a problem with ssh on AIX 5.3, it's don't automagically export the display, i have added the right entry in ssh_config ( i have copied it from my other linux boxes), but nothing, can anybody helps ??
Thanks
Krusty
 
Old 10-18-2005, 07:51 AM   #2
lennoni
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Rep: Reputation: 1
Add -X to the command line when logging in?

ssh -X user@myhost.org
 
Old 10-18-2005, 08:43 AM   #3
krusty_lab
LQ Newbie
 
Registered: Oct 2005
Location: rom,italy
Distribution: redhat,fedora,AIX
Posts: 24

Original Poster
Rep: Reputation: 15
I use Putty and i enable X forwarding, it's work for my other linux boxes Linux
 
Old 10-18-2005, 09:25 AM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
i have added the right entry in ssh_config
That's the wrong file. You need to update sshd_config.

Code:
X11Forwarding yes
 
Old 10-18-2005, 05:53 PM   #5
baktor
LQ Newbie
 
Registered: Sep 2005
Location: Atlanta, GA USA
Posts: 17

Rep: Reputation: 0
if your the administrator of the AIX server, you will want to look at /etc/ssh/sshd_config

Particularly:

AllowTcpForwarding yes
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes

I bet your server has X11Forwarding no. This means the server isn't going to honor forwarding automatically. The above settings tell sshd that you want X11 forwarding and to automatically use localhost:10 as the default tunnel to create for it. Hope this helps...

Make sure you `refresh -s sshd` when done.
 
Old 10-19-2005, 05:20 AM   #6
krusty_lab
LQ Newbie
 
Registered: Oct 2005
Location: rom,italy
Distribution: redhat,fedora,AIX
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks a lot, now every think is working right ...
Thanks
Krusty
 
Old 01-04-2006, 03:35 AM   #7
pragathi
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Angry X11 forwarding Problem

I have installed the Openssh into two AIX 5.2 servers and one server is working fine, but the other one giving the error message "The remote SSH server rejected an X11 forwarding request."
sshd_config file settings are same on both servers. Followed the all instruction given in the previous replies, but did not solve. Is there any other reason to getting this error ?

Thnx,
Pragathi
 
Old 01-04-2006, 01:09 PM   #8
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Might there be something in a .profile that manually sets the DISPLAY variable? Can't think of anything else, though using ssh -vvv might offer some more clues.
 
Old 01-10-2006, 12:24 AM   #9
pragathi
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
SSH X forwarding is working now. The problem was with a missing file set (AIX). After installing the downlevel file sets X forwaring started working. Thanks.
 
Old 11-02-2007, 07:43 AM   #10
rajeesh@hcleai.com
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by pragathi View Post
SSH X forwarding is working now. The problem was with a missing file set (AIX). After installing the downlevel file sets X forwaring started working. Thanks.

I have similar problem. Please let me know the file sets that you
have installed.


Thanks in Advance,
Rajeesh
 
Old 01-02-2008, 09:36 AM   #11
xlio
LQ Newbie
 
Registered: Jan 2008
Location: Lithuania
Distribution: Slackware, ArchLinux, AIX
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by rajeesh@hcleai.com View Post
I have similar problem. Please let me know the file sets that you
have installed.


Thanks in Advance,
Rajeesh
I encountered same problem some time ago. All configuration was correct but still X11 forwarding was not working.
After some googling I found out what in some cases (like mine) xauth executable was missing and therefore X11 forwarding could not work.

Next I installed X11.apps package from AIX instalation CD (it contains mentioned executable). After that X11 forwarding worked just fine.

Check your system, if xauth is not missing. Usually it is located in one of the following dirs:

ls –l /usr/bin/xauth /usr/X11R6/bin/xauth /usr/lpp/X11/bin/xauth

Last edited by xlio; 02-15-2008 at 07:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH X forwarding djgerbavore Linux - Networking 1 11-17-2005 09:40 AM
X forwarding via SSH bd1308 Linux - Software 4 08-30-2005 07:13 PM
Port forwarding for ssh Adriaan Linux - Networking 1 03-08-2004 09:11 AM
ssh and X-forwarding Björneborg Linux - Networking 2 02-19-2004 10:50 AM
ssh, and port forwarding Tricky Linux - Networking 3 01-06-2003 07:50 PM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration