LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   AIX (https://www.linuxquestions.org/questions/aix-43/)
-   -   IBM AIX root password Recovery steps (https://www.linuxquestions.org/questions/aix-43/ibm-aix-root-password-recovery-steps-938906/)

glendalebiker 04-09-2012 10:52 AM

IBM AIX root password Recovery steps
 
Hi,

I have read previous topics related with this issue, but in the last step when starting rootvg with shell,system prompts an error to terminal screen over n over again,I can't see whats written.

Our cluster based on AIX 5.3, I'm using a different AIX 5.3 CD then the one we installed, could it be the reason of error ? Do I have to use exactly the same version/revision disk I used in the installation ?

P.S: Installed OS is AIX 5.3 ---9, CD I'm using 5.3 ---7.

Thanks,

DukeSSD 04-09-2012 06:46 PM

Could be the old boot media, could be a bad console / connection, either way your old AIX level goes out of IBM support at the end of the month - Call IBM, get them to help get your system back up and help you upgrade to something still in support for a while longer than the next 3 weeks...

jefro 04-09-2012 07:03 PM

"With bootable media as the same version and level as the system, boot the system. The bootable media can be any ONE of the following: "

http://www-01.ibm.com/support/docvie...d=isg3T1000366

glendalebiker 04-10-2012 02:34 AM

Thanks for your responses. I would like to ask 1 more thing.

Server is IBM P series (520), with AIX 5.3 installed as I stated before. How about connecting directly from console port (HMC) ? I read somewhere if connected from HMC then I can edit etc/security/passwd ??? Delete root's encrypted password and it will become NULL.

Anyone tried this before ?

glendalebiker 04-11-2012 03:51 AM

HMC not working for root password recovery....

System OS level is IBM AIX 5300-08 (5.3.8.0). The OS CD/DVD I'm trying for boot is 5300-07.

Recovery steps are successful till last step "Access this Volume Group and start a shell" in Service Mode (with 5300-07 CD/DVD). But when system tries the mount rootvg it gives error, and prompt errors to terminal screen (we can't see the error clearly cause it keeps prompting over and over again).

Today I found 5300-08 disk and I will try with this,hope it works.

One of the questions I want to ask to you is the "mksysb". If we can have the current system's mksysb and copy it to a tape disk, can we also use this to recover root password ???

cliffordw 04-18-2012 02:16 AM

Hi there,

Regarding the boot from CD, the problem is most likely caused by a mismatch between the software on the CD and that in rootvg, which you are mounting. You can try and circumvent this by choosing "Access this volume group and start a shell before mounting the file systems" instead of "Access this Volume Group and start a shell". This way will be running completely from the CD. If this works, you'll have to mount the root filesystem (/dev/hd4) manually (say to /mnt), and the "passwd" command won't work as expected, so you will have to edit the /mnt/etc/security/passwd file manually. Set the password stanza for root to "KsXcTr5uZPZt6" (without the quotes), which is an encrypted version of "p@ssw0rd" (again without the quotes). Unmount & reboot, and you should be able to log in with this temporary password.

Regarding the mksysb, I'm not sure what you mean by a "tape disk", or whether your mksysb is currently on tape / CD / file on disk. If you have access to another AIX server, you can restore the /etc/security/passwd file from the mksysb to a temporary file, as follows:
Code:

cd /tmp
restore -xqvf your_mksysb_device_or_filename ./etc/security/passwd

You can then use the password stanza from this file in my steps above.

Alternately if you have access to the mksysb from the problematic server, you can boot & mount /dev/hd4 as above, and then use this restore command to restore the passwd file.

I hope this helps!

glendalebiker 04-23-2012 02:10 PM

@ cliffordw,

Thanks for the feedback. Forgive my laziness, I did try above last week.Started shell without mounting rootvg, then manually mounted hd4, I then edited /etc/security/passwd (password and lastupdate).

After changing the password I did sync and rebooted the server, it worked like a charm.

My OS is AIX 5.3 with TL8, you can use 5300-08,5300-09 or even 5300-07 CD to do this. Error I'm getting is due to incompatible version of the medium I'm using, as you also stated above. Although I's using same version CD 5300-08,it kept giving me that error.

Thanks for all your valuable inputs.


All times are GMT -5. The time now is 07:25 AM.