LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 07-08-2009, 07:41 AM   #1
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
How to find the number of physical processors in a AIX machine


Hi,

I need to find out the number of physical processors the AIX operating system is running in. Here i am referring to the physical processors in a system and not the number of cores. So if a processor is dual-core, number of cores will be 2 and number of physical processors will be 1.

I am looking for a way to determine this programatically. If there is no way of determining this programatically then a command output is also fine.

Can you please help me on this??
 
Old 07-09-2009, 01:16 AM   #2
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
prtconf | more
 
Old 07-09-2009, 01:30 AM   #3
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Original Poster
Rep: Reputation: 0
prtconf will show you the number of cores. It doesn't give any info about the number of CPU sockets(a.k.a physical procesors)
 
Old 07-15-2009, 07:59 PM   #4
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
No prtconf is correct

compare
# prtconf | grep Processor
or
# lsdev -Cc processor

with the value of:
# bindprocessor -q

lcpu in the following shows the same result
# sar 1 1
or
# lparstat

Last edited by baznz; 07-15-2009 at 08:15 PM.
 
Old 07-16-2009, 12:30 AM   #5
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Hi baznz,
i don't know which version u r using. I am using AIX 5.3 here and in that

prtconf | grep Processor
or
# lsdev -Cc processor will give the same output which is the number of cores and

# bindprocessor -q
or
# lparstat will give the same output which is the number of logical processors.

I am talking about the physical processor count(number of sockets) here and not any of the above.
 
Old 07-16-2009, 06:10 AM   #6
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
Its helpful to post the output of those commands so we can see what you seeing.

If your logical processors is the same value as the output in prtconf, then you dont have multi threading turned on.
 
Old 07-16-2009, 06:31 AM   #7
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Original Poster
Rep: Reputation: 0
I have pasted below the outputs of all commands. The machine runs a PowerPC_POWER5 processor as u can see from the output below and it is a dual-core processor.

% prtconf
/usr/sbin/prtconf[156]: /usr/lib/boot/bin/dmpdt_chrp: cannot execute
System Model: IBM,9110-510
Machine Serial Number: 062D7EA
Processor Type: PowerPC_POWER5
Number Of Processors: 2
Processor Clock Speed: 1500 MHz
CPU Type: 64-bit
Kernel Type: 64-bit
LPAR Info: 1 06-2D7EA
Memory Size: 3808 MB
...............
................
...............
+ L2cache0 L2 Cache
+ mem0 Memory
+ proc0 Processor
+ proc2 Processor

% lsdev -Cc processor
proc0 Available 00-00 Processor
proc2 Available 00-02 Processor

% lparstat

System configuration: type=Dedicated mode=Capped smt=On lcpu=4 mem=3808

%user %sys %wait %idle
----- ---- ----- -----
3.5 10.2 8.7 77.5

% bindprocessor -q
The available processors are: 0 1 2 3
 
Old 07-16-2009, 07:00 AM   #8
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
Well im not sure why my original post didn't answer your question. Prtconf is telling you that you have two physical processors which are multi threaded hence you have 4 logical processors.

Perhaps you are getting confused because IBM uses different terminology to Intel regarding cores. In System P cores are the number of physical processors.

Last edited by baznz; 07-16-2009 at 07:04 AM.
 
Old 07-16-2009, 07:22 AM   #9
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Original Poster
Rep: Reputation: 0
hi baznz,

the count 2 here is not the physical processor count, it is the count of the number of cores.
The term physical processor and cores are two different things.
 
Old 07-16-2009, 08:49 AM   #10
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
I think you taking me for a ride, im not wasting any more time with this forums.
 
Old 07-16-2009, 07:22 PM   #11
DukeSSD
Member
 
Registered: Sep 2007
Posts: 90

Rep: Reputation: 20
Hi shawshank, I don't mean to bang on but I think baznz is correct and there is simply a terminoligy problem here.

power5 processors only come in 2 way and 4 way modules. For "way" read CPU.

Your system has one 2 way processor, one unit comprising of two physical processors in the same chip.

If you look inside and pull off the biggest heatsink you can find (please do not do this) then you will find one chip. So you could say it has one processor and be correct but that "processor" module or chip - lump of silicone - has 2 cpus on it, therefore two central processing units or "processors"...

This one chip is a 2 way processor, it has 2 cpus on the one chip and each one is a processor (cpu) in its own right, they do share cache and stuff but you have a single "chip", two processor system.

If you want to get into the dual / quad core stuff then as far as IBM and power machines terminoligy is concerned then a core is a processor.

Again as baznz said with the power5 multi threading capabilities a single cpu will appear as two logical processors to AIX because the system (hypervisor) can process two threads (nearly) simultaneously and so can present the OS with two logical procassors for each physical CPU, or "core" as you seem to be calling them.

So could you please restate your question. Do you need to find the number of processor modules, be they 2 or 4 way, in your system?

As pprevoo said in your similar thread over on unix.com can you grep the lscfg -vp output for WAY or PROC, it should be down at the end in the platform stuff and should also be listed on all LPARS - which may give you a problem because you may have a single virtual cpu in your partition but it will show all the physical processors in the system...

Good thread though and I'm interested in helping you resolve the problem.

HTH.
 
Old 07-16-2009, 07:54 PM   #12
baznz
LQ Newbie
 
Registered: Oct 2005
Posts: 19

Rep: Reputation: 1
Nice post Duke.

His output already shows everything we need to know.

System Model: IBM,9110-510
Machine Serial Number: 062D7EA
LPAR Info: 1 06-2D7EA

type=Dedicated

His running a 510 they dont come larger then a two way. Also he is using one partition looking at the name of the LPAR, its the default system partition. Also the fact that he is running dedicated CPU, with the maximum amount of CPU that that box can take.

If he really needs to know the physical layout of the chips, then he should call IBM to open up the machine for him.
 
Old 07-17-2009, 12:48 AM   #13
shawshank_blr
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Original Poster
Rep: Reputation: 0
HI,

sorry for the ocnfusion here with terminology. Actually what I wanted to figure out here was the number of 'chips' in the AIX machine.

According to DukeSSD...
""""So you could say it has one processor and be correct but that "processor" module or chip - lump of silicone - has 2 cpus on it, therefore two central processing units or "processors"...""""

What I want to figure out is also the number of "lump of silicone" inside the box.

Is there a way to find this out accurately??...Thnx for ur help...
 
Old 07-17-2009, 10:08 PM   #14
DukeSSD
Member
 
Registered: Sep 2007
Posts: 90

Rep: Reputation: 20
Hi, in your box, 1

As I said, p5 come in 2 or 4 way so you have one 2 way chip.

1 chip with two processors (cores) on it.

The only way to determine if any system has two or four way chips is to check the order (the sales order where the specification is listed) to see if it is a Q model (Q, like the p550Q, stands for Quad because it uses quad core, or quad processor chips) or to check the lscfg -vp output for WAY or PROC and see if it posts 2-WAY or 4-WAY (or you could probably go through the pain of looking up the part or ccin numbers and then checking infocentre to see the description of that part.

baznz,
what if you have a 2 processor system but no POD code, only one of the two would come active!

shawshank, I presume you know about CUoD activation and have activated your other processor / core with your POD code 4DDD61B456E5D684PODD0000000200413C

http://www-912.ibm.com/pod/pod

Someone else is after the same info:

http://www.ibm.com/developerworks/fo...hreadID=268759

Last post:

I've checked is on LPARs on two servers - p55A and p570 - both servers 8 CPUs and seems that in p55A there are 2 4-core CPUs and in 570 4 2-core CPUs.

$ lsattr -El sys0 -a modelname
modelname IBM,9117-570 Machine name False
$ lparstat -i|grep ^Active\ Phys
Active Physical CPUs in system : 8
$ lscfg -vp|grep WAY
2-WAY PROC CUOD :
2-WAY PROC CUOD :
2-WAY PROC CUOD :
2-WAY PROC CUOD :
$ lscfg -vp|grep proc
proc0 Processor
proc2 Processor
proc4 Processor
proc6 Processor
$



$ lsattr -El sys0 -a modelname
modelname IBM,9133-55A Machine name False
$ lparstat -i|grep ^Active\ Phys
Active Physical CPUs in system : 8
$ lscfg -vp|grep WAY
4-WAY PROC CUOD :
4-WAY PROC CUOD :
$ lscfg -vp|grep proc
proc0 Processor
proc2 Processor
proc4 Processor
proc6 Processor
$

So the 570 has dual core and the 9133-55A is a p550Q - quad core processors / quad CPU chips.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to find Machine serial number of solaris machine? adastane Solaris / OpenSolaris 15 01-09-2012 08:29 AM
How to find the number of physical processors and architecture in a hp-ux machine shawshank_blr Other *NIX 3 07-24-2009 09:24 AM
How to find out if my RedHat machine is running both processors? jleavitt Red Hat 4 09-10-2004 02:35 PM
Find Serial Number of Machine zael Programming 4 10-27-2003 12:39 PM
how do i find number of cpus in one machine? doublefailure Linux - General 3 03-26-2002 02:52 PM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration