-   AIX (
-   -   Force delete key to work in aix ksh ? (

Vilius 09-09-2007 03:18 PM

Force delete key to work in aix ksh ?
I'm using AIX console over putty.
I'm not very happy with default ksh command editing capabilities so I forced insert mode, arrow keys and command history by issuing:

set -o emacs
alias __D=`echo "\002"`
alias __C=`echo "\006"`

in emacs mode history works using ctrl+p, so only thing missing is del key-
How to force del key to work as it should ?


ilikejam 09-09-2007 05:26 PM


Have you tried

stty erase ^?

stty erase ^H

Vilius 09-10-2007 06:13 AM

neither of them works, just prints out ~ symbol.

Rooster 09-24-2007 03:35 PM

Try "stty erase ^?"


To get the ^? part, you need to actually press your backspace key.

So literally type "stty erase <backspace>" and it will slap in the ^?
Then just press enter and you will have backspace.

unfortunately this does not appear to work in .profile startup. I know, annoying but I have already developed the habit of typing "stty erase <backspace>" when I first login to an AIX box via putty.

The other option is to use Exceed, which sets it all up nice and neat for you from the get-go.

-The Rooster

DukeSSD 09-25-2007 04:45 PM

Have you played with the PuTTY "configuration > keyboard" settings?

I don't use emacs but have found the delete key does not work in AIX, nor does the backspace until you change the setting from control-? to control-H.

Once you get used to using backspace instead of delete all is well.

Please let me / us know your results.

Vilius 10-15-2007 12:47 PM

thanks guys, but my problem was to get delete key working, not backspace - I managed backspace to work using putty keyboard settings as DukeSSD mentioned. I can live with that(backspace) but I wanted all the keys to work 'properly'.

vchalam777 04-29-2011 09:53 AM

delete char
Not sure if the order in your .profile matters

Change the order from
stty erase ^?
stty erase ^h


stty erase ^h

stty erase ^?

DukeSSD 04-30-2011 07:46 PM

As far as I have ever known or found on AIX, and I only use ksh and the vi editor, the Del key simply does not work and cannot be made to work.

HTH but please let us know if you find a way.

DukeSSD 05-02-2011 05:59 PM

OK, just fired up my old 5.3 test box and the CDE, tried with dtterm and xterm on the native keyboard and console.

The Del key produces some strange results both on the ksh command line and in vi but all seem to result in a beep from the system and in the session none relate to deleting the character at the cursor, so as mentioned above, I don't think AIX supports the Del key in any obvious or known format.


crabboy 05-03-2011 11:15 AM

I've never used the delete key in all my years using AIX. Using vi mode in the shell, you just don't need it.

I did notice while trying to use it that it did produce odd results as DukeSSD suggested. For me it changed the case on the character it was on or made the entire current word uppercase.

trbennett48 05-11-2011 09:36 AM

I have no problem using my delete-key.

In the PUTTY Terminal-Keyboard configuration:
- In the "Backspace Key" section, I selected "Control-H"
- In the "Home and End Keys" section, I selected "Standard"
- In the "Function Keys & Keypad" section, I selected "Xterm R6"


All times are GMT -5. The time now is 05:36 AM.